[Stable Update] 2022-12-06 - Kernels, Mesa, Plasma, Cinnamon, Nvidia, LibreOffice, Pipewire, Virtualbox

1.I dont understand this Mesa Hardware Acceleration thing, isnt Mesa for gaming?

2.Im using Shotcut Video Encoder with libx264 codec, does it affect me? But i have deselect “use Hardware encoder” because it reduced the quality of the exported video, should i expect longer video convert progress after the update?

  1. I have a nvidia card, is this mainly a AMD only issue?

the same situation.
systemctl --user restart pulseaudio.service
restores sound


Can’t boot after reboot on my laptop (haven’t checked my PC at home yet). Was able to restore using timeshift-btrfs.

Had this message during failed boot:

I believe libcrypto3 is from openssl, and I recall installing openssl3-git to resolve paru and other stuff not being able to connect because of librecypto.so.3 being missing. Other than that, I run kernel 6.0 and that was mentioned to be a possible issue.

After work, I’ll remove openssl3-git before trying to upgrade again, just in case that matters.

This is my system info in the timeshift snapshot (before upgrade, booted to kernel 5.15, just in case, since I have work) I’ve restored to, in case it’s relevant.

System Info

Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2022-12-06_09-26-19/@/boot/vmlinuz-5.15-x86_64
root=UUID=c7af1d31-23be-4a82-8c00-cef723969280 quiet
resume=UUID=9a308197-d050-4ad5-8df0-05c7ba0010a7 udev.log_priority=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 80E4 v: Lenovo G40-80
serial: Chassis: type: 10 v: Lenovo G40-80
Mobo: LENOVO model: Lenovo G40-80 v: NO DPK serial:
UEFI: LENOVO v: B0CN95WW date: 08/03/2015
ID-1: BAT0 charge: 9.7 Wh (70.8%) condition: 13.7/28.5 Wh (48.1%)
volts: 16.2 min: 14.4 model: Lenovo IdeaPad type: Unknown serial:
status: charging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial:
charge: 55% (should be ignored) rechargeable: yes status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard
serial: charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2461 high: 2515 min/max: 500/2700 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2506 2: 2494 3: 2515
4: 2330 bogomips: 17565
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: AMD Sun LE [Radeon HD 8550M / R5 M230] vendor: Lenovo
driver: radeon v: kernel alternate: amdgpu arch: GCN-1
code: Southern Islands process: TSMC 28nm built: 2011-20 pcie: gen: 2
speed: 5 GT/s lanes: 4 link-max: lanes: 8 bus-ID: 04:00.0
chip-ID: 1002:666f class-ID: 0380 temp: 43.0 C
Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 1-6:4
chip-ID: 5986:055d class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting,radeon
alternate: fbdev,vesa dri: iris,radeonsi gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1487 built: 2013 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 5500 (BDW
GT2) direct render: Yes
Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Sound API: ALSA v: k5.15.78-1-MANJARO running: yes
Sound Server-1: JACK v: 1.9.21 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.59 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac:
Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b4 class-ID: 0280
IF: wlp3s0 state: up mac:
IF-ID-1: surfshark_ipv6 state: unknown speed: N/A duplex: N/A
IF-ID-2: surfshark_tun state: unknown speed: 10 Mbps duplex: full mac: N/A
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-7:5 chip-ID: 8087:07dc class-ID: e001
Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Local Storage: total: 689.33 GiB used: 407.39 GiB (59.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD5000LPCX-24C6HT0 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial:
rev: 1A02 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SSD PLUS 240GB
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 04RL scheme: GPT
ID-1: / raw-size: 210.51 GiB size: 210.51 GiB (100.00%)
used: 151.45 GiB (71.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 210.51 GiB size: 210.51 GiB (100.00%)
used: 151.45 GiB (71.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 210.51 GiB size: 210.51 GiB (100.00%)
used: 151.45 GiB (71.9%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 12.77 GiB used: 3.46 GiB (27.1%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
System Temperatures: cpu: 46.0 C mobo: N/A gpu: radeon temp: 44.0 C
Fan Speeds (RPM): N/A
Processes: 346 Uptime: 20m wakeups: 9 Memory: 11.6 GiB
used: 6.22 GiB (53.6%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2439
pm: pacman pkgs: 2408 libs: 548 tools: pamac,paru,yay pm: flatpak pkgs: 31
Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.23

Edit: Confirmed: happens on both my PC and laptop, but uninstalling openssl3-git before upgrading prevents the issue.

strange that after this upgrade my intel NUC can’t display, it will flash a purple screen and then goes blank. Will think to re-install the OS :cry:

update: the display works after I choose “fallback initramfs”, need some help ! I’m not familiar with it.

Affects only hardware-accelerated video decoding. Encoding is unaffected.

Nvidia and Intel GPUs are unaffected.

1 Like

Before running update, modified /etc/pacman.conf to ignore package update for mesa as follows:

IgnorePkg   = mesa mesa-demos mesa-vdpau lib32-libva-mesa-driver lib32-mesa lib32-mesa-demos lib32-mesa-vdpau libva-mesa-driver lib32-vulkan-intel lib32-vulkan-radeon vulkan-intel vulkan-radeon 

Update completed without problems.

Running with:

mesa 22.2.3-1
mesa-demos 8.5.0-2
mesa-vdpau 22.2.3-1
lib32-libva-mesa-driver 22.2.3-1
lib32-mesa 22.2.3-1 
lib32-mesa-demos 8.5.0-1 
lib32-mesa-vdpau 22.2.3-1
libva-mesa-driver 22.2.4-1 
lib32-vulkan-intel 22.2.3-1
lib32-vulkan-radeon 22.2.3-1
vulkan-intel 22.2.3-1
vulkan-radeon 22.2.3-1

No problems here in Plasma 5.24.7 LTS with the above-quoted bump to KDE Frameworks. Just thought I’d mention this, for those who are also still using the LTS version of Plasma. :slight_smile:

The only small surprise I had with this update — but this was quickly remedied — was that for some mysterious reason, the Telegram Desktop icon had vanished from my Favorites section in the Application Dashboard. But that was of course easily put back. :wink:


ERROR:pulse_util.cc(350)] pa_operation is nullptr.

I found out that the problem occurs in the WaitForOperationCompletion function

This is fixed with 390.157-2

Thank you, I appreciate. RDP is quite important to my use case.

1 Like

Great, thank you @greysoft !

I am using pipewire and the same situation, restarting the services fixes temporally the audio as it crash again later

1 Like

I can confirm 390.157-2 fixed the issue for me, thank you very much @philm

Indeed. As an aside, I found out that the problem is caused by plugging in my second monitor that had a different refresh rate. Removing it makes the icons, font, aurorae window border etc work well. But I need to use my second monitor so Plasma LTS it is.

I had the same behaviour with Gnome/X11, but this has happend before on other major updates too.
You don’t need to do a hard reset in these cases: please switch to another Terminal session (i.e. Crtl+Alt+F3). There you can check if pamac or pacman is still updating and when there is no further activity, you can do a sudo reboot.

Would this need to be done for the lib32 version of the package, as well? If so, would you have a link to its repo? (I looked but I couldn’t find it…)

I am with Ryzen 5800H running only with integrated AMD video, the problems with wake up from sleep actually started after update to kernel 6.0.8-1. I moved to 6.0.5_rt14 and the problem is gone. On everything was working. I can confirm that with 5.15 LTS it is working correctly.

The openvpn client in GNOME is not working anymore. It keeps asking me for my password, but never connects. The same configuration works when I run it from the terminal.

it unfortunately also affects encoding.

For now it looks like it hasn’t been disabled for on lib32-mesa since I also couldn’t find a repo for it.
If/when it is disabled the repo with the package should be in Multilib · GitLab

1 Like