[Stable Update] 2022-12-06 - Kernels, Mesa, Plasma, Cinnamon, Nvidia, LibreOffice, Pipewire, Virtualbox

Test to make sure it’s actually working though, not sure if some part of it was disabled anywhere else.
I unfortunately can’t test it myself.

1 Like

Had just updated, which included firefox and kde (wayland). Firefox started to notify “Restart to keep using”, i then closed firefox and kwin_wayland dumped its core and restarted, just be aware that after the update kwin_wayland may crash (and including all applications that rely on it, like konsole)
(amd cpu & amd gpu)

1 Like

Firefox still crashing on Nvidia with Performance/Hardware acceleration “on” when opening Downloads Dialog, So still need to turn off Performance settings.

1 Like

Well you can always follow our gitlab: [pkg-upd] 22.2.4-1 (e4fbdd70) · Commits · Packages / Extra / mesa · GitLab

I triggered a rebuild of the stable ISOs here: Release 202212061117 · manjaro/release-review · GitHub

1 Like

All went pretty smooth. The Magic Trackpad did not want to work with bluetooth. So I restarted the bluetooth service systemctl restart bluetooth.service and then checked the status systemctl status bluetooth.service and it showed me:

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: active (running) since Tue 2022-12-06 13:11:14 CET; 5s ago
       Docs: man:bluetoothd(8)
   Main PID: 14681 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 76839)
     Memory: 1.1M
        CPU: 103ms
     CGroup: /system.slice/bluetooth.service
             └─14681 /usr/lib/bluetooth/bluetoothd

dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/aptx_ll_0
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/aptx_ll_duplex_1
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/aptx_ll_duplex_0
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/faststream
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/faststream_duplex
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSink/opus_05
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/opus_05
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSink/opus_05_duplex
dec 06 13:11:14 roland-xps bluetoothd[14681]: Endpoint registered: sender=:1.143 path=/MediaEndpoint/A2DPSource/opus_05_duplex
dec 06 13:11:14 roland-xps bluetoothd[14681]: src/device.c:set_wake_allowed_complete() Set device flags return status: Invalid Parameters

I do not remember seeing that error before but I am not 100% sure if it is a new error as everything always worked. Now I turned on the Magic Trackpad and noticed it started working.

Checking the bluetooth status again, one more error was added to the output, the rest is all the same:

dec 06 13:11:21 roland-xps bluetoothd[14681]: src/profile.c:record_cb() Unable to get Hands-Free Voice gateway SDP record: Host is down

I get the idea this last error is because of my bluetooth headphones are off.

The trackpad continues to work so that kind of sorted itself out.

The only problem I still have since the previous update, the Hotspot functionality no longer works is still present. I already reported that in the previous release:

Tested. Works! :grin:

❯ mpv --hwdec=auto "Lets not worry too much about what file was used :P"
 (+) Video --vid=1 (*) (h264 1920x804 23.976fps)
 (+) Audio --aid=1 (*) (aac 6ch 48000Hz)
 (+) Subs  --sid=1 'Does it really matter that much.srt' (subrip) (external)
[vo/gpu/wayland] GNOME's wayland compositor lacks support for the idle inhibit protocol. This means the screen can blank during playback.
Cannot load libcuda.so.1
Using hardware decoding (vaapi).  <---
AO: [pulse] 48000Hz 5.1 6ch float
VO: [gpu] 1920x804 vaapi[nv12]
AV: 00:00:42 / 01:51:49 (1%) A-V:  0.000

Not entirely sure why it tried to load libcuda :thinking:

❯ pacman -Q | grep cuda | wc -l
❯ pacman -Q | grep nvidia
mhwd-nvidia 525.60.11-1
mhwd-nvidia-390xx 390.157-1
mhwd-nvidia-470xx 470.161.03-1

Thanks Philip, thanks a lot ::

My concern was support for it being disabled on other packages other than mesa (Fedora is know to disable support for some things on multiple places), I linked to that package’s repo on my original comment on the issue when I suggested the workaround :wink:.

I’m gonna repeat the question I originally tagged you on, “any chance of this being reverted to being enabled as it’s on Arch?”


How to re-enable functionality?

After todays update cant login to gnome wayland session. It throws me back to login screen. Haven’t tried x.
Xorg crashes as well.
Core control window popped up but gnome tells me to log out because something went wrong.

After the upgrade my sound stopped working.
I already tried to downgrade pipewire, alsa-card-profiles and libcamera but it still doesn’t work (I’m always restarting after any change). I also tried with an older kernel but no success.
Pulseaudio looks normal. It recognizes the different output devices and I can change volume but no sound comes out of my laptop.
I’m using cinnamon desktop env btw.
Does anyone else have an idea which upgrade could have caused my sound not working and what I could do to fix it?

[UPDATE]: Following the advice mentioned down below, I can get sound for a while again by restarting the pulseaudio service. But for example pluging in headphones or just changing the volume will make it not work again. My laptop is currently almost unusable for me like this (it’s my work laptop and I need video calls etc.)


I reported that the NVIDIA 525 update made my, and others’, external display unusable in the 2022-12-01 Testing Update thread and the issue has not been resolved. The only solution for now is to downgrade to 515 or to ensure that the built-in display remains enabled at all times, which is a major regression.

The upstream project Mesa disabled those codecs by default. Arch decided to ship those codecs still. Others followed the suggestion by upstream and kept them disabled.

The assumption that patents are already paid by the hardware manufacturer of your graphics card is wrong. I can’t get into specifics, but there are plenty of legal games that are played by hardware vendors to avoid paying those fees.

One example is Apple. If you ever bought a product from them you will have a separate position on your bill stating fees for proprietary codecs of around 5 €. This way you as the customer pay the fee so Apple can provide you with that user experience. You can also read this: Apple-supported H.264 standard gains free license for Internet video use | AppleInsider

As a distribution, we have to ensure we don’t have a way to enable a complete codepath for such codecs to avoid the legal risks. There are a number of ways to approach this, but it’s important that Manjaro itself cannot provide a complete path to access hardware acceleration for these codecs either.

So to answer your question: scroll up as it might have been answered already.


Did the full update and restarted: Absolutely no issues for me, everything seems to be working perfectly… includes system suspend, monitor power saving, and playing Youtube videos. I’m also an amdgpu / Mesa user so I was concerned at first… KDE here but still on X11 instead of Wayland, wonder if some of the issues mentioned here are WL specific which would mean I did well not to switch yet.

Is this Gentoo?
It’s not a solution.

1 Like

I don’t think that is necessary as Manjaro isn’t based in the US:


can I ask, was there linux 6.0 in this stable update ?
I updated but my system shows kernel 5.15.81-1-MANJARO.
I just wanna know if I had any problems in my system ?

1 Like

Is plasma freezes fixed here? :slight_smile: