[Stable Update] 2022-12-06 - Kernels, Mesa, Plasma, Cinnamon, Nvidia, LibreOffice, Pipewire, Virtualbox

Which encoders?

x264 and x265 use the CPU.

For GPU encoders, Intel and Nvidia provide their own encoders for AVC and HEVC.

It affects the amd hardware encoders for both h264 and h265 (as well as the hardware decoders), intel and nvidia are unaffected for any of it as far as I know


Like I said though I seem to be getting the same video decoding for both h264 and h265 on amdgpu, no extra CPU being used during playback nor any performance / quality difference. I wonder if this issue is either for older or newer card models. In any case I hope the team can fix it soon for everyone affected, it sounds like a worrying limitation.

Same here. Audio test (front left, front right) after a fresh boot is fine.
But when playing a video stream in firefox oder chrome, there is no audio and the audio test doesn’t work anymore.


So since today you can say, AMD GPU’s are no longer the recommend Hardware when it comes to Linux :frowning:

mesa is a split package that contains the following:


mesa-demos and the lib32 packages are not related.


I read somewhere in this forum that it seems to be a kernel problem. I was on the newest LTS and change to 6.0 and it was solved. When 6.1, which is supposed to be LTS I will change to that one


Thank you @salvaram - that did the trick!

After update CPU temperature is a little high by using any browser like Firefox or Chromium. Before the update is was working without fan unless I open YouTube video. I thought it may be mesa codec issue as other are mentioning this thread so install the mesa-git and lib32-mesa-git but no avail.

Dell inspiron 155505 AMD Ryzen 7 4700U Radeon shared graphics card.


@khandakershahi and @pheiduck I notice you’re both using AMD GPUs. This is very likely due to the change in mesa. :frowning:

@MirceaKitsune even with a 4K video in YouTube (watching it at the maximum resolution), you’re still not seeing any extra CPU usage or temperatures? Even if you let the video play for a while?

I have a problem with xfce screenshooter after this update.
I am trying to take a screenshot of a selected area of the top application window but it is ignoring the application windows and only seeing the wallpaper on my desktop.

I’ve reinstalled screenshooter and tried taking screen shots of different application windows but it only seems to see the desktop wallpaper.

Is anyone else experiencing this odd behaviour?

Plasma freezes will NEVER be fixed :slight_smile:

Am I the only one whose installation effectively crashes because it cannot download linux 6 headers? How do I convince pamac to try a different mirror after it fails to complete a download after 12 hours?

I have no issue with AMD GPU and mesa 22.2.4. :man_shrugging:
Firefox runs fine with 4k Youtube when using default hardware acceleration. No high temperature, less than 10% GPU usage and CPU usage.

1 Like

Hm, I have a bug with qemu, my vms won’t boot

Seems a Kernel bug, because downgrade of qemu does not change the behavior


I have 2 core amd laptop with amd igpu. If you have any tests in mind I can do them before and after update.

Let this video play for at least 5 to 10 minutes, longer if possible.

(Open it in YouTube’s website, not in here!)

Preferably in fullscreen, or at least in “theater mode”.

Do not let it “auto-select” the resolution.

Select the 4K 60fps option (which is the highest resolution and framerate to choose from in the viewing options.)

Keep an eye on CPU temperatures (all cores and/or composite) throughout.

Keep an eye on CPU usage (all cores and/or composite) throughout.

Repeat the same exact thing after applying the Stable Updates and rebooting.

(Make sure to view the video in the same exact way before and after.)

UPDATE: See my post further down. @Begemoth made a good point, in which YouTube videos are unlike to be AVC or HEVC anymore, as they shifted towards more open video codecs now.

Longer than 10 minutes in fullscreen then “theater mode”.

AMD CPU usage and temperature:

AMD GPU usage and temperature:

1 Like

Do you know if this was the same before the mesa update?

I think it’s the same as before.