[Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt

I get a strange problem with Plasma/KDE after update!
After some hours when a notification appears, it makes a blank/black rectangle and screen get stuck but I still can type and run commands, just screen doesn’t show anything and keeps frozen.

Does anyone have same problem? How can I fix it?

DE: KDE 5.99.0 / Plasma 5.26.3
WM: KWin
WM Theme: Kvantum

If anyone else has this problem, my temporary solution is to open a terminal by pressing Ctrl + Alt + T shortcut, wait for enough long time so that you make sure terminal is opened (screen doesn’t show anything). Then type following command to restart plasma:

killall plasmashell && kstart5 plasmashell

I’ve seen what seems like the same problem occasionally over recent weeks (so probably not directly related to this update). I haven’t managed to confirm a pattern around what’s triggering it, but it seems to happen when I’ve been running darktable (photo processing program) for a period of time.
Your way out seems like it’s preferable to what I’ve been doing (rebooting using SysRq keys).

1 Like

This update breaks something either tied to monitor resolution, or window rules.

Here’s the chain of events for me. Yesterday I installed the latest update, and after restart I noticed that programs don’t start with maximized horizontally/vertically as instructed. So after not finding a fix to it, I decided to restore a previous Timeshift.

This somehow broke my grub… “grub debug malloc not found” error on startup. Again I tried anything I could find on these forums, got on a live usb and used chroot to do grub-install and update-grub, and even though it said it was reinstalled, the problem was still there.

So eventually I reached the nuclear option and wiped my boot drive and reinstalled manjaro, the latest Plasma stable version from the site, the one from August 26th. After installation was done, I fiddled with it a bit and I gave it a “pamac update”. And the problem with the window rules was back. I’ve tried restoring previous Timeshifts again, different ones, but somehow my booting was broken again and had to reinstall manjaro again…

So right now I’m using Manjaro 2022-08-26
KDE 5.24.6
KDE Frameworks 5.96.0
Qt Version 5.15.5
Kernel 5.15.60-1-MANJARO (64-bit)
Graphics Platform X11

Hardware: AMD 5800X + GeForce 2070 Super + 32GB RAM, monitors 1440p primary and 1080p secondary

If on this fresh manjaro install, I do the latest update, window rules get broken. Maximize horizontally/vertically gets broken. Even without window rules, some programs don’t want to maximize when double clicking the top bar. Some notifications appear close to the middle of the screen (lower and to the right compared to center), so I think the resolution is seen as much smaller than it is. If I open firefox on the 1440p screen, it still gets “maximized” to 1080p.

So Manjaro stable release 2022-08-26 + update 2022-11-14 cause problems with resolution and window rules. I suspect something the nvidia drivers are at fault, the linux 515.65 that come with the stable release are OK, the update bumps them to 520.56.06 and I think that’s the issue.

I could try to do the full update while ignoring linux515 and linux515-nvidia, and if any of you got any other suggestions of apps to ignore… maybe we can single out the culprit.

Oh and one more question… What happened to Steam, doesn’t it come preinstalled in Manjaro anymore?

1 Like

I had the same problem. I resolved changing the theme.

I installed Black Maia which is compatible with GNOME 43.

A post was split to a new topic: Libcrypto.so.3 after stable update

Most of my OpenVPN connections stopped working in NetworkManager. There is no any information about the reasons in the log:

nmcli c up "Germany, Frankfurt S3"
Error: Connection activation failed: Unknown reason
Hint: For more information, use «journalctl -xe NM_CONNECTION=d290757d-a374-49a4-9c4e-48060f111cab + NM_DEVICE=wlp2s0»

And after the hint using:

bigpc NetworkManager[2737]: <warn>  [1668938718.2041] vpn[0x5566810ec960,d290757d-a374-49a4-9c4e-48060f111cab,"Germany, Frankfurt S3"]: dbus: failure: connect-failed (1)

openssl-1.1 is installed. Do anybody know how to fix it?

Check the journal, there will be an error message.

journalctl -u  NetworkManager -t nm-openvpn

You might want to add -b and --no-pager

Since it is probably because you use ancient, insecure chipers, update your config. You can find multiple topics in the forum about this.

Also do not downgrade, it will just delay the time until you will need to update your config anyway. And maybe leaves you with the next update without a networking at all.

Ok, thank you, it’s more comprehensible:

OpenSSL: error:0A00018E:SSL routines::ca md too weak
nm-openvpn[35695]: Cannot load certificate file

And then you copy paste that error into google and go to first superuser-com result.

A recent openssl update is enforcing higher cert signings. Check with your vpn provider to reissue any depreciated certs associated with your profile and then regenerate openvpn configs.

Do NOT follow any silly advice by disabling all security by adding something like “DEFAULT:@SECLEVEL=0” to your configs. :roll_eyes:

I have a problem with wake up from suspend. Normally My Laptop Dell Inspiron 15 5505 ADM Ryzen 7 4700u has no S3 but I able to fix it by DSDT modification. Now after the update 3 times after suspend no display and I got this error message.

What went wrong I can’t figure it out.

Nov 20 10:36:48 PM kernel: [drm:process_one_work] *ERROR* ib ring test failed (-22).
Nov 20 10:36:48 PM kernel: amdgpu 0000:03:00.0: [drm:amdgpu_ib_ring_tests [amdgpu]] *ERROR* IB test failed on gfx (-22).
Nov 20 10:36:48 PM kernel: Non-boot CPUs are not disabled
Nov 20 10:36:20 PM nmbd:   register_name: Failed to send packet trying to register name WORKGROUP<1d>
Nov 20  8:49:54 PM kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, but soft recovered
Nov 20  8:49:44 PM kernel: amdgpu 0000:03:00.0: amdgpu: 	 RW: 0x0
Nov 20  8:49:35 PM nmbd:   Packet send failed to ERRNO=Network is unreachable
Nov 20  6:44:56 PM systemd-coredum: Process 1624 (goa-daemon) of user 1000 dumped core.

Had to refresh keys before being able to proceed with update.

Added “libx11 1.8.2 causes firefox to freeze” to the Known issues and solutions

1 Like

I am also with night light broken after update (on intel though), did you managed to fix it?

Unable to switch to my Creative usb headset after the latest update. It is still detected by the kernel, but it does not show up as a device in volume control any more.

After the update and a reboot, Chrome started rendering “big”–the wrong display scaling was being used. I had spent many hours trying to get scaling to work properly in Manjaro when using Wayland. The SDDM logon screen scaling is a persistent issue. But I was surprised to see Chrome rendering all of a sudden “broken”. Knowing I had a similar issue with Firefox previously, I checked out Firefox. It too, was all of a sudden “broken”–rendering things way too large.

In the case of Firefox, previously, I set a configuration flag in the about:config page. I set layout.css.dpi to 256 (my monitor’s physical DPI) and layout.css.devPixelsPerPx to 2.

I had also tried setting various things in various configuration files. One thing I set was in /etc/environment: GDK_SCALE=2.66.

Ok, so back in Firefox, I reset layout.css.devPixelsPerPx to 1. And boom! Firefox was “fixed”. Ok, this is definitely a scaling issue that’s been “fixed” in one of the updates. Unfortunately, there’s no such flag like that in Chrome.

So, I backed out the GDK_SCALE variable I set in /etc/environment and rebooted. But, upon restart, typing the command echo $GDK_SCALE, I received back 2.00. Where was this being set??? Apparently, this was put in a configuration file in my local home directory–though, I did not set this, and this is why scaling probably never worked the way I thought it should–“my settings” were being overridden by the entry in a local configuration file in my Home directory which I never set! The file is ~/.config/plasma-workspaces/env/10-hidpi.sh, which had export GDK_SCALE='2.00' inside it. So I set that line to export GDK_SCALE='1.00', reboot, and now Chrome was fixed too.

1 Like

libcrypto.so.1.1 breaks grub generation with update-grub failing too…Installing the recommended package fixes it too…

Firefox with graphic card (hardware) acceleration fails to process clicks on some websites. If you run it from the command line you get a message :slight_smile: :

GFX1-]: glxtest: VA-API test failed: process crashed. Please check your VA-API drivers.

Anyone knows how to solve this without disabling hardware acceleration?

1 Like

I have a reoccurring but kind of not properly reproducible issue:

When I use the three finger swipe gesture to switch Desktops on Gnome, sometimes the whole system freezes for a few seconds.
Though it’s not always the reproducible e.g. if I just rebooted my system it mostly works fine.
E.g. I have Xournal++ on desktop 1 and Firefox on desktop 2, after a clean restart the gesture works flawless, but most of the time when I already worked for a few hours or so(possibly switched to standby a couple times) my entire system freezes for at least 5 seconds or so, this is especially annoying when I accidentally trigger the gesture while navigating with my fingers.
The issue persists if I close Xournal++ or/and FF so I dont think it’s entirely their fault/if at all.

My system:
CPU: AMD Ryzen™ 5 5500
GPU: AMD Radeon™ Graphics
RAM: 8,0 GiB
Note: This issue was deffenitly not present before though the Xournal++ Version updated two days prior.