[Stable Update] 2022-10-10 - Kernels, Octopi, Deepin, GlibC, Haskell, Python; Nvidia 520.56.06

2 posts were split to a new topic: Deadbeef seems to have a problem playing flac files

New package from about 3 or 4 days ago: linux60-broadcom-wl does not run properly on boot, error mentions 6.0.2-1-MANJARO, I don’t know where it gets that from.

I think the package has a wrong setting. To confirm the issue wasn’t from my fiddling, I created a clean install from Manjaro-xfce minimal iso (on the official download page) and updated then updated kernel to 6.0, then added the package.

[misha@delphin ~]$ inxi -Nazy
  Device-1: Broadcom BCM43228 802.11a/b/g/n vendor: Dell driver: N/A
    modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
    chip-ID: 14e4:4359 class-ID: 0280
  Device-2: Broadcom NetXtreme BCM5761 Gigabit Ethernet PCIe vendor: Dell
    driver: tg3 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A
    bus-ID: 08:00.0 chip-ID: 14e4:1681 class-ID: 0200

[misha@delphin ~]$ journalctl -b | grep wl
Oct 17 23:33:47 delphin kernel: wl: version magic '6.0.2-1-MANJARO SMP preempt mod_unload ' should be '6.0.2-2-MANJARO SMP preempt mod_unload '

Expect to get similar to linux519-broadcom-wl …

Oct 17 17:51:47 delphin kernel: wl: loading out-of-tree module taints kernel.
Oct 17 17:51:47 delphin kernel: wl: module license 'MIXED/Proprietary' taints kernel.
Oct 17 17:51:47 delphin kernel: Disabling lock debugging due to kernel taint
Oct 17 17:51:47 delphin kernel: wl: module verification failed: signature and/or required key missing - tainting kernel
Oct 17 17:51:47 delphin kernel: wl 0000:02:00.0: enabling device (0100 -> 0102)
Oct 17 17:51:47 delphin kernel: wlan0: Broadcom BCM4359 802.11 Hybrid Wireless Controller (r587334)
Oct 17 17:51:47 delphin kernel: 
Oct 17 17:51:47 delphin kernel: wl 0000:02:00.0 wlp2s0: renamed from wlan0

There seems to be an issue with libQt6Gui. Several Qt applications crash during startup on my system:

[   31.897273] qtcreator[1757]: segfault at 58 ip 00007f45c9da247c sp 00007ffcfa34b490 error 4 in libQt6Gui.so.6.4.0[7f45c9b23000+579000]
[ 1112.883421] qt6ct[3389]: segfault at 58 ip 00007fab731a647c sp 00007ffd4b63e9a0 error 4 in libQt6Gui.so.6.4.0[7fab72f27000+579000]
[ 1297.441308] qtdiag6[3579]: segfault at 58 ip 00007fc3ac06747c sp 00007fff95e9b0d0 error 4 in libQt6Gui.so.6.4.0[7fc3abde8000+579000]
[ 1344.970073] qjackctl[3945]: segfault at 58 ip 00007fc30f3c947c sp 00007ffc1906a910 error 4 in libQt6Gui.so.6.4.0[7fc30f14a000+579000]

One question, u need to do this every time u change your primary monitor ???

Because i have the same issue…and i solve it on the gui tool…thanks

It remembers it for monitors for which I’ve set it. The GUI saves these preferences to the same file so it’s persistent.

Does require a log-out/in to see the changes.

This driver kills the dithering feature, that i use for a long time :frowning:

I need dithering for my colour banding problems that i have with my Dell Monitor.

Can i upgrade my Kernel without the new nvidia driver?

pamac update
Synchronizing package databases...
Resolving dependencies...
Checking inter-conflicts...

To upgrade (7):
  libxnvctrl          520.56.06-1  (515.76-1)    extra     
  nvidia-utils        520.56.06-2  (515.76-1)    extra     
  mhwd-nvidia         520.56.06-2  (515.76-1)    extra     
  lib32-nvidia-utils  520.56.06-1  (515.76-1)    multilib  
  linux515            5.15.74-3    (5.15.72-1)   core      
  linux515-nvidia     520.56.06-3  (515.76-14)   extra     
  manjaro-pulse       20221015-2   (20221002-1)  extra     

Total installed size: 243.2 MB

Will i run into problem when i upgrade only this 2 Packets?

  linux515            5.15.74-3    (5.15.72-1)   core 
  manjaro-pulse       20221015-2   (20221002-1)  extra

After this update I faced with long time shutdown.
I use KDE.
does anybody have the same issue?

Worked around the issue for now by downgrading Qt packages to 6.3.2. Basically this worked by:

pamac install downgrade
sudo DOWNGRADE_FROM_ALA=1 downgrade qt6-5compat qt6-base qt6-declarative qt6-positioning qt6-quick3d qt6-quicktimeline qt6-serialport qt6-shadertools qt6-svg qt6-tools qt6-translations qt6-wayland qt6-webchannel qt6-webengine 

and then chosing version 6.3.2 for all packages.

1 Like

I had this in the past a few times, where after a major upgrade on my system, a reboot/shutdown would take ages, or even stuck (seemingly). So I sometimes try a few key combinations and presses and it would restart successfully. My suspicion was the Nvidia driver, but that is probably because I hate it. Do you have Nvidia?

I press ctrl+alt+del for rebooting when system stucks on shutdown and then after reboot just try again to shutdown. but it’s annoying.
I use amd video

In my case it takes around 2 mins to shutdown the hdd when initiating a shut down. I’m using XFCE and NVIDIA. Unsure how to fix it.

Don´t [ CTRL+ALT+DEL ] !

if possible :wink:

Gentle shut down a suddenly hanged PC to minimize a chance of getting a broken filesystem and data loss:

Hmm. Maybe you could use xrandr. Using HDMI here is one example to turn it on.

xrandr --output HDMI-1 --set dithering On

1 Like

Metapackage manjaro-pulse is to install 3 base packages needed for PulseAudio:
( pulseaudio + pulseaudio-alsa + pulseaudio-bluetooth )
If you skipped updating, or even removed this metapackage, there should be no adverse effect on PulseAudio packages

1 Like

And what about the new Kernel?

Im worried, that when i upgrade the newest Kernel and after a restart. That its may possible, that my PC wont boot into Linux… because the newest nvidia driver is needed somewhere?

My Monitor is actually working with a Display Port Cable… Do i have to use a HDMI Kabel when i try your command?

I think you would use the command

–output eDP1


–output eDP1-1

Not sure. The HDMI was just for example purposes.

Your kernel concerns: Do you have another kernel installed to use as a fallback if a newer kernel gave you a black screen? I like to have more than one kernel installed for that reason.

With Kernel 5.9 I started to see issues with my Thinkpad P14s AMD Gen 1’s touchpad. After waking up from sleep dragging would not work anymore. Also, double tapping would not be working anymore. I had to run “sudo modprobe -r psmouse && sudo modprobe psmouse” every time in order to make it work again.

This was fixed with the first RC of Kernel 6.

Now, with 6.0.2-2 touchpad issues have reoccurred.

I dont have other Kernels installed, but if i had… they would be updated too if they arent EOL.

When i look at the nvidia xserver menue it shows DP-4 as connected device.


So should i use this command?
xrandr --output DP-4 --set dithering On


xrandr --output eDP1-4 --set dithering On

I had an issue with ceph-lib 15.2.17-1 not updating/rebuilding and crashing pamac. Then the system became unresponsive after trying to update it a couple of times though pamac (couldn’t reboot, couldn’t open a terminal).

I did a search for ceph-lib 15.2.17-1 and the general response was to delete it if not needed. I can’t remember installing it as I rarely install anything from AUR any more where I can help it.