[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

Hello community,

Another stable branch update with some usual package updates for you. This also marks the start of a new release series for Manjaro Linux we codenamed Sikaris.

image
Each new Major Manjaro KDE release will bring a new wallpaper. This we call North.

  • Some of our Kernels got renewed and all rebuilt against GCC 12.2
    • Note: 5.18 kernel series is now marked EOL
  • Linux Firmware got updated
  • KDE Plasma is now at 5.25.5
  • KDE Gear got renewed to 22.08.0
  • KDE Frameworks got updated to 5.97.0
  • LibreOffice released 7.4.0 and moved 7.3.5 to the still branch
  • AMDVLK is now at 2022.Q3.3
  • More adjustments to Qemu
  • Firefox 104.0.2 and Thunderbird 102.2.2 got added
  • NetworkManager 1.40.0 ships with many improvements
  • PipeWire 0.3.57 includes fixes and improvements
  • Mesa is now at 22.1.7
  • Calamares got renewed to 3.2.61 which also brings new slideshows
  • We removed our XFCE-gtk3 compatible packages from our repos
  • Our Steam packages are now similar named as with upstream Arch
  • Regular KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77. If you want a ISOs with this stable-update included, take a look at github.


Our current supported kernels

  • linux419 4.19.257
  • linux54 5.4.212
  • linux510 5.10.141
  • linux515 5.15.65
  • linux518 5.18.19 [EOL]
  • linux519 5.19.7
  • linux60 6.0.0rc4
  • linux515-rt 5.15.55_rt48
  • linux518-rt 5.18.0_rt11 [EOL]
  • linux519-rt 5.19.0_rt10

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

28 Likes

Known issues and solutions

:information_source: This is a wiki post; please edit as necessary.
:star: Please, consider subscribing to the Stable Updates Announcements RSS feed


Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:


:arrow_right: 2022-09-12

Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.

electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

element-desktop dependency error
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rekeyringbuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su

2022-08-16

suil 0.10.16-1 breaks LV2 plugin GUIs in Ardour

Arch removed gtk2 compatibility in suil which is required by Ardour. Best solution is to downgrade to suil-0.10.12-2.

sudo pacman -U https://archive.archlinux.org/packages/s/suil/suil-0.10.12-2-x86_64.pkg.tar.zst

2022-08-13

element-desktop dependency error
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su

2022-08-07

Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

The following should no longer be needed:

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.

2022-07-29

KDE Wayland: Kickoff "KDE menu", notifications and tooltips show in the upper left corner
  • This is due to an upstream packaging bug, which has since been reverted.
  • In the meantime, you can (temporarily) disable the associated Wayland feature (thanks @ufo_driver):
sudo echo 'export QT_WAYLAND_DISABLE_FIXED_POSITIONS=1' > /etc/profile.d/qt5-wayland-regression.sh
  • It should now be fixed with qt5-wayland 5.15.5+kde+r38-3.
Missing dependency 'gcc8-libs=8.5.0-1' required by gcc8
  • This happens even while gcc8-libs is already installed (8.5.0-1).
  • Fixed by manually uninstalling gcc8 and gcc8-libs.

2022-07-18

wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.

2022-07-12

Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab

5 Likes

I had TimeShift as my backup, but I had zero issues!

4 Likes

Just a minor issue, the plasma5-themes-breath package isn’t updated with the latest background on any branch.

5 Likes

It’s still being worked on (we also need a dark variant), we got just a packages update (so-called prerelease update) here, more major things will show up in upcoming weeks.

1 Like

“Each new Major Manjaro KDE release will bring a new wallpaper. This we call North.”

I upgraded, but I don’t see this new wallpaper. Is it only on fresh installation?

It’s not a major release yet :wink: Just a sneak peek of the upcoming change.

P.S. (also @geodic) for now you can get it manually from our Breath repository.

5 Likes

After updating, i got a black screen on the first reboot. Waited 10 minutes and nothing happened, although i could hear my hard drive moving.
I just restarted again and it all worked on that reboot

1 Like

< begin rant >

In my personal opinion, we should have stuck to Plasma 5.24. It was a long-term support release and it was perfect.

Plasma 5.25 has loads of bugs — which I was already warning those newbies about who were loudly complaining weeks ago as to why 5.25 wasn’t in the Stable branch yet — and the graphical transitions from 3D compositing to 2D compositing are now all messed up, as could already be seen when the KDE developers rewrote the flip switch and cover switch effects a while ago. And so now that ugliness has also reached the desktop grid effect and the desktop layout indicators when switching between virtual desktops.

So those are the issues I was having, and I solved it by disabling the desktop layout indicators. I guess I’ll just have to live with the ugly desktop grid rewrite.

Seriously, we should have stuck with 5.24. :frowning:

< end rant >

25 Likes

Wonderful picture!

I switched to the testing branch on my PC yesterday, so I can’t report anything :slight_smile: Anything but since I got to the testing branch yesterday, finally my gimp color picker does function :slight_smile:

Congratulation for this beautyful release.

1 Like

So if anyone uses backintime, packages have been renamed by the looks of it, and backintime replaces backintime-cli, so you need to install backintime-qt if you want a GUI.

Otherwise no issues so far.

3 Likes

Yeah, I hate it when seeing people saying things like: “Ah, things work for me so there might be some problems on your side” without actually being helpful to those who actually came across the problem.

8 Likes

I just had a huge issue with my custom KDE Plasma after this update. First I had issues with my keyrings, which I resolved by following the docs, but now I’m stuck with the issue below. It’s been awhile since a major issue like this:

Any help is highly appreciated.

Major issues here. Maybe the Nouveau driver I am using. ??

The plasma desktop was not loading. I had a mouse cursor. I could launch apps that had a shortcut assigned such as Dolphin. But no DE. :frowning:

I used Timeshift to roll back to KDE 5.24.6. Whew.

The 5.19 kernel upgraded just fine as far as I can tell.

I redid the update but held back anything that wanted to update to 5.25.5-1. So I am at 5.24.6 but KDE frameworks 5.97 and Qt. 5.15.5 using x11

The plasma shell is working again.

2 Likes

Yes, I had to roll back to 5.24.6 then redid the update, updating everything except upgrading to 5.25.5-1.

It is working again. But now what? Be patient? :slight_smile:

2 Likes

Thanks for the heads up!

1 Like

I have a small problem with Firefox 104.2.2:
Pop up windows open with the complete size of the desktop at the following link: https://www.surfmusik.de/radio/swr-3-live-dsl,920.html

I have a problem with Ruby default gem updates. I got this error when installing the packages from stable update 2022-09-12.

error: failed to commit transaction (conflicting files)
ruby-ruby2_keywords: /usr/lib/ruby/gems/3.0.0/gems/ruby2_keywords-0.0.5/LICENSE exists in filesystem
ruby-ruby2_keywords: /usr/lib/ruby/gems/3.0.0/gems/ruby2_keywords-0.0.5/README.md exists in filesystem
ruby-ruby2_keywords: /usr/lib/ruby/gems/3.0.0/gems/ruby2_keywords-0.0.5/lib/ruby2_keywords.rb exists in filesystem
ruby-ruby2_keywords: /usr/lib/ruby/gems/3.0.0/specifications/ruby2_keywords-0.0.5.gemspec exists in filesystem
Errors occurred, no packages were upgraded.

Should I uninstall Ruby before updating the packages? Any ideas?

Edit: This issue has been resolved. I removed the conflicting files above and re-run the pacman command for package updates. Maybe uninstalling Ruby is not a good idea because there are other tools, like RubyGems and Bundler, that are dependent with it.

I haven’t updated yet. I’d like to know what the above means before proceeding.

pacman -Ss xfce-gtk3 shows 2 packages. Of those two, I have installed community/manjaro-xfce-settings 20220616-2.

I also:

  • searched pacman -Ss compat|grep -i xfce to make sure I wasn’t missing anything.
  • looked at the detailed list of all package changes, saved it and grepped for compat (results were haskell and libcurl).

What packages make up the XFCE-gtk3 compatible packages?

After the update,
on Manjaro KDE, everything related to KDE (especially Plasma) has huge lags.
Clicking anything on the desktop, taskbar now takes about 3s until something happens.
All other programms work fine (Firefox, Vivaldi, KeePassXC, etc…). It’s just “everything KDE” that feels sloppy, laggy and unresponsive now.

Tried with kernels:
5.18.19-3, 5.19.7-1
(I need at least 5.18.x for the AMD videocard to work)

HW:
Ryzen 7 5800X
AMD RX 6700 XT

Update: Tried clearing cache, now Plasma crashes on boot.
Will revert to previous update via timeshift and try to make a “cleaner” update later. Have to work now :stuck_out_tongue:

Update 2: Tried another upgrade after clearing all caches, tmp and closing all programs and it works now. I have, however other minor problems with KDE now, for example: the autostart entries in systemsettings5 do not work anymore.

2 Likes