[Stable Update] 2022-08-16 - Glibc with EAC fix, Nextcloud, KDE-git, Cinnamon, Haskell, Python

Thank you so much! I wasn’t aware this was a problem until you pointed it out. As an alternative, I downgraded the package by installing it from my pacman cache:
sudo pacman -U /var/cache/pacman/pkg/suil-0.10.12-2-x86_64.pkg.tar.zst

I have the same problem :frowning: tried to update several Manjaro computers and getting this issue

“An error occurred while trying to share the directory. The share has not been created”
Samba internal report:
net usershare add: cannot convert name “Everyone” to a SID. The transport connection is now disconnected."

Tested to update with a clean install and it’s working, but i don’t want to reinstall all the computers.
Only option is to revert it with Timeshift

1 Like

pamac quit due to corrupt sway database (Jonas Strassel signature). Updating with pacman -Syyu worked instead.


Do this → Can't connect to samba after update; Service is running (2022-08-13 -> 2022-08-16) - #29 by TheInvisible

1 Like

Until now I had no problem, everythig works fine.

10 posts were split to a new topic: Stable channel update frequency

Hi all,
I had an issue with my lightdm upgrade:

  • I am on Manjaro stable : XFCE flavor. which comes with lightdm, by default.
  • I configured it to work with my fingerprint (it worked before the upgrade, it now works again after the upgrade + workaround)
  • I launch the pamac upgrade, and let the computer do its thing for a while.
  • I come back and try to log back into my session: but I faced a “Failed authenticate” error. (or something).
  • I couldn’t get my fingerprint recognised. I couldn’t enter my password: which happens when fingerprint doesn’t work, usually.

my dirty workaround:

  1. Open a new TTY (Ctrl + Alt + F2) and log into your session with the password. (because it works !)
  2. run: systemctl restart lightdm

This will reset your session:

  • All your unsaved work will be lost.
  • Unable to see the output of the previous pamac upgrade (warning or errors)
  • but the fingerprint is now working back again :tada:

Happy to take any advice on this: what should I have done? ways to save the work ? ways to authenticate ? Ability to get the pamac upgrade outputs ?

Thanks all.

Thank you! That led me to the problem. The issue was not “using a share path outside a home directory”
because i’ve tried to make a share inside my home directory and got the same issue. So I uninstalled apparmor and snapd and all its dependencies. Don’t need Snap packages anyway. Now it’s working to make a network share thru Dolphin again.

Replying to myself (bad form).

Was not getting update notices.

I had to pamac update --force-refresh to get the database to sync. The lck file didnt exist, so there was another issue. Now I will wait and see if I get update notifications.

1 Like

I got a similar probleme once ago…
Probleme was, even after updating the mirrorlist in pamac, i got no update notification.
Reason was, that the first server in the mirrorlist was outdated.
After i edited the etc/pacman.d/mirrorlist and removed the server from the list, the updates were shown.

A post was split to a new topic: Corrupted packages/invalid keyrings during update

Oh no… You don’t need to remove AppArmor… Just disable it and reboot your PC

sudo systemctl disable apparmor

Bring it back Bring it back :rofl:
//Timeshift it back. I hope you snapshot that before you remove AppArmor :sweat_smile:

Follow up my thread … I’m still searching for proper way to config AppArmor to make Samba work again

1 Like

After the update the Ctrl key no longer works in my virtualbox virtual machines, it just treats Ctrl-C as the letter C etc, where it didn’t before the update.

Virtualbox guest additions are up to date, and the same behaviour is seen on both a Windows and Linux guest. When disabling its “mouse integration” option the ctrl key works as expected, but is a workaround that introduces its own usability issues. There’s an older issue relating to this in virtualbox relating to using ctrl on the host to locate the mouse pointer, however I don’t have this setting on.

This issue doesn’t occur in vmware virtual machines. I’m running the 5.15 kernel and Cinnamon.

I was just about to report the Ctrl key issue too. It’s not just Virtualbox. Any combo with left Ctrl is broken for me on multiple Cinnamon systems. I did some digging and previously they said this was a bug in XOrg that had to get patched. But that was in 2018.

So yeah, on my systems ( multiple ones so multiple keyboards ) if I try to do Ctrl+Shift for example, it does not work. But some things do. Ctrl+Alt left / right works. The majority of my issues are Ctrl+Shift but other things have not worked at times.

In the virtual keyboard I can bring up, when I press left Ctrl it never lights up to recognize it as being hit. Other keys do. But obviously that’s not completely right if Ctrl+Alt+left/right works.

I can use the right Ctrl and that works, but there’s no way I’m going to get used to that after a couple of decades of left Ctrl + something. :open_mouth:

In any case, something got borked with using the left Ctrl key in the update

Hello, I have a problem that I can’t access the internet but i can connect to wifi right after the update. How to solve this sir?. Now i’m running on 5.15.59-1. Thanks in advance.

Oh my… You’ve right! Never thought about it. Reverted with Timeshift and made the update.
Disabled the Apparmor and now Samba share is working again :slight_smile:
I hope there is a proper solution for it :confused:

Still errors in Journal when using Firefox:

I did open an issue on the Cinnamon Github page to let them know

edited to include link :


The update to the latest master cinnamon mentioned in that ticket has fixed my issue with ctrl in virtualbox. Thanks to all involved!

1 Like

Or use aa- complain to restore functionality:

sudo aa-complain /usr/bin/smbd
sudo aa-complain samba-dcerpcd samba-bgqd samba-rpcd samba-rpcd-classic samba-rpcd-spoolss

to check status: sudo aa-status
You might need to reboot afterwards
1 Like