[Stable Update] 2022-08-13 - Kernels, Mesa, Gnome, Firefox, Haskell, Python, Systemd

Hello community,

Another stable branch update with some usual updates for you.

Checkout what ETAPRIME has to say about our UM350 MiniPC!

  • Most of our Kernels got updated with needed security fixes
  • Gnome pushed out some updates to 42.4
  • Mesa got updated to 21.3.6
  • Systemd is now at 251.4
  • Firefox got renewed to 103.0.2
  • Vivaldi 5.4
  • Regular Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.255
  • linux54 5.4.210
  • linux510 5.10.136
  • linux515 5.15.60
  • linux518 5.18.17
  • linux519 5.19.1
  • linux515-rt 5.15.55_rt48
  • linux518-rt 5.18.0_rt11
  • linux519-rt 5.19.0_rt10

Package Changes (Thu Aug 11 20:44:03 CEST 2022)

  • stable community x86_64: 1363 new and 1345 removed package(s)
  • stable core x86_64: 33 new and 31 removed package(s)
  • stable extra x86_64: 332 new and 334 removed package(s)
  • stable kde-unstable x86_64: 247 new and 247 removed package(s)
  • stable multilib x86_64: 19 new and 19 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

:information_source: This is a wiki post; please edit as necessary.
:star: Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

:arrow_right: 2022-08-13

element-desktop dependency error
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su


Glibc 2.36 update will break EasyAntiCheat within Proton

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.


KDE Wayland: Kickoff "KDE menu", notifications and tooltips show in the upper left corner
  • This is due to an upstream packaging bug, which has since been reverted.
  • In the meantime, you can (temporarily) disable the associated Wayland feature (thanks @ufo_driver):
sudo echo 'export QT_WAYLAND_DISABLE_FIXED_POSITIONS=1' > /etc/profile.d/qt5-wayland-regression.sh
  • It should now be fixed with qt5-wayland 5.15.5+kde+r38-3.
Missing dependency 'gcc8-libs=8.5.0-1' required by gcc8
  • This happens even while gcc8-libs is already installed (8.5.0-1).
  • Fixed by manually uninstalling gcc8 and gcc8-libs.


wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.


Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab


Akonadi (KMail / Kontact / KOrganizer...) fails to start
touch ~/.local/share/akonadi/db_data/ib_logfile0
akonadictl start
mariadb-upgrade --defaults-file=~/.local/share/akonadi/mysql.conf --socket=/run/user/$(id -u)/akonadi/mysql.socket
Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package. /etc/locale.conf will automatically be restored if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.


I could not update with the CLI version, due to an permission error cp: cannot create regular file '/var/tmp/pamac/dbs/sync/pamac_aur.db': Permission denied, even after a reboot. But for some reason the graphical Pamac updates (at least it downloads right now, will remain to be seen if everything works fine). Has anyone experienced this too or is it something unique to my system?

I got this problem that blocks upgade process:

:: Replace med with community/med-openmpi? [Y/n] 
resolving dependencies...
looking for conflicting packages...
:: hdf5-openmpi and hdf5 are in conflict. Remove hdf5? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: hdf5-openmpi and hdf5 are in conflict
 -> error installing repo packages

Dependency error:

# pacman -Syyuw
:: Synchronizing package databases...
 core                  165.9 KiB   172 KiB/s 00:01 [#######] 100%
 extra                1849.4 KiB  1581 KiB/s 00:01 [#######] 100%
 community               7.1 MiB  1967 KiB/s 00:04 [#######] 100%
 multilib              180.6 KiB   271 KiB/s 00:01 [#######] 100%
:: Starting full system upgrade...
:: Replace med with community/med-openmpi? [Y/n] y
resolving dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

Added workaround for element-desktop dependency issue to “Known Issues and solutions” wiki post.


sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su

After update unable to open Manjaro Settings Editor in Gui. Get following error using Cli:

“manjaro-settings-manager: error while loading shared libraries: libhd.so.22: cannot open shared object file: No such file or directory”

run ls -l, the owner must be your login “$USER”
you have root ? maybe you have run pamac cli with sudo? (rm this file or use chown)

Thanks @philm ,
re the 2022-08-07 update:

Glibc 2.36 update will break EasyAntiCheat within Proton

Can you confirm that the embedded glibc 2.36-1 is patched ?
Because this prevented me to performed the previous update.
Many thanks in advance.

After updating to 42.4, when I press the Gnome app search does not work when I press the cmd.

If you use lightdm , look out for lightdm.conf.pacnew .

1 Like

I checked the permissions and there was not file at place '/var/tmp/pamac/dbs/sync/pamac_aur.db'. My db was and still is at '/var/tmp/pamac/pamac_aur.db'. Restarting wouldn’t change, but updating with the pamac GUI did update normally and now I can update and use the CLI pamac again. So it is solved in my case, but wanted to mention if someone has same issue, they should try to use the GUI. I usually don’t use sudo pamac, so this was not the issue here.

Next time you encounter this error try pamac update --force-refresh.


Looks like a partial update. hwinfo should be v22.0-1.

Thunar+Samba seems broken (since the last update AFAIK): By clicking on the individual computers in Thunar nothing happens nor error-messages showing up.
Connection by “mount” works (also copying files), the service are running fine and as far as I checked the smb.conf didn’t change, so I guess this issue happens in Thunar or on the gvfs-side.

If anyone finds a bugtracker-entry or solution, pls mention.

make sure that you have version 0.5.7-6 of manjaro-settings-manager installed.

It is

Hwinfo shows 21.82
kernal is 5.18

I know, I told you it’s a partial upgrade. Redo it (with other mirror if it doesn’t update).

It seems that DT_HASH will be re-added in v2.36-2. It will give more time to Epic to fix EAC problem with DT_GNU_HASH.
see github

1 Like