[Stable Update] 2022-07-21 - Cinnamon 5.4, Kodi Game-Addons, Pipewire 0.3.56, KDE-Git

pamac in terminal can still access AUR package ( use -a or –aur ) even if AUR support is disabled in pamac-manager GUI

1 Like

blueman-applet seems a bit buggy with this update, but everything else is dandy.

A very interesting and potentially useful tip. Thanks.

libkipi-22.04.0.tar.xz … FAILED (unknown public key BB463350D6EF31EF)

I resolved this with

pamac remove libikipi

pacman -Qi libkipi will tell you if the package is being used for anything

Thanks for your reply. The rest of the packages updated with no problem, but I’m still getting the same problem. It’s not a major problem, doesn’t affect usability, but I’d rather have it cleared up if possible.

I checked dependencies, and it seems to be required by grass, the GIS program, so I’m reluctant to just remove it, since I do use that app.

But how can we remove celt 0.11.3-5 ?

Atleast i have no option in pamac UI.

I got the same message. I have solved by clicking on 3 points and then “refresh databases”.

grass can be compiled using the official python-wxpython now (may have some glitches though), so you can modify the PKGBUILD of grass to build it.
The package python-wxpython-dev can be built on my side, so need more people for troubleshooting. Please visit the AUR page and report the issue there.

You indeed need to do so from the Browse or Installed tab instead of the Update tab.

1 Like
$ openrct2
openrct2: symbol lookup error: openrct2: undefined symbol: _ZN9benchmark10InitializeEPiPPc

What does it do the final “w”?

This from man pacman:

       -w, --downloadonly
           Retrieve all packages from the server, but do not install/upgrade
-w, --downloadonly

Hi guys,
I’ve apply the update today and my Bluetooth, one of my USB port and also a LAN and USB hub from a Type C hub 3.1 - HDMI, LAN, USB stops working. Only HDMI works from that hub.
The machine is HP Probook 455 G7 with Ryzen 7 4700U.
Any suggestions how to fix them ?
Okay that was strange.
I’ve switch to my Windows to check if everything if working there. And everything works fine. After taht restart to Manjaro again and all the posrts working fine.
So the problem was solved magically :slight_smile: Sorry for the spam, but if someone want logs write me back what to post and to check them.

it’s easy to add option h for to get help :wink: (or use man)

 pacman -Sh
 pamac update -h
 pamac install -h

I did try changing the URL in the buildfile to the one from the AUR instead of the wxpython one. This got me as far as cloning the files and setting up the transaction.

Then, however, I get:
could not satisfy dependencies:

  • removing wxgtk3-dev breaks dependency ‘wxgtk3-dev’ required by python-wxpython-dev

Update: I figured I could just remove grass altogether, but I get the same error and can’t remove it.

Remove the package first, and then install it again. It already changed the dependency to wxwidgets-gtk3.

A post was split to a new topic: Thanks for all the kodi libretro addons

Since this update (or the previous one) Manjaro Gnome on my Intel NUC running kernel 5.15.55-1 goes into airplane mode by itself. It seems to happen after reboot and sometimes after the screen has been locked. Is this a known issue? Or can I disable airplane mode all together? As I don’t need it in my setup.

The only thing that I found when searching for _ZN9benchmark10InitializeEPiPPc is this two year old issue: libbenchmark_main.a doesn't contain main() function with -DBENCHMARK_ENABLE_LTO=true · Issue #1070 · google/benchmark · GitHub

Anybody else experiencing this? How to fix it?