[Stable Update] 2022-07-21 - Cinnamon 5.4, Kodi Game-Addons, Pipewire 0.3.56, KDE-Git

BTW, after the previous update, I did some stuff with these wx… packages and could get all AUR packages that depended on them to work again except for wxwabbitemu-git. I’ve reported the issue on their tracker. I was asked for a log and because it’s a C++ installation, the log is tens of thousands of lines long, so maybe they’re still reading it to this day. :smiley:

If there’s nothing too integral to the system that got updated, you could just restart the affected programs, for example the desktop environment, the window manager, etc. How you do that depends a lot on which ones you use. But most major updates to Manjaro also update the kernel or other very deep underlying parts, so rebooting is recommended anyway.

1 Like

I know. I was just joking. :joy:

The package python-wxpython-dev would not update. Manually disabled it, rest of the update went fine.

There is no error message as such, it hangs on “cloning python-wxpython-dev build files” and doesn’t go any further. Googling has not got me any answers.

4 posts were split to a new topic: Ruby-bundler: /usr/bin/bundle exists in filesystem


When I tried to use VirtualBox all my images failed to load and a popup appeared showing NS_ERROR_FAILURE (0x80004005). In the forum one can find several solutions for the problem, however the one that worked for me was:

What I noticed is that my extension was 6.1.36, but VB was 6.1.34, so I downloaded the correct extension from here:

After loading VB as root and manually installing it, everything worked fine again.



I always set the package “virtualbox-ext-oracle” to ignore in pamac. I only install it when an update matches the version. This works quite well.


I suggest you ignore it first, upgrading the system, and then see if you can upgrade it.

Hi, I am struggling to apply the latest update. I get the following error before I can apply what I think are the packages from the 7/18 update:

could not satisfy dependencies:

  • removing lib32-alsa-lib breaks dependency ‘lib32-alsa-lib’ required by lib32-alsa-plugins
  • removing lib32-alsa-lib breaks dependency ‘libasound.so=2-32’ required by lib32-alsa-plugins

I managed to get all other package updates to go through by ignoring the 3 alsa packages, although the first time I tried, the updated libnotify package was giving me 404 errors from all mirrors. alsa-lib, alsa-card-profiles, and alsa-ucm-conf are still floating around in my pamac and refuse to update.

edit: this is now blocking all new package installations, even if they have nothing to do with alsa.

error t=2022-07-21T13:00:19Z
[xapp-status@cinnamon.org]: No JS module ‘recordingIndicator’ found in search path
[xapp-status@cinnamon.org]: Error importing applet.js from xapp-status@cinnamon.org

After updating, I get the Cinnamon message where it tells me an applet or extension didn’t load properly, checking the logfiles shows this, XApp Status Applet is also a system applet so It’s not something I can just change and uninstall.

1 Like

I ran VB for years and dealt with all these little quirks over the last year i converted my VB image to qcow2 and starting using KVM… is there any particular reason you arent running KVM… its native built into the kernel… just convert your virtual box image to qcow2 and you are off the races!! and no more crap shoot every update


Not fast enough. :angry: It’s been 18 hours since the release of the July 21 Stable Update.

EIGHTEEN HOURS AGO! Why are they waiting so long to release the next Stable Update?

I want to use KDE 8 alpha pre-release right now. They introduced “sparkly windows”, which surrounds the application’s window border with an animated lighting effect, which you can customize and sync with your bluetooth RGB light strips! I NEED this feature. It’s not fair that Arch Linux, Gentoo, and KDE Neon get to have all the fun before us! :sob:

Following the update (a combination of the 7-18 & 7-21 patches) and reboot I now have the AUR package celt pending an AUR update.

I did not manually install this package, was it something that was moved to the AUR? Can I just remove this package safely?

Edit: I can find celt being removed from the changelog of the testing 7-20 update but not from any record on stable release posts. I don’t know why so any advice on what to do with this package is welcome.


Thank you @Cytomax for the tip. I once read something about that conversion, but in the end I just forgot about it. I will try it.


Even if the AUR support is disabled in Pamac?

If you use pamac to install packages and you haven’t enabled AUR support, then indeed, obviously, AUR (optional) dependencies will not be suggested.
But if that package was previously in the main repositories, and you installed it when it was still there, then whether you have AUR support enabled now or not is irrelevant. That package is installed and dependencies must still be resolved, whether your system can find its repository or not.

pamac in terminal can still access AUR package ( use -a or –aur ) even if AUR support is disabled in pamac-manager GUI

1 Like

blueman-applet seems a bit buggy with this update, but everything else is dandy.

A very interesting and potentially useful tip. Thanks.