[Stable Update] 2022-06-24 - Kernels, KDE Frameworks, Cinnamon 5.4, Qt5, Gstreamer, Haskell, Python

5 posts were split to a new topic: I get the message that the package is wrong or corrupt

I did the update yesterday, and today when I restarted the computer, I realised that my external monitor is not positioned as it used to be. I went to System Settings > Display and Monitor > Displays to try to reconfigure it, but instead of the usual panel, I get to see the following error message:

I’ve tried to reinstall kdisplay and disman, but it doesn’t solve the problem. I suppose these are important modules, no? Or can I remove them, as suggested by the error message?

Output of `inxi -Fazy`
Kernel: 5.18.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/vmlinuz-5.18-x86_64
root=UUID=ca0b13f1-3220-4bc9-9dc7-77d2311111e0 rw rootflags=subvol=@ quiet
apparmor=1 security=apparmor udev.log_priority=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 4180Q3U v: ThinkPad T420
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 4180Q3U serial: <superuser required>
UEFI-[Legacy]: LENOVO v: 83ET82WW (1.52 ) date: 06/04/2018
ID-1: BAT0 charge: 42.5 Wh (57.5%) condition: 73.9/75.5 Wh (97.9%)
volts: 11.1 min: 11.1 model: SANYO 45N1023 type: Li-ion serial: <filter>
status: not charging
Info: model: Intel Core i7-2640M bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 built: 2010-12 process: Intel 32nm family: 6 model-id: 0x2A (42)
stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1683 high: 3089 min/max: 800/3500 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 3089 2: 1060 3: 797
4: 1786 bogomips: 22332
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Lenovo ThinkPad T420 driver: i915 v: kernel arch: Gen6
process: Intel 32nm built: 2011 ports: active: DP-3,LVDS-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0126 class-ID: 0300
Device-2: Chicony integrated camera type: USB driver: uvcvideo
bus-ID: 1-1.6:6 chip-ID: 04f2:b221 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 3520x1200 s-dpi: 96 s-size: 931x317mm (36.65x12.48")
s-diag: 983mm (38.72")
Monitor-1: DP-3 pos: right model: PA248QV serial: <filter> built: 2020
res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2 size: 518x324mm (20.39x12.76")
diag: 611mm (24.1") ratio: 16:10 modes: max: 1920x1200 min: 720x400
Monitor-2: LVDS-1 pos: primary,left model: LG Display 0x02e2 built: 2010
res: 1600x900 hz: 60 dpi: 131 gamma: 1.2 size: 310x174mm (12.2x6.85")
diag: 355mm (14") ratio: 16:9 modes: 1600x900
OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 22.1.2
direct render: Yes
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.18.6-1-MANJARO running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.21 running: no
Sound Server-4: PulseAudio v: 16.1 running: yes
Sound Server-5: PipeWire v: 0.3.52 running: yes
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
driver: e1000e v: kernel port: 5080 bus-ID: 00:19.0 chip-ID: 8086:1502
class-ID: 0200
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 8086:0085 class-ID: 0280
IF: wlan0 state: up mac: <filter>
IF-ID-1: wwp0s29u1u4i6 state: down mac: <filter>
Device-1: Broadcom BCM2045B (BDC-2.1) type: USB driver: btusb v: 0.8
bus-ID: 1-1.4:4 chip-ID: 0a5c:217f class-ID: fe01 serial: <filter>
Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Local Storage: total: 2.05 TiB used: 1.51 TiB (73.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3B6Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS541010A9E680
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: A7G0 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD7500KMVV-11A27S0 size: 697.98 GiB block-size: physical: 512 B
logical: 512 B type: HDD rpm: 5200 serial: <filter> rev: 1032 scheme: MBR
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 28.69 GiB (28.7%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot raw-size: 512 MiB size: 511 MiB (99.80%)
used: 177.9 MiB (34.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 365.26 GiB size: 365.26 GiB (100.00%)
used: 308.38 GiB (84.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 28.69 GiB (28.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Alert: No swap data was found.
System Temperatures: cpu: 58.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3187 mobo: 65535 fan-2:
Processes: 286 Uptime: 59m wakeups: 1 Memory: 15.41 GiB
used: 4.22 GiB (27.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 2070
lib: 433 flatpak: 0 Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.19


1 Like

My Cinnamon panel wasn’t working right either. It seemed to prefer an “always hide” behavior, then later decided to add a “tiny size” to the mix. I couldn’t figure out a way to make it work, so I had to do a Timeshift restore.

Please test zfs-dkms / zfs-utils 2.1.5-1 coming along shortly.

The precompiled modules; i.e., linux518-zfs are NOT updated yet.

The F2FS problem that was present in previous update is still present.
My laptop refuses to boot, timeshift backup corrupted.

I’m kinda disappointed, all newest kernels still can cause serious data loss with F2FS.

Telegram 4.0 is a complete piece of junk. It cannot start minimized, and has serious problems with window manager and display.

Update was fine initially, but now linux518-zfs 2.1.5-1 is failing to load the ZFS kernel modules. linux515-zfs 2.1.5-1 is also failing, so it seems to be the ZFS update rather than the specific kernel.

EDIT: Downgrading to ZFS 2.1.4 has my ZFS functional again. Definitely an issue with the precompiled ZFS 2.1.5-1 packages.

sorry for the late, i just tested, it worked, i can boot into my system with zfs-dkms 2.1.5-1 now. thanks.

Or just use pamac update.

The suddenly-appeared zfs update (2.1.5-1) breaks my zfs root. I have to chroot my system to rollback to my earlier snapshot (or downgrade zfs back to 2.1.4) and regenerate my boot image with mkinitcpio -P to make my system bootable again.

1 Like

The linux515-zfs (2.1.5-1) update is causing issues here too.

% uname -r
% journalctl -p 3 -b
systemd-modules-load[392]: Failed to insert module 'zfs': Exec format error
kernel: spl: version magic '5.15.50-1-MANJARO SMP preempt mod_unload ' should be '5.15.49-1-MANJARO SMP preempt mod_unload '
systemd[1]: Failed to start Load Kernel Modules.

It’s as though the linux515-zfs (2.1.5-1) package has been built against the Unstable linux515-headers (5.15.50-1)

1 Like

Yes sir. I just updated to latest “stable” release and system is now dead. Cannot boot, cannot mount pools. Is there a quick solution? I cant even boot a thumb drive and load my pools.

uname -r

Thanks for the heads up.

In fairness, looks like the update of zfs from 2.1.4 → 2.1.5 was not part of the bulk Stable Updates, but rather a separate update on its own, built on June 27.

Going to skip updating zfs until I know for sure this has been resolved.

I’m currently rebuilding the ZFS extra modules for testing / stable as we speak as version 2.1.5-1.0.


Not to be pedantic, but wouldn’t that be -2 instead of -1.0? :grin:

Shall install and test on my ZFS storage once the update comes down the pipe. I have more versatility, since I’m not using a ZFS root, but rather ZFS for separate storage (backups of my data).

No, as 2.1.5-2 is in unstable. :wink:

1 Like

ZFS 2.1.5-1.0 is working fine for me. Thanks for the rapid fix!


Qbittorrent won’t start.
Here’s what helped me.
Remove qBittorrent.conf from ~/.config/qBittorrent to some temp folder.
Run qBittorrent. It should start as if it was just installed.
Quit qBittorrent and open new (default) ~/.config/qBittorrent/qBittorrent.conf in your text editor.
From GUI section copy “Qt6\TransferList\HeaderState” parameter (long bite string) and paste it in your old qBittorrent.conf file.
Replace new config with old one and run qBittorrent. Now all you should do is to adjust some headers.

1 Like

On Cinnamon
The keyboard applet on the status bar makes the whole right part of the bar grow and overflow off the screen whenever I change keyboard layouts.
Removing the applet and adding it back again seems to fix the issue.
Update: It broke again after restarting :sob: I know it’s an applet so I’ll have to wait for an update on it.

Another issue on Cinnamon.

My setup:

  • On a laptop
  • External monitor plugged in and setup as the primary display
  • Second status bar (panel) on the secondary display (the laptop monitor)

The issue: Unplugging the external monitor will not display the main status bar on the laptop monitor, the second status bar will be there instead. Logging out and back in again solves the issue.

After this update I had serious issues with akonadi crashing. I could not resolved the problem with the steps mention in the description.

This is what it worked for me:

  1. mv ~/.local/share/akonadi/db_data ~/.local/share/akonadi/db_data_bk
  2. mkdir ~/.local/share/akonadi/db_data
  3. akonadictl start
1 Like