[Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird

To downgrade gnutls:

sudo DOWNGRADE_FROM_ALA=1 downgrade gnutls

then choose: 2


Thank you very much!! :star_struck:

This worked for me too. Thanks! :grinning:

I can no longer use my media keys (play/pause etc), they just cause a gray square with a white “no” sign to appear (circle with diagonal line). Re-assigning them in Gnome does not help (though they were gone). Volume control keys work.

No everything ok, must be a theme issue

Are you by any chance getting dbus errors when running

journalctl -r

I’m having similar issues as I detailed here which went away but have come back after this update.

7 posts were split to a new topic: Lock screen broken after 2022-05-23 update

I checked the RU Blacklist website for blocked IPs & aur.manjaro.org was included. But it seems only because that recycled IP had been used before for pr0n.
It might be different from your side, as I get the IP for UK cdn.

ping aur.manjaro.org
PING 1715854792.rsc.cdn77.org ( 56(84) bytes of data.
64 bytes from london-13.cdn77.com ( icmp_seq=1 ttl=51 time=69.4 ms


2 posts were split to a new topic: Intermittent trouble with music playback

Idk if its normal but since the update on wayland plasma when I put the mouse over things on the launcher there is no change or selection, its “invisble”… idk if it’s understandable xD I think I can make photos of this…

PD: with the mouse is not a problem the problem is with the keyboard that you have to select things with no “idea” where are you

Attempt to upgrade have me this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing gcc (12.1.0-2) breaks dependency ‘gcc=11.2.0-4’ required by gcc-d

Any help will be greatly appreciated.

gcc-d 11.2.0-4 has been removed from the [core] repository.


Remove it and then update.

1 Like

This solved the issue, thanks.

The network manager 1.38 update has already arrived, but the issue of connecting my UMTS modem remains. There is a connection, but there is no Internet. The same problem was on version 1.36. (what is interesting Ubuntu 22.04 lts on version 1.36 has the same problem). I am forced to use version 1.34… help me fix the problem! thank.

Cadence (community/cadence 0.9.1-5) will not start, even after rebuilding qt5-styleplugins. It throws the qt5 library version error that we have come to know and love.

I checked all the other qt5 dependencies for Cadence, as well as my AUR installs for other qt5-related packages. I don’t see any other qt5 libs from the AUR. Several of Cadence’s qt5 dependencies from the main repos were updated this time around.

For me, the most reliable way to resolve this was to roll qt5-* back to 5.15.3. I went ahead and downgraded everything (edit: every qt5 thing, not every everything) that was upgraded yesterday, and re-re-built qt5-styleplugins.

Success: Cadence starts!

I use Cadence quite nearly every day–it is a gui front end for configuring, running, and monitoring JACK–so this will be the state of things until it works with the latest qt5 libraries. I will have to see if anything else I use is now unhappy.

If anyone wants more details on what I downgraded and how, I can provide them. Cadence’s direct dependencies are qt5-base, qt5-svg, and qt5-translations, but I downgraded any others that were at 5.15.4 and were upgraded with this most recent update.

My lingering not-quite-questions:

I do not know if the current version of Cadence was built against qt5-* 5.15.4. The Manjaro stable version is up to date with the Arch version (0.9.1-5), which says it was last updated in 2022-01-26. I would ask the maintainer, but as a Manjaro(ish) user, the scarlet M on my chest makes that a little less inviting than it might otherwise be. For now, I will keep an eye out for updates.

I also did not clean build qt5-styleplugins before panicking and downgrading all the qt5 things, but as far as I can tell, none of the sources have changed for an age or so.

A pacman hook to rebuild qt5-styleplugins whenever qt5-base updates might be useful. If I ever make one that works, I will share. Don’t hold your breath; I’ll be doing well to find time to put on socks. :slight_smile:

I can’t reproduce, cadence runs fine. Remove qt5-styleplugins and see if the issue still occurs.

OK. I’ll try that tomorrow on this desktop and report back, but I can say that I updated the laptop just now and Cadence is starting up fine on it. qt5-styleplugins is not installed there.

But now, on both machines, Ardour is hanging when I try to quit it. It has to be killed using top unless my WM notices and asks if I want it to do my dirty work.

Starting Ardour from the terminal does not reveal any useful errors–its last message is butler drops pool trash , which is apparently a debug string related to garbage collection. From audio buffer pools.

I have learned so much today! Looks like tomorrow I have an actual problem to debug, though. Thanks for listening.

Seeing an issue in LibreOffice. I receive this warning:

The master password is stored in an outdated format, you should refresh it

But I do not have a master password set. Any ideas what’s happening and how to fix it?

Since this update, every time I turn on my computer or wake it from sleep, I get prompted to enter the WiFi password for the network I automatically connect to. The same thing happens if I disconnect and reconnect to the network. Before, the password was remembered.

I’ve checked that kwalletmanager is installed and up-to-date. Its GUI doesn’t report any errors. I’ve also tried adding the password in the “Connnections” config GUI, but this has no effect (when I close and reopen the GUI the password is gone, and it still asks each time).

Edit: this persisted a reboot earlier, but I just rebooted again having reinstalled kwalletmanager and it seems alright now. @westwyv our issues sound similar, maybe give that a try.

Yeah this is pretty garbage. I switched back to FireFox for that reason alone. I don’t believe it’s Manjaro specific, but I won’t bet my house on it. I think it’s Chrome ( and thus all Chromium based browsers ) using maybe libadwaita? That was my only guess b/c the last update I think included Gnome 42 and that’s when it started. It’s quite frustrating since I actively chose not to use Gnome for multiple reasons yet they have screwed up the look and feel of the system just because they want to. I sent a report to Google on that ( since all Chromium browsers seem to do that ) but yeah, the chance they care about my report is about 0. Maybe if lots of ppl complain