[Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird

Thank you for your work Manjaro team :love_letter: .


Somehow this update broke my sound. I am running Pipewire+WirePlumber for more than a year now and did not have any problems before but after this upgrade I experienced no sound and “Dummy output”. I know about Arch announcement and despite it does not seem to apply to me I installed pipewire-media-session instead of wireplumber and it fixed my sound :person_shrugging:

WirePlumber has some issues. Hopefully they fix it in a newer version. For now use Media-Session


When will we get Official stable new isos?

I’m getting this
:: installing nvidia-utils (510.73.05-1) breaks dependency ‘nvidia-utils=510.68.02’ required by linux516-nvidia

Linux 5.16 isn’t on the list of supported Kernels, so that is probably causing it. I don’t know what the correct step for this is. Just a remainder that you guys always should check if your installed Kernel is supported. Here is a simple script that I use to check after each update: check_eol_kernel.sh and the discussion: Can I get a warning about EOL of a kernel?


I had this problem, and on reboot I received a black screen.
SOLUTION: Boot using Shift, change to 5.15 (LTS), log in, remove 5.16 kernel AFTER install some LTS kernel.

The problem was: the update remove the compatibility with 5.16, and NVIDIA drivers probabily has some issue with that.

The default install SHOULD be with LTS. (well, for me was not with LTS)


After the reboot, I had a warning saying Failed to Start Optimus Manager Commands Daemon
I was working on chroot stuff to try the update again but after 7th restart my system booted fine. Anyone has any idea what happened?

I am getting major lag with desktop UI features as well as lost functionality. Can’t click anything in the top bar including volume, wifi, and power buttons. This has been persistent since last update but was rectified with restarts. Not taking the time tonight but will update tomorrow on what is happening!

Had to do a workaround because Xorg started to misbehave on KDE Plasma. All the windows somehow got wider outlines and the screen edge “present windows” did not work.

I switched to Wayland session and everything works as expected. Hopefully won’t bump into something else.

EDIT: Had to add package xdg-desktop-portal-gtk and reboot so that dbus found more functionality because flatpak apps could not send links to my default browser on Wayland.

Same problem and same solution. Was on 5.16 kernel


After the upgrade, my desktop background is gone - it just shows a black background now. If I try to set the background image again (in Dophin, right-click on the image and set as background), nothing happens; the background stays just black. Any ideas?

might take a while as we wait for Plasma 5.25 and some fixes for Gnome 42. However your can give today’s review ISOs a spin …


After trying lots of different things I just did another reboot and then it finally worked. So issue solved (with unknown reason)…

Thank you so much! The second command solved the issue for me. You just saved me hours of debugging! Awesome!

As great as usual.
Keep up the wonderful work you are doing.


if you have another kernel intalled ( 5.15 LTS or 5.10 LTS )
reboot on theses versions kernel
suppress kernel 5.16 ( and all version EOL ), then you can update


kmymoney broken by this update, crash when save is clicked.

Output when run from terminal and save is clicked with Version 5.1.2-7

malloc(): corrupted top size
22 -- exe=/usr/bin/kmymoney
zsh: alarm      kmymoney

and with previous version Version 5.1.2-6

kmymoney: malloc.c:2617: sysmalloc: Assertion `(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)' failed.
22 -- exe=/usr/bin/kmymoney
zsh: alarm      kmymoney

Temp fix…

downgrade gnutls to 3.7.4-3 (instead of 3.7.5)

453896 – When saving a new transaction Kmymoney crashes each time without saving

This update broke git-delta for me. Seems that git-delta was built against bat v0.21.0 but the bat package is still at v0.20.0. This causes git-delta to crash immediately with the error message:

thread 'main' panicked at 'something is very wrong if the default theme is missing', /build/.cargo/registry/src/github.com-1ecc6299db9ec823/bat-0.21.0/src/assets.rs:205:22

Downgrading git-delta to v0.12.1 solved this issue for me.

1 Like

I have problems with KDE PIM. akonadictl start fails:

$ akonadictl start
org.kde.pim.akonadictl: Starting Akonadi Server...
org.kde.pim.akonadictl:    done.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: database server stopped unexpectedly
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection!
org.kde.pim.akonadiserver: executable: "/usr/bin/mysqld"
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/jonas/.local/share/akonadi/mysql.conf", "--datadir=/home/jonas/.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid")
org.kde.pim.akonadiserver: stdout: ""
org.kde.pim.akonadiserver: stderr: "2022-05-24 11:13:41 0 [Note] /usr/bin/mysqld (server 10.7.3-MariaDB) starting as process 11259 ...\n"
org.kde.pim.akonadiserver: exit code: 6
org.kde.pim.akonadiserver: process error: "Process crashed"
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...
$ akonadictl status
Akonadi Control: stopped
Akonadi Server: stopped
Akonadi Server Search Support: available (Remote Search, Akonadi Search Plugin)
Available Agent Types: akonadi_akonotes_resource, akonadi_archivemail_agent, akonadi_birthdays_resource, akonadi_contacts_resource, akonadi_davgroupware_resource, akonadi_etesync_resource, akonadi_ews_resource, akonadi_ewsmta_resource, akonadi_followupreminder_agent, akonadi_google_resource, akonadi_ical_resource, akonadi_icaldir_resource, akonadi_imap_resource, akonadi_indexing_agent, akonadi_knut_resource, akonadi_kolab_resource, akonadi_maildir_resource, akonadi_maildispatcher_agent, akonadi_mailfilter_agent, akonadi_mailmerge_agent, akonadi_mbox_resource, akonadi_migration_agent, akonadi_mixedmaildir_resource, akonadi_newmailnotifier_agent, akonadi_notes_agent, akonadi_notes_resource, akonadi_openxchange_resource, akonadi_pop3_resource, akonadi_sendlater_agent, akonadi_tomboynotes_resource, akonadi_unifiedmailbox_agent, akonadi_vcard_resource, akonadi_vcarddir_resource

EDIT: starting manually:

mysqld --defaults-file=/home/jonas/.local/share/akonadi/mysql.conf --datadir=/home/jonas/.local/share/akonadi/db_data/ --socket=/run/user/1000/akonadi/mysql.socket --pid-file=/run/user/1000/akonadi/mysql.pid
2022-05-24 11:20:53 0 [Note] mysqld (server 10.7.3-MariaDB) starting as process 12764 ...
Aborted (core dumped)

coredumpctl info 12764 → Stacktrace akonadi MariaDB stack trace from `coredumpctl info` · GitHub

$HOME/.local/share/akonadi/db_data/mysql.err has many errors like this:

2022-05-24 12:15:35 0 [ERROR] InnoDB: Page [page id: space=0, page number=2] log sequence number 819501819 is in the future! Current system log sequence number 798199832.
2022-05-24 12:15:35 0 [ERROR] InnoDB: Your database may be corrupt or you may have copied the InnoDB tablespace but not the InnoDB log files. Please refer to https://mariadb.com/kb/en/library/innodb-recovery-modes/ for information about forcing recovery.
2022-05-24 12:21:19 0 [Note] InnoDB: 128 rollback segments are active.
2022-05-24 12:21:19 0 [Note] InnoDB: Removed temporary tablespace data file: "./ibtmp1"
2022-05-24 12:21:19 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2022-05-24 12:21:19 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2022-05-24 12:21:19 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2022-05-24 12:21:19 0 [Note] InnoDB: 10.7.3 started; log sequence number 798199820; transaction id 1519280
2022-05-24 12:21:19 0 [Note] InnoDB: Loading buffer pool(s) from /home/jonas/.local/share/akonadi/db_data/ib_buffer_pool
2022-05-24 12:21:19 0x7f7ce3fff640  InnoDB: Assertion failure in file /build/mariadb/src/mariadb-10.7.3/storage/innobase/include/fut0lst.h line 128
InnoDB: Failing assertion: addr.page == FIL_NULL || addr.boffset >= FIL_PAGE_DATA

Is it advisable to set a recovery mode as indicated by the [ERROR] message?

Temporary Downgrade to mariadb 10.6 yields the same errors.

I’ve reset the databases:

mv ~/.local/share/akonadi ~/.local/share/akonadi_BACKUP
akonadictl start
# ignore some errors
akonadictl stop
# wait
akonadictl start

→ seems I have not lost any settings :slight_smile: Since all my (relevant) resources are in Nextcloud/gmail/company IMAP, they are now being redownloaded.

1 Like