[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0

I have font issue. The font in thunar looks different before update.

Manjaro/XFCE stable here, arrived today (2022-05-16) and after upgrading Timeshift to 21.09.1-4 and rsync to 3.2.4-1 again (from downgraded 3.2.3-4) I can confirm it works as intended.

N.B.: Don’t forget to remove your IgnorePkg = rsync line in /etc/pacman.conf if you added one!

1 Like

Hi Community,

I am using Manajro Gnome and I have upgraded from pacman -Syu today. After the upgrade, I found my app themes are not consistent.

Here are screenshots:

and in my gnome tweaks, the themes are configured as below

and /etc/environment configuration as below

#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#

QT_AUTO_SCREEN_SCALE_FACTOR=1

QT_QPA_PLATFORMTHEME="gnome"

QT_STYLE_OVERRIDE="kvantum"


# Force to use Xwayland backend
# QT_QPA_PLATFORM=xcb

#Not tested: this should disable window decorations
# QT_WAYLAND_DISABLE_WINDOWDECORATION=1

EDITOR=/usr/bin/nano

I have searched the forum, but I haven’t figured out what happened here.

Thanks in advance

Hi, during update of libkipi I have a message:

The PGP key D81C0CB38EB725EF6691C385BB463350D6EF31EF is needed to verify libkipi source files.
Trust Heiko Becker heiko.becker@kde.org and import the PGP key ?

Should I click trust?

There is also:
aacid@kde.org, cfeck@kde.org

Wondering if any other Gnome users have come across this issue?

When I go to settings and enable ‘Dark’ style it changes everything as expected to Dark mode, however after a while (even without a reboot) it changes back to Light mode and I have to manually select Dark mode in settings again.

Any fix that anyone is aware of?

Not even from Known issues and solutions in the first reply?

1 Like

After update, mouse after 2-5 clicks in gnome settings, firefox (may be in other apps) not responce. Gnome + wayland session. In Xorg everything allright.

@elendrilex Deactivate in ‘Layouts’ > Settings > Automatic dark theme = Off

so after the update im getting following message at shutting down and booting:

cp: cannot create directory '/run/initframs/': no such file or directory

didnt find anything on how to solve this…

Probably this: FS#74534 : [mkinitcpio] shutdown hook copy

yes looks like thats it, but unfortunately no solution …

as mentioned above in this thread, libkipi has been moved to AUR and is not needed anymorefor packages from the official repositories so you might want to uninstall it.
Should you want to keep it anyhow, because you are using a package from AUR the still requires it, then yes, you need to accep the sigs from the AUR package. This is alsways required and the risk you have to take using packages from AUR.

1 Like

You can try YOLO style by editing /usr/lib/initcpio/hooks/shutdown:

#!/usr/bin/ash

run_cleanuphook() {
    rm -rf /usr/lib/modules
    cp -ax / /run/initramfs
}

# vim: set ft=sh ts=4 sw=4 et:

and add install -dm0755 /run/initramfs before that cp. :smiley:

my file looks the same as what you provided… switched to 5.15 kernel, and after running sudo mkinitcpio -P, didnt see those messages again… so ill wait if they appear again, hopefully not, and then try YOLOing haha

Weird (unless linux515.preset uses different hooks). Anyhow, shutdown hook is only needed if you have separate /usr partition: mkinitcpio -H shutdown

i dont have any separate /usr partition
output from: mkinitcpio -H shutdown:

==> Help for hook 'shutdown':
This hook copies the contents of the initramfs into /run/initramfs for reuse
on shutdown. This is needed when you have /usr mounted on a separate partition.

==> This hook has runtime scripts:
  -> cleanup hook

Thanks for your replies! I’ve figured it out!

Turns out I had gnome-control-center-x11-scaling installed rather than gnome-control-center, not sure why I had that installed. So I just did:

$ sudo pacman -Sy gnome-control-center

then

:: gnome-control-center and gnome-control-center-x11-scaling are in conflict. Remove gnome-control-center-x11-scaling? [y/N] y

and voila!

1 Like

Dash-to-Dock has an issue that causes extensions app to disable all controls.
I reported it to the github page, but also here since its bundled with manjaro.
There were 2 d2d updates yesterday & today, but the issue remains. v72

  1. Open gnome-extensions or gnome-extensions-manager
  2. edit settings on dash-to-dock (don’t need to change anything)
  3. close settings
  4. after a moment, the Extensions app becomes disabled.

Then check your hooks in /etc/mkinitcpio.conf - shutdown hook isn’t needed. (if it’s not there, then :person_shrugging: )

My system boots from its normal SSD. Do I need to chroot from USB? And when I boot from USB and do something like sudo manjaro-chroot -a, what do I do next?