[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0

5 posts were split to a new topic: I cannot upgrade libkipi

It looks like some pamac dependency resolving issue. Gwenview and Spectacle required libkipi before this update, but new versions don’t. But for some reason upgrade insists of installing libkipi from AUR. I just installed new versions of gwenview and spectacle manually with --no-upgrade flag and then full upgrade did not prompt me to reinstall libkipi from AUR.

8 posts were split to a new topic: Timeshift issues

That’s the problem, libkipi was required by some apps before update and trying to remove it says smth like removing libkipi breaks dependency libkipi required by gwenview. So I cannot just remove it before upgrade. And why pamac insists on building this package from AUR when it is not required by new app versions - that’s a question.

2 Likes

Thank you, now it work “out of the box” for me! :blush:

Thank you philm and the Manjaro team,
on behalf of all the owners of a XPS 13, because this stable update got our fingerprint to work again.
You are the best! :heart_eyes:

After upgrading, my system has no sound. The sound output becomes Dummy Output.

P.S.

I installed sof-firmware and the sound works again.

1 Like

Thank you for fixing the problem with xfce4-terminal that had broken in the previous stable update.

Problem: [Stable Update] 2022-04-15 - Kernels, Mesa, Nvidia, Budgie, PipeWire, LIbreOffice, KDE Frameworks, Wine - #4 by haha

Solution: Use the current stable update (2022-05-13) and the proper behavior of Ctrl-Shift-PgUp and Ctrl-Shift-PgDn has been restored.

i haven’t updated yet;
libkipi is from the official repositories.

pacman -Qi libkipi                                                                                                           ✔ 
Name            : libkipi
Version         : 21.12.3-1
Description     : An interface to use kipi-plugins from a KDE application
Architecture    : x86_64
URL             : https://www.kde.org/
Licenses        : GPL  LGPL  FDL
Groups          : None
Provides        : None
Depends On      : kxmlgui  kservice  hicolor-icon-theme
Optional Deps   : None
Required By     : gwenview  spectacle
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 273.86 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Tue 01 Mar 2022 10:56:04
Install Date    : Mon 14 Mar 2022 18:10:24
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature
2 Likes

After this update, the (GNOME) Activities app launcher does not work for me.
For instance:

  1. Click on Activities menu (or hit the Windows key)
  2. Enter anything in “Type to search” zone (for instance 'Emacs")
  3. Click on the “Emacs” icon that shows up (or any other app): nothing happens.

Anyone having the same issue here?

1 Like

The problem is that GDM have updated their udev rules to not enable wayland for nvidia cards if certain power management features are not set up. Specifically, these lines in /usr/lib/udev/rules.d/61-gdm.rules

# Check if suspend/resume services necessary for working wayland support is available
TEST{0711}!="/usr/bin/nvidia-sleep.sh", GOTO="gdm_disable_wayland"
TEST{0711}!="/usr/lib/systemd/system-sleep/nvidia", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c \"sed -e 's/: /=/g' -e 's/\([^[:upper:]]\)\([[:upper:]]\)/\1_\2/g' -e 's/[[:lower:]]/\U&/g' -e 's/^/NVIDIA_/' /proc/driver/nvidia/params\""
ENV{NVIDIA_PRESERVE_VIDEO_MEMORY_ALLOCATIONS}!="1", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_HIBERNATE=`systemctl is-enabled nvidia-hibernate`'"
ENV{NVIDIA_HIBERNATE}!="enabled", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_RESUME=`systemctl is-enabled nvidia-resume`'"
ENV{NVIDIA_RESUME}!="enabled", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_SUSPEND=`systemctl is-enabled nvidia-suspend`'"
ENV{NVIDIA_SUSPEND}!="enabled", GOTO="gdm_disable_wayland"
LABEL="gdm_nvidia_end"

To fix this I had to enable a bunch of services and add a kernel parameter. Like so

sudo systemctl enable nvidia-hibernate
sudo systemctl enable nvidia-resume
sudo systemctl enable nvidia-suspend
echo 'options nvidia NVreg_PreserveVideoMemoryAllocations=1' | sudo tee /etc/modprobe.d/nvidia-power-management.conf
sudo mkinitcpio -P
2 Likes

I am having the same issue with libkipi and the key causing a failure to build. Any ideas how to fix this?

After the update succeeded; the pamac GUI popped up a message that updating/building libkipi had failed (which overwrote the “reboot required” popup).

Taking the hint from others that it was a no longer required library for the new KDE packages that used to use it, i checked for orphans, found libkipi listed, uninstalled it, and rebooted.

Post reboot after the update when firefox launched, it was like it contained a snapshot of what was on the desktop as opposed to rendering my saved sessions last site visited (nor it’s accompanying tabs). Tried launching another firefox instance and it behaved the same. The fix was two-fold:

  1. Logging out and back in corrected the firefox rendering (no more desktop “snapshot”)
  2. Recovered my ~/.mozilla/firefox/<profile>/sessionstore-backups/ files from Back In Time to restore my saved sessions/tabs… oh and I also deleted the ~/.mozilla/firefox/<profile>/sessionstore.jsonlz4 file to ensure firefox used the restored session backups

There is a known issue with latest RSYNC and TimeShift, discussed here incompatibility with latest rsync 3.2.4 · Issue #891 · teejee2008/timeshift · GitHub, people should provide info there for a quicker fix.

5 Likes

Hi everyone. Thanks for the update!

It seems that the builtin extension vertical-overview is not working now. A post in the extension page mentions it works fine on Gnome 42 on Fedora.

Any ideas on what I can do to fix it? I can’t stand the horizontal workspace paradigm.

ps: this error is given:
GObject_Object.prototype.[__GObject__hook_up_vfunc] called on incompatible Object

Smooth update overall, thanks to the Manjaro team :slight_smile:

The only little “issue”, but it’s related to an AUR package, so …, is a required rebuild of ckb-next (seems to be related to libquazip1-qt5 update).

Update worked fine for. Just want to mention one issue again, so people are aware.

I have kernels 5.10, 5.15 and 5.17 installed. I was using 5.15 as a default kernel, because 5.17.1 couldn’t resume from hibernate on my hw (intel Haswell, using iGPU). After running the update and reboot, the system booted by default to 5.17, not my previous default 5.15. IMHO, it should only change the default kernel if the old default is not present anymore, making it a conscious decision to use another kernel.

n.b.:
The hibernation issue seems to be fixed in 5.17.6 on my machine.

1 Like

Still no official Matcha or libadwaita supported modern theme for the legacy GTK4 apps in Gnome 42 (control-center, clocks, maps, etc…).
Outdated libadwaita apps are back in the 90’s. We need Matcha to bring them back in the future and on par with the more modern GTK apps (from before libadwaita).

2 Likes

See the second top reply.