[Stable Update] 2022-03-14 - Kernels, KDE, LibreOffice, Kodi, Qt5, Mozilla, NetworkManager, Pipewire

As a note: upgrading libvirt in this update has different directory permission requirements on /etc/libvirt/secrets/
before: 700
after update: 755

libvirt warning
warning: directory permissions differ on /etc/libvirt/secrets/
filesystem: 700  package: 755

After the update (since my first message), KDE (Plasma wayland + pipewire) just crashed, but restarted on its own

so i would recommend if using KDE Plasma Wayland (+ Pipewire) to be careful to not have anything important open when installing this update

Update: the restarted KDE was more brocken than it was usable, so i had to reboot (like KDE just dosnt want to start some applications and didnt let me logout, which froze the whole KDE stack)

For me the update is broken I get the following error:
could not satisfy dependencies:

  • removing lib32-libjpeg-turbo breaks dependency ‘lib32-libjpeg’ required by lib32-gdk-pixbuf2
  • removing lib32-libjpeg-turbo breaks dependency ‘libjpeg.so=8-32’ required by lib32-libtiff

Resolved not all mirrors were synced


10 posts were split to a new topic: No network after laptop rebooted during updating

I’m here to report that the latest Qt update broke everything Qt related. The aforementioned report with the message

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)

is where Qt based programs bail out. So far I’m counting VLC, KeepassXC and Nextcloud. Curious to see what else will break.


As I mentioned: AUR packages like qt5-styleplugins need a rebuild against the new Qt5 packages …


Thanks, that fixed it. I wasn’t sure what needed to be rebuilt there.

When in doubt: rebuild all AUR packages (preferrably before posting :slight_smile: ).

1 Like

It’s solved
Thank you

There’s a known bug in Firefox 98 with hardware acceleration.


When upgrading to 5.16.14-1, all my audio devices are gone and there’s no sound. It was working in 5.15 (Thinkpad X1 Carbon Gen 9)

EDIT: Ended up messing around with uninstalling and reinstalling packages like manjaro-pipewire and got audio working again.

A post was split to a new topic: My internet connection is no longer working

I am using Manjaro XFCE. Qt apps like Okular and Gwenview no longer work.

$ okular
Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
Aborted (core dumped)

My first idea would be that you didn’t update qt5 before building for your repository.

1 Like

Is there any action required for this?

I did some cleaning in the issue log. I suggest we note the associated update date from now on, so we can more easily clean obsolete logs.


Yup works now. Thanks

1 Like

Had to set user=myuser and group=libvirt in /etc/libvirt/qemu.conf.
I wonder how this was able to work before the update :thinking: