[Stable Update] 2022-02-05 - Kernels, LibreOffice, KDE Gear, Nvidia, Calamares, VirtualBox, Pipewire, Mesa, Systemd

Same for me, using
sudo pacman -S pipewire-jack
as specified by another user, does not fix the issue.

I had the same dependency problem and I did the following:
I ran

sudo pacman -Sdd pipewire-jack

This reinstalled pipewire-jack and removed jack2 but left lib32-jack2. So I forcefully removed only lib32-jack2 with

sudo pacman -Rdd lib32-jack2

Then I proceeded with the update as usual and it asked me for a provider for lib32-jack.so. I chose pipewire and was able to update successfully.

This way you don’t have to remove other packages like portaudio and fluidsynth which depend on lib32-jack2 and jack2.

Note: The first -d skips version checks and the second -d skips dependency checks.


I had to extend it to this
pacman -R lib32-jack2 lib32-portaudio lib32-fluidsynth jack2


same here
i had to remove cadencetoo, which depends on jack2-dbus

it’s a useful tool for me, any chance to install it without removing pipewire-jack?


now my synthv1 shows up in Helvum (pipewire patchbay), so Catia (Cadence) is not needed anymore for patching jack2 outputs

Keyboard and trackpad are not working after the update.

I am having the same issue I have stated here:

is it due to libinput update, or because of kernels, I am not sure.

Is this normal? It’s taking a while

This was mentioned as a new issue in Testing Update 2022-02-04

:pencil2: post#2 edited to add this as a new issue


Possibly missing firmware when installing the kernel linux-5.16.5-1-MANJARO.

WARNING: Possibly missing firmware for module: xhci_pci

The first boot after the upgrade, the kernel message shows the following error,

kernel: Bluetooth: hci0: FW download error recovery failed (-110)
kernel: Bluetooth: hci0: sending frame failed (-19)
kernel: Bluetooth: hci0: Failed to read MSFT supported features (-110)
kernel: Bluetooth: hci0: command 0xfc1e tx timeout

However, my Bluetooth adaptor seems to be working. My device is

ID 8087:0029 Intel Corp. AX200 Bluetooth

When I connected my Sony DualSense controller, the kernel message shows

Bluetooth: hci0: Failed to read codec capabilities (-56)
1 Like

Upgrade went fine, but one minor issue. I checked for orphaned packages after the update and got the following:

> pamac list -o
celt           0.11.3-4  extra  180.1 kB
pamac-gtk      10.3.0-4  extra  726.3 kB
zita-alsa-pcmi 0.4.0-1   extra  79.8 kB
zita-resampler 1.8.0-1   extra  202.6 kB

I removed all of them after checking that they are not required anymore, already wondering about pamac-gtk. When I now check for obsolete packages again it shows

> pamac list -o
pamac-cli 10.3.0-4  extra  206.7 kB

Installation details for the package show that it has been installed as a dependency for another package, but is currently not required by anything anymore

pamac info pamac-cli
> pamac info pamac-cli
Name                  : pamac-cli
Version               : 10.3.0-4
Description           : A Package Manager based on libalpm with AUR and Appstream support
URL                   : https://gitlab.manjaro.org/applications/pamac
Licenses              : GPL3
Repository            : extra
Installed Size        : 206.7 kB
Groups                : --
Depends On            : libpamac>=11.0
Optional Dependencies : --
Required By           : --
Optional For          : --
Provides              : pamac-cli=10.3.0-4 pamac-zsh-completions
Replaces              : --
Conflicts With        : pamac<=7.3.4-2 pamac-aur pamac-cli-dev pamac-zsh-completions
Packager              : Philip Mueller <philm@manjaro.org>
Build Date            : 2022-01-26 22:20:32 Wed
Install Date          : 2022-02-03 12:22:41 Thu
Install Reason        : Installed as a dependency for another package
Validated By          : Signature
Backup files          : --

I could probably fix this by marking it as explicitly installed, but I wonder if others see the same and if that might cause problems for users who automatically and recursively uninstall orphaned packages.

I couldn’t upgrade my system initially because jack2 and pipewire-jack are now in conflict. I also couldn’t manually uninstall jack2 due to it being a dependency for some other packages.

To resolve, I simply unchecked jack2 in the list of packages to upgrade. This prompts pamac to remove jack2 while upgrading pipewire-jack.

Found my solution here: https://www.reddit.com/r/archlinux/comments/s7hcuc/comment/htb35pc/?utm_source=share&utm_medium=web2x&context=3

1 Like

i had to remove lib32-fluidsynth and lib32-jack2 manually to install/upgrade pipewire-jack which removes jack2.

its solved for me.

Got on the first run of pacman:

nvidia-utils-510.47.03-4-x86_64.pkg.tar.zst failed to download
error: could not rename /var/cache/pacman/pkg/nvidia-utils-510.47.03-4-x86_64.pkg.tar.zst.part to /var/cache/pacman/pkg/nvidia-utils-510.47.03-4-x86_64.pkg.tar.zst (No such file or directory)

Seems like it wanted to rename it two times and second one is failed, because after this message this file already there with proper name.

Then on the second run:

error: nvidia-utils: signature from "Mark Wagie <mark@manjaro.org>" is invalid
:: File /var/cache/pacman/pkg/nvidia-utils-510.47.03-4-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

So I can’t upgrade my system

Seems it’s resolved now

Updated successfully to 5.16.5-1-MANJARO and Nvidia 510.47.03 (GeForce RTX 3070).
Can anybody confirm is it safe to remove nvidia-fake-powerd? Is driver spamming dbus-enabled applications with invalid messages fixed?


1 Like

Anyone else coming here please note that pamac the GUI updater cannot make the changes or perform the upgrade, don’t ask why. You have to use pacman from a ‘terminal’.
As noted
sudo pacman -S pipewire-jack
agree to all the changes
sudo pacman - Syyu

or one of the ‘recipes’ here : Pacman Overview - Manjaro.

For anyone interested the Arch maintainers announced this change 3 weeks ago:

I’m thankful for all the discussion around the jack2/pipewire-jack conflict. For some reason for me, pacman would not upgrade the pipewire-jack package, only reinstall (tried with -S and -Sdd)…

$ sudo pacman -S pipewire-jack
warning: pipewire-jack-1:0.3.43-1 is up to date -- reinstalling
looking for conflicting packages...

Packages (1) pipewire-jack-1:0.3.43-1

and this had me concerned about using the pamac GUI option mentioned (since pamac/pacman do/accomplish similar things, and even share a log file)…

Until I discovered that command line pamac would take care of both the upgrade and jack2 removal…

$ pamac install pipewire-jack
Resolving dependencies...
Checking inter-conflicts...

To upgrade (1):
  pipewire-jack  1:0.3.45-1  (1:0.3.43-1)            extra  152.5 kB
To remove (1):
  jack2          1.9.20-3    (Conflicts With: jack)  extra

Not sure why pacman gave no joy, but pamac seemed to have stepped up.

Oops… spoke too soon. After letting answering “Y” to apply the transaction, pamac quickly shot out “Transaction successfully finished.” without making any changes? If i run the below command back-to-back… it repeats itself thinking there’s an update and conflict to resolve… and the pamac GUI still shows jack2 installed with pipewire-jack still not upgraded.

$ pamac install pipewire-jack
Resolving dependencies...
Checking inter-conflicts...

To upgrade (1):
  pipewire-jack  1:0.3.45-1  (1:0.3.43-1)            extra  152.5 kB
To remove (1):
  jack2          1.9.20-3    (Conflicts With: jack)  extra

Total download size: 152.5 kB
Total installed size: 198.7 kB
Total removed size: 2.0 MB

Apply transaction ? [y/N] y
Transaction successfully finished.

I seem to be having issues with both pamac and pacman and not sure why. :man_shrugging:

I do know my mirrors are up to date and in sync…

$ pacman-mirrors
Pacman-mirrors version 4.23.2
Local mirror status for stable branch
Mirror #1   OK  02:17   Canada  https://muug.ca/mirror/manjaro/
Mirror #2   OK  04:40   Canada  https://mirror.csclub.uwaterloo.ca/manjaro/
Mirror #3   OK  00:20   Canada  https://osmirror.org/manjaro/
Mirror #4   OK  01:17   Canada  https://mirror.0xem.ma/manjaro/

EDIT: Thought I’d try a reboot, but no change… neither pamac nor pacman will upgrade pipewire-jack and resolve jack2 via the command line

Wifi device not recognized after Update - Surface Pro 3 (Marvell 88W8897 [AVASTAR] 802.11ac Wireless)

kernel: mwifiex_pcie 0000:01:00.0: enabling device (0000 -> 0002)
kernel: mwifiex_pcie: PCI memory map Virt0: 00000000a5efdaee PCI memory map Virt2: 000000007951e1be
kernel: mwifiex_pcie 0000:01:00.0: Direct firmware load for mrvl/pcie8897_uapsta.bin failed with error -2
kernel: mwifiex_pcie 0000:01:00.0: Failed to get firmware mrvl/pcie8897_uapsta.bin

Needed manual offline firmware (linux-firmware-marvell) installation after the update.
The update routine does not care about:

Installiere linux-firmware-whence (20220119.0c6a7b3-3)...
Erneuere linux-firmware (20211027.1d00989-1 -> 20220119.0c6a7b3-3)...
Erneuere linux510 (5.10.89-1 -> 5.10.96-1)...

Arch split their firmware package and the normal does not include marvell firmware any more. See #721 and #723. Installing linux-firmware-marvell should fix this.

1 Like

There’s an open bug report: FS#73588 - ffmpeg4.4 cannot be installed: cannot resolve “libx264.so=164-64”

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: jack2 and pipewire-jack are in conflict