[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

I am not sure but you might want to set it in Appearance - Fonts instead of SDDM.

@jpalko Thank you for your help in the previous topic.

Apparently it was not a smart idea of me to remove an old video-nvidia-3xx driver and use the generic(?) video-nvidia driver and update the system afterwards rightaway.

After reboot my cpu governor was in powersave state. But i could be fixed with cpupower.

Everything else works fine so far.

About python packages, do I also need to reinstall --user installed packages as well?

If you’re experiencing boot issues with optimus-manager 1.4-3, uninstall it and use optimus-manager-git 1.4.1 from the AUR instead.

1 Like

Happy New Year :tada: :confetti_ball:, and thank you for another smooth update! Only thing “odd” I noticed was a downgrade to manjaro-hello.

I have questions about the Python 3.10 upgrade and “leftovers” I found in ~/.local/lib/python3.9 and /usr/lib/python3.9 I’ve asked @ Python 3.9 to 3.10 validation and cleanup


EDIT: I did notice I had a bluetooth “issue” in journalctl after the update reboot:

$ journalctl --priority err --boot 0
Jan 02 10:34:30 AM4-5600X-Linux bluetoothd[791]: Failed to set mode: Blocked through rfkill (0x12)

Now, this might have been because I had bluetooth “disabled” in the KDE plasma panel… but I performed the following commands just to be sure:

  • $ sudo rfkill unblock bluetooth
  • $ sudo systemctl restart bluetooth

A post was split to a new topic: Conflicting files during latest stable update

This does not give all Python packages from AUR only, it gives all Python packages from AUR and from the repos.
Wouldn’t it better to do this instead ?

pacman -Qm $(pacman -Qqo /usr/lib/python3.9)

If run after the update (which you should do before rebuilding) then it wont return any repo packages.

2 Likes

Had to remove Green With Envy and reinstall so it reinstalled its dependencies properly, but other than that went smoothly. Only 1 thing to upgrade to Python 3.10 - patool

Problem in KiCad 6. Switching language doesn’t work.

Error
Unable to switch language to Deutsch
The KiCad language file for this language is not installed.

Perhaps there are some ‘kicad-locale’ packages missing? :grin:

Can’t find KiCad in Manjaro-gitlab but at CMakeList.txt from KiCad-gitlab building “translation libraries” is set “OFF” at the moment.

option( KICAD_BUILD_I18N
“Build the translation libraries.”
OFF )

Yes, the thing is that it shouldn’t be necessary. This happened because of a regression and this update should fix this, but for some reason it doesn’t in my case, so I’m wondering why

I have python 3.9.9 . you said the python updated to version 3.10

Pamac freezed at the beginning of the update.
I have used

sudo pacman -Syu

And all was OK.

You did see this, right? :wink:

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

Why is yay recommended to update AUR packages if pamac can do it anyway? Or is this something different (I don’t know much about this, that’s why I ask):

$ pamac build --help
Build packages from AUR and install them with their dependencies
1 Like

3.10 is newer than 3.9.9

No, it is not different. I always wonder too - why everyone is using some weird things when pamac exists OOB. I personally did pamac build $(pacman -Qoq /usr/lib/python3.9) and it worked flawlessly.

1 Like

Thank you for the confirmation. I was about to do that too, but was not sure. Note: I thought maybe because the flag --answerclean All, which pamac does not have. Did you have to answer for every package? I have 164 packages.

No, it listed all packages it was going to install/reinstall/delete and asked for confirmation one time. As if you tried to install multiple packages with pamac.