[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

We have a grub.pacnew file to look at,
otherwise al fine, including rebuilds aginst python 3.10 .


I have created a log file of pacman -Syyu and removed the files with rm -v /path/to/file.

Now the update went fine.

But during update process, another error is display no font config found for console.

optimus-manager broken after update.

$ optimus-manager --status
Traceback (most recent call last):
  File "/usr/bin/optimus-manager", line 33, in <module>
    sys.exit(load_entry_point('optimus-manager==1.4', 'console_scripts', 'optimus-manager')())
  File "/usr/bin/optimus-manager", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 919, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 518, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for optimus-manager

Edit: Resolved by uninstalling optimus-manager, rebooting, re-installing optimus-manager and rebooting again.


When I open Steam, I see that it works fine.

But I got the error from journalctl -p 3 -b while starting Steam using amdvlk for AMD Radeon GPU.

systemd-coredump[9729]: [🡕] Process 9726 (vulkandriverque) of user 1000 dumped core.
                                              Module /home/zesko/.local/share/Steam/ubuntu12_64/vulkandriverquery with build-id ac0445e362400ff36a439c9a4a5a313a2bc0a109
                                              Module linux-vdso.so.1 with build-id 33391ff5d8b361d70dd5922e8d2b5c1b451401bb
                                              Module libcrypto.so.1.1 with build-id 4c926b672d97886b123e03a008387aecf0786de4
                                              Module libssl.so with build-id 1024424ab33a3767da03f4fdb1fc1b02479f160f
                                              Module libicudata.so.70 with build-id e1dcc2a88cfaafed882d09c90c668af0eed4efed
                                              Module liblzma.so.5 with build-id 8b615460aa230708c5183f16bede67aa0437d95e
                                              Module libicuuc.so.70 with build-id 2e245c2bf12f95fd8ab79b3a4be99524677cbd70
                                              Module libXdmcp.so.6 with build-id 8ca0792d23c8b8b4c0864297512349292bea5955
                                              Module libXau.so.6 with build-id 1c67764663e07bec24d8951e5fd93f4d165979ff
                                              Module libxml2.so.2 with build-id b710b880b0d4e9c93554fa632129db44c20632cd
                                              Module libncursesw.so.6 with build-id 859adb8b03a5655151b4da104bc4b326a0d4bc8c
                                              Module libedit.so.0 with build-id 4b0babfcad161c2ad0af6e59e2493258db23a331
                                              Module libffi.so.8 with build-id f90d8b734f6de9b25faedb8cbfab7054dafc0a42
                                              Module libdrm.so.2 with build-id 457a1a1bd25f1d5541a10d3f16c5dc1440d77c7d
                                              Module libxshmfence.so.1 with build-id 8876d9ccf620858795724ca24b9e567585a77cec
                                              Module libxcb-shm.so.0 with build-id fb797f299a446f559a95afcc168227482cc800d1
                                              Module libxcb-randr.so.0 with build-id b6c1c7d4b28863b55ade251813db7f246b7ffe8b
                                              Module libxcb-sync.so.1 with build-id dda14591103b01b1311906053bf1ca9e82ade35c
                                              Module libxcb-present.so.0 with build-id 68f5465258750e2397b1333b3ffc01ee33caa4e1
                                              Module libX11-xcb.so.1 with build-id 0db4f94d8ae31b8dc9a83f825a9171656f1e532c
                                              Module libxcb.so.1 with build-id 0d1ef11740a5daad2ee331e812a51aa6574af222
                                              Module libzstd.so.1 with build-id 6214183688018e3fba6d66db10c2c8d0b45e0578
                                              Module libexpat.so.1 with build-id 16023a53e7b5bbdff92bd0bf2eebd36f9b5b879f
                                              Module libz.so.1 with build-id 0c1459c56513efd5d53eb3868290e9afee6a6a26
                                              Module libwayland-client.so.0 with build-id 0a237f2fd096bada4ca381eec5d64474c4078be4
                                              Module libxcb-dri3.so.0 with build-id 9407a2480e09dc5a1dd9d9a0652fa8d32b328c91
                                              Module libelf.so.1 with build-id a4fb077dcec6ee26a5fab1fa10c59bd03b1078e4
                                              Module libdrm_amdgpu.so.1 with build-id 30d019987d514b23115b47d6b47c1e45c18fdbaf
                                              Module libLLVM-13.so with build-id 82982c299d46219d0eab8ee9cb8bb7365483453b
                                              Module libvulkan_radeon.so with build-id 5acf9134b163454e51e06337deb316d61a1f3243
                                              Module amdvlk64.so with build-id 45a23aea5cfa127688d1c3f041b9f9d570f748c1
                                              Module libpthread.so.0 with build-id 07c8f95b4f3251d08550217ad8a1f31066229996
                                              Module libvulkan.so.1 with build-id 0c8486d8689e18bd837da80fe4d17664a248bc10
                                              Module libgcc_s.so.1 with build-id 7f8508bb914546ada778809b64b99d234337d835
                                              Module libm.so.6 with build-id 2b8fd1f869ecab4e0b55e92f2f151897f6818acf
                                              Module ld-linux-x86-64.so.2 with build-id 040cc3dd10461562f177df39e3be2f3704258c3c
                                              Module libc.so.6 with build-id 4b406737057708c0e4c642345a703c47a61c73dc
                                              Module libstdc++.so.6 with build-id 9b5eeeb149bf3c4efe787fb398b44f00507aec87
                                              Module libdl.so.2 with build-id 5abc547e7b0949f89f3c0e21ab0c8331a7440a8a
                                              Stack trace of thread 9726:
                                              #0  0x00007fcd73d92d22 raise (libc.so.6 + 0x3cd22)
                                              #1  0x00007fcd73d7c862 abort (libc.so.6 + 0x26862)
                                              #2  0x00007fcd73dd4d28 __libc_message (libc.so.6 + 0x7ed28)
                                              #3  0x00007fcd73ddc92a malloc_printerr (libc.so.6 + 0x8692a)
                                              #4  0x00007fcd73dddcfc _int_free (libc.so.6 + 0x87cfc)
                                              #5  0x00007fcd73de19e8 __libc_free (libc.so.6 + 0x8b9e8)
                                              #6  0x00007fcd72176095 n/a (amdvlk64.so + 0x1697095)
                                              #7  0x00007fcd72189f82 n/a (amdvlk64.so + 0x16aaf82)
                                              #8  0x00007fcd721a5cba n/a (amdvlk64.so + 0x16c6cba)
                                              #9  0x00007fcd721a70f0 n/a (amdvlk64.so + 0x16c80f0)
                                              #10 0x00007fcd7246aa24 n/a (amdvlk64.so + 0x198ba24)
                                              #11 0x00007fcd7246b4d4 n/a (amdvlk64.so + 0x198c4d4)
                                              #12 0x00007fcd728f6d81 n/a (amdvlk64.so + 0x1e17d81)
                                              #13 0x00007fcd71146cbf n/a (amdvlk64.so + 0x667cbf)
                                              #14 0x00007fcd7101da6b n/a (amdvlk64.so + 0x53ea6b)
                                              #15 0x00007fcd71020ea0 n/a (amdvlk64.so + 0x541ea0)
                                              #16 0x00007fcd70e17354 n/a (amdvlk64.so + 0x338354)
                                              #17 0x00007fcd70df8ca9 n/a (amdvlk64.so + 0x319ca9)
                                              #18 0x00007fcd70dfa462 n/a (amdvlk64.so + 0x31b462)
                                              #19 0x00007fcd729cbfed n/a (amdvlk64.so + 0x1eecfed)
                                              #20 0x00007fcd73bade2c n/a (libvulkan.so.1 + 0x2fe2c)
                                              #21 0x00007fcd73bb7d9f n/a (libvulkan.so.1 + 0x39d9f)
                                              #22 0x00007fcd73bb8c45 n/a (libvulkan.so.1 + 0x3ac45)
                                              #23 0x00007fcd73bbcfb8 vkCreateDevice (libvulkan.so.1 + 0x3efb8)
                                              #24 0x00005572d2db3fdd n/a (/home/zesko/.local/share/Steam/ubuntu12_64/vulkandriverquery + 0x4fdd)
                                              ELF object binary architecture: AMD x86-64

It seams amdvlk 2021.Q4.3-1 is incompatible with the file $HOME/.local/share/Steam/ubuntu12_64/vulkandriverquery from Steam.

  1. Solution:
    Downgrade to amdvlk 2021.Q4.2-1. This error is gone.

  2. Solution: (Recommend)
    Uninstall amdvlk and lib32-amdvlk, because vulkan-radeon already exists.

PS: I noticed that vulkan-radeon has better performance and is smoother than amdvlk when playing Game!

Edit:// amdvlk was fixed today:

1 Like

I left my current grub configuration and removed the pacnew no boot problems or other…

A post was split to a new topic: Nethack: cannot write scoreboard file ‘record’

I have following error when upgrading manjaro sway

greetd-tuigreet-0.7.1-2-x86_64.pkg.tar.zst failed to download
error: failed retrieving file 'greetd-tuigreet-0.7.1-2-x86_64.pkg.tar.zst' from packages.manjaro-sway.download : Maximum file size exceeded

Previous Xorg-Server upgrade made everything huge (or at least kde plasma) because of a regression.
I didn’t want to do the -dpi 96 in /etc/sddm.conf trick that was mentioned everywhere, but wait for the next upgrade instead.
Xorg 21.1.2 is supposed to fix this but after upgrade and reboot I still see kde plasma huge. Do I have to do something?

Just in case it is relevant, this was on a fresh OS install so I didn’t have a working xorg and then an upgrade made it huge, but instead the fresh install was already huge, but still I was hoping the upgrade would fix it automatically.

Edit: I solved the problem, it had nothing to do with the Xorg’s regression. I explain it here [Solved] Fix of Xorg regression not working

I am not sure but you might want to set it in Appearance - Fonts instead of SDDM.

@jpalko Thank you for your help in the previous topic.

Apparently it was not a smart idea of me to remove an old video-nvidia-3xx driver and use the generic(?) video-nvidia driver and update the system afterwards rightaway.

After reboot my cpu governor was in powersave state. But i could be fixed with cpupower.

Everything else works fine so far.

About python packages, do I also need to reinstall --user installed packages as well?

If you’re experiencing boot issues with optimus-manager 1.4-3, uninstall it and use optimus-manager-git 1.4.1 from the AUR instead.

1 Like

Happy New Year :tada: :confetti_ball:, and thank you for another smooth update! Only thing “odd” I noticed was a downgrade to manjaro-hello.

I have questions about the Python 3.10 upgrade and “leftovers” I found in ~/.local/lib/python3.9 and /usr/lib/python3.9 I’ve asked @ Python 3.9 to 3.10 validation and cleanup

EDIT: I did notice I had a bluetooth “issue” in journalctl after the update reboot:

$ journalctl --priority err --boot 0
Jan 02 10:34:30 AM4-5600X-Linux bluetoothd[791]: Failed to set mode: Blocked through rfkill (0x12)

Now, this might have been because I had bluetooth “disabled” in the KDE plasma panel… but I performed the following commands just to be sure:

  • $ sudo rfkill unblock bluetooth
  • $ sudo systemctl restart bluetooth

A post was split to a new topic: Conflicting files during latest stable update

This does not give all Python packages from AUR only, it gives all Python packages from AUR and from the repos.
Wouldn’t it better to do this instead ?

pacman -Qm $(pacman -Qqo /usr/lib/python3.9)

If run after the update (which you should do before rebuilding) then it wont return any repo packages.


Had to remove Green With Envy and reinstall so it reinstalled its dependencies properly, but other than that went smoothly. Only 1 thing to upgrade to Python 3.10 - patool

Problem in KiCad 6. Switching language doesn’t work.

Unable to switch language to Deutsch
The KiCad language file for this language is not installed.

Perhaps there are some ‘kicad-locale’ packages missing? :grin:

Can’t find KiCad in Manjaro-gitlab but at CMakeList.txt from KiCad-gitlab building “translation libraries” is set “OFF” at the moment.

option( KICAD_BUILD_I18N
“Build the translation libraries.”

Yes, the thing is that it shouldn’t be necessary. This happened because of a regression and this update should fix this, but for some reason it doesn’t in my case, so I’m wondering why