[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

Since this update, my mic stops working as soon as I start an application that uses it like Discord or OBS. I then have to reboot if I want it to work again.

I know that my mic works before starting those applications because I can see activity when looking at the volume mixer and I don’t see any activity once I start one of those application.

Downgrading pipewire to 3.40-1 fixes the issue.

Edit: Looks like an issue is already opened with pipewire : https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1892

i’ll have to dig deeper what’s the cause, but after updating the cpu-load is very high and temperatures are at around 80°C while using the PC in the same manner as before.

I think I’ve got a problem with kernel 5.10 and the last updates. If I can chroot the system, I will upgrade to the kernel to 5.15.

pip (python package manager) was missing after update; (SOLVED)

Parts of the previous pip (for python3.9) was still present after the update not functioning (“no package owns /usr/lib/python3.9”), and pip3.10 was not automatically instsalled.

i’m using pip on a weekly basis, so it was most probably there before the update.

After reboot I reinstalled pip3.10 via the package manager (gui), because I wasn’t sure about the package’s name (python3-pip? python-pip3? python3-pip3? python3.10-pip?)

I install python-pip.
(i don’t know with manjaro whether it’s better to use the packange manager or install pip manually. Since this update wasn’t smooth, I’ll try to stick with the package-manager system; i think the previous was manually installed via getpip.py).

There was a real mess with previous pip3.9 executables litter (under ~/.local/bin/, in /usr/bin, multiple symlinks, real files, and stubs),
So I had to manually delete every pip* executable + remains.

then symlink /usr/bon/pip3.10 as /usr/bin/pip

pip now works again.

I attempted to follow the instructions for updating python / AUR - as suggested, I:

  • ran pamac upgrade in the terminal (all successful)
  • ran pamac build $(pacman -Qoq /usr/lib/python3.9)`(all successful)
  • run pamac upgrade --aur

this is where I had a problem - in the output, I received the following:

> Could not find all required packages:
	python2-py (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-atomicwrites (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-wcwidth (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-pathlib2 (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-setuptools-scm (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-pluggy (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-attrs (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-more-itertools (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-funcsigs (Wanted by: python2-beautifulsoup4 -> python2-pytest)
	python2-importlib-metadata (Wanted by: python2-beautifulsoup4 -> python2-pytest)

Is this because I have some even older python packages installed? Can I have any advice on what to do about this? I’m rather over my head at this point!

(Edit: I did some googling and doing pacman -o on these, it looks like python2-beautifulsoup4 was installed as a dependency of another package, but is listed as “required by: none” - I am guessing that it is no longer needed but nervous about deleting it and causing a problem… Am I correct in thinking that this is the package that is causing the problem? I don’t seem to have python2-pytest installed… It looks like I have a few python2 packages from the AUR, and also listed as orphans…)

Many thanks!

Sorry for lateness of reply.
I wrote the wiki-post item about pip.
Later I moved it to this separate post.
Later again, I realized that the whole idea (that I got from somewhere else) was flawed.
Now it uses ‘pip list’, and you don’t need to do it before the main upgrade.
So if you still have questions, and/or didn’t do it yet, please read that post again.

Please see this post.

1 Like

The git page says: “Update gui to use wxFormBuilder 3.10” on Oct 20th.
So the GUI is wxWidgets, and that’s probably where the problem comes from.

Anyway It’s not a Manjaro issue - check the issues at facelessuser Rummage github.

It’s normal that the old “site-packages” (and maybe some other stuff) is still there after the update.
Nothing there can work because the old python executable is gone.

The new python executable uses the new site-packages directory.

Now that you have installed ‘python-pip’ via the package manager,
you can expect it to be updated automatically next time.

that was a temporary (and unrelated) issue with the manjaro sway database. should be fixed now though?

python2 is deprecated. You should remove all packages depending on it.

Then it is an orphan and not needed/used by your system anymore.

If it’s unneeded it’s just using up space and cause update problems like the one you’re seeing now. No need to be nervous - remove orphans.

1 Like

Thanks very much freggel.doe, it’s very useful to have that reassurance – I went through and removed all the python2 packages with pamac, checking first (using pacman with the -Qii option) that there was nothing unexpected that depended on them. I’m glad to say that all seems to have gone well, and removing the packages has indeed had no ill effect. After removing these, pamac updated my other AUR packages fine, and so the upgrade has now been successful. Many thanks again for the pointers!

Upon running

pacman -Qoq /usr/lib/python3.9

I knew bauh was going to stop working, it was the only AUR package from that output. That was my fault though, I was waaaay behind on its version, it works now after being rebuilt.

1 Like

A post was split to a new topic: qBittorrent segmentation fault

Thanks @jgxvx , this works fine form me, I uninstall official package optimus-manager-1.4-1 and then I install optimus-manager-1.4-3 from AUR repository to compatibility with python 3.10 =) and then my second monitor works excellent =).

PS: I didn’t know optimus-manager package is not anymore on official repository.

I’m having an issue when attempting to update my system. This is the error

error: perl: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/perl-5.34.0-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

I am using the command sudo pacman -Syu and I attemped resetting the following solution but it didn’t work.

I believe that is the recommend solution and the other one says that is a possible solution and I don’t want to find out it broke pacman even more.

EDIT: I was able to fix it by attempting the other solution.

4 posts were split to a new topic: The latest update changed all settings of my nvidia-driver

From my side, I can not update:

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
(388/388) checking keys in keyring                 [######################] 100%
(388/388) checking package integrity               [######################] 100%
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Finally it worked with the graphical install…

Why was font-manager removed from community?

font-manager 0.8.7-1 -

Arch still shows it in community repo - font-manager.

It appears in Unstable, not Testing or Stable. Does that mean it is coming back?

The story of font-manager is as follows:

It was originally in the AUR, then a previous Manjaro team member imported it to our community repo, I dropped it in a cleanup, then it was just recently imported from the AUR to the Arch community repo and therefore it’s back in our community repo. Got it? :stuck_out_tongue:

1 Like