[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

You might have an outdated mirror. Seems @Yochanan pushed Thunderbird earlier to stable branch, without checking on libffi 3.4.2-4 presence. Therefore wait till your mirror updates or change to a more current one using pacman-mirrors tool.

1 Like

I seem to have a Virtual box conflict, and as a result it fails to update. I tried both ā€œpamac updateā€ and sudo pacman -Syuu", but both failed.

vb update
vb conflict

Virtual box conflict log:
:: Synchronizing package databasesā€¦
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Some packages should be upgraded firstā€¦
resolving dependenciesā€¦
looking for conflicting packagesā€¦

Packages (1) archlinux-keyring-20211028-1

Total Download Size: 0.96 MiB
Total Installed Size: 1.36 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packagesā€¦
archlinux-keyrinā€¦ 979.1 KiB 2.56 MiB/s 00:00 [##############] 100%
(1/1) checking keys in keyring [##############] 100%
(1/1) checking package integrity [##############] 100%
(1/1) loading package files [##############] 100%
(1/1) checking for file conflicts [##############] 100%
(1/1) checking available disk space [##############] 100%
:: Processing package changesā€¦
(1/1) upgrading archlinux-keyring [##############] 100%
==> Appending keys from archlinux.gpgā€¦
==> Updating trust databaseā€¦
gpg: next trustdb check due at 2022-01-20
==> Updating trust databaseā€¦
gpg: next trustdb check due at 2022-01-20
:: Running post-transaction hooksā€¦
(1/1) Arming ConditionNeedsUpdateā€¦

:: Starting full system upgradeā€¦
:: Replace virtualbox-guest-dkms with community/virtualbox-guest-utils? [Y/n] y
:: Replace virtualbox-guest-dkms with community/virtualbox-guest-utils-nox? [Y/n] y
resolving dependenciesā€¦
looking for conflicting packagesā€¦
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: virtualbox-guest-utils and virtualbox-guest-utils-nox are in conflict

Simply do this and try to update:

sudo pacman -Rdd virtualbox-guest-dkms

Fixed with 0.3-3.

1 Like

after today update Iā€™m facing again in shutdown

Failed to unmount /oldroot: Device or resource busy
sd-umount: Failed to unmount /oldroot/sys: Device or resource busy
shutdown[1]: Failed to finalize file systems, ignoring.

related to systemd update?

AirVPN Eddie-UI complaining kernel 5.15.2-2 not loading iptables module when applying network lock , kernel 5.14 is fineā€¦


Some tray icons have become buggy after latest update

Screenshot from 2021-11-20 02-26-59
[notice there is an additional dark background in copyq (the scissor) and nextcloud sync (the tick) icon. also the mentioned icons look quite distorted]

Any solution?

all went smooth except my clipit icon looks ugly now (think itā€™s the dafault one). thought it might be an issue only on i3 but I see others have similar issues.

That fixed the problem, and update was successful. Thanks a lot Philm for a quick response!

I just wish I could find a solution so to get rid of this annoying ā€œpop upā€ message every time you open a voice mail message via VLC player. It simply wonā€™t save the settings no matter what you do, and the message pops up every time. It has been like this for months, and Iā€™m assuming it is a Thunderbird issue!
Thunderbird settings

Ouch! Looks like some sort of nasty in opencl (presumably opencl-mesa, as that was the only package upgraded).

I had opencl enabled in Gimp, but it wasnā€™t previously actually working (something to do with ā€œimageā€ not being available). It seems now that ā€œimageā€ is now at least partially available. So now it looks like Gimp is finding what it thinks is a working option and trying to use it. After a short time processing a picture, my entire desktop freezes. Then after about 30 seconds or so, it goes blank, then I see patches of screen flashing all over the place, then after another short period, the screen just goes black. is needed to get me back to the SDDM login.

Disabling opencl within Gimp seems to fix this problem.

I only had two problems with the upgrade:

  1. Conflict between pipewire-media-session and wireplumber
  2. World repositories became unavailable over time. I had to switch to regional.

I advise you to up the speed and bandwidth of the world mirrors. The load on them will now be higher than before due to the recent spam attack by Russian hackers: https://partner.steamgames.com/doc/steamdeck/testing#3

Looks my octopi is broken with this update:

eden@pandora:[~]: octopi                                                                                                                                                                                                                                                  
octopi: error while loading shared libraries: libqtermwidget5.so.0: cannot open shared object file: No such file or directory

I reinstalled octopi, but no luck. Any idea what went wrong and how to fix it?

Itā€™s already fixed with 0.12.0-2.

Update didnā€™t arrive to my village yet :slight_smile:

1 Like

Hello everyone, I have a very old nvidia card that still needs the 340 driver.
So far, everything has worked fine with the workaround ā€œ[HowTo] get legacy 340xx NVIDIA drivers backā€.
But after this update, the workaround no longer works.
Does anyone here have any ideas or is there an update?

I just found a solution in the AUR of Archlinux that works.
In the AUR ā€œnvidia-340xxā€ the following is suggested:

FiestaLake commented on 2021-11-11 07:55:
May be useful for someone. As now Xorgā€™s version of ABI is 25.2 after updating Xorg to 21.1.1 I had to add these lines to xorg.conf to start graphics successfully.

Section "ServerFlags"
    Option "IgnoreABI" "1"

From nvidia-390xx-dkms, but it should work on 340xx too.

1 Like

thanks to folks that fixed this. Much appreciated.

Sometimes Manjaro is a bit leading edge for me, but the support on this forum is just great.


KDE. Try enter to tty1, but nothing happens after press ctrl+alt+f1

Thanks for this solution which worked perfectly for me! :+1:

small ā€œDesktop Effectā€ issue where the transparency of moved windows was no longer being invoked post updateā€¦ fix turned out to be a setting I needed to enable

Not sure if the settingā€™s name changed between versions or if the update missed recycling/migrating the settingā€¦ but a simple enough fix.


I have the same issue. Nextcloud and CoreCtrl icons are messed up.

Getting a 404 from the main KDE download page for this Full ISO.

This 404s ā†’ https://download.manjaro.org/kde/21.2pre1/manjaro-kde-21.2pre1-211119-linux513.iso
This does not: https://download.manjaro.org/kde/21.2pre1/manjaro-kde-21.2pre1-211119-linux515.iso

513.iso vs 515.iso

I see the links above are different and available but, thought Iā€™d mention it, fwiw.