[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

The update well and truly broke my hybrid graphics situation in my Lenovo X1 Extreme gen 2 (GTX 1650 / HD 630).

When trying to use the nvidia card (either with manual xorg.conf or optimus-manager), the GPU can no longer detect the internal screen:

[  1154.688] (--) NVIDIA(GPU-0): DFP-0: disconnected
[  1154.688] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[  1154.688] (--) NVIDIA(GPU-0): DFP-0: 2660.0 MHz maximum pixel clock
[  1154.688] (--) NVIDIA(GPU-0): 
[  1154.688] (--) NVIDIA(GPU-0): DFP-1: disconnected
[  1154.688] (--) NVIDIA(GPU-0): DFP-1: Internal DisplayPort
[  1154.688] (--) NVIDIA(GPU-0): DFP-1: 2660.0 MHz maximum pixel clock
[  1154.688] (--) NVIDIA(GPU-0): 
[  1154.732] (--) NVIDIA(GPU-0): SAMSUNG (DFP-2): connected
[  1154.732] (--) NVIDIA(GPU-0): SAMSUNG (DFP-2): Internal TMDS
[  1154.732] (--) NVIDIA(GPU-0): SAMSUNG (DFP-2): 600.0 MHz maximum pixel clock
[  1154.732] (--) NVIDIA(GPU-0): 
[  1154.821] (==) NVIDIA(0): 
[  1154.821] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1154.821] (==) NVIDIA(0):     will be used as the requested mode.
[  1154.821] (==) NVIDIA(0): 
[  1154.823] (II) NVIDIA(0): Validated MetaModes:

The DFP-2 here is my HDMI port, and the DFP 0-1 seem to be the USB-C outputs. The X server actually does launch, but only on the external screen, if its connected. The internal screen seems to be handled by iGPU, although I am not 100% sure about that one:

  1154.917] (--) intel(G0): Integrated Graphics Chipset: Intel(R) HD Graphics
[  1154.917] (--) intel(G0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 6 threads
[  1154.917] (==) intel(G0): Depth 24, (--) framebuffer bpp 32
[  1154.917] (==) intel(G0): RGB weight 888
[  1154.917] (==) intel(G0): Default visual is TrueColor
[  1154.917] (**) intel(G0): Option "VirtualHeads" "2"
[  1154.917] (II) intel(G0): Output eDP1 has no monitor section
[  1154.918] (**) intel(G0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[  1154.918] (II) intel(G0): Enabled output eDP1
[  1154.918] (--) intel(G0): Using a maximum size of 256x256 for hardware cursors
[  1154.918] (II) intel(G0): Output VIRTUAL1 has no monitor section
[  1154.918] (II) intel(G0): Enabled output VIRTUAL1
[  1154.918] (II) intel(G0): Output VIRTUAL2 has no monitor section
[  1154.918] (II) intel(G0): Enabled output VIRTUAL2
[  1154.919] (II) intel(G0): EDID for output eDP1
[  1154.919] (II) intel(G0): Manufacturer: BOE  Model: 809  Serial#: 0
[  1154.919] (II) intel(G0): Year: 2018  Week: 30
[  1154.919] (II) intel(G0): EDID Version: 1.4
[  1154.919] (II) intel(G0): Digital Display Input
[  1154.919] (II) intel(G0): 10 bits per channel
[  1154.919] (II) intel(G0): Digital interface is DisplayPort
[  1154.919] (II) intel(G0): Max Image Size [cm]: horiz.: 35  vert.: 19
[  1154.919] (II) intel(G0): Gamma: 2.20
[  1154.919] (II) intel(G0): No DPMS capabilities specified
[  1154.919] (II) intel(G0): Supported color encodings: RGB 4:4:4 

This gives me the weird situation which is not at all intended by the xorg configs - the internal screen works on iGPU (and only after I log in to plasma!), and the external is handled by the dGPU. This is super laggy and inefficient.

How do I fix all this nonsense and get back to my cozy optimus-manager setup where only 1 GPU is active at a time?

I’ve tried kernels 5.13 and 5.15, and both drivers 470 and 495.

Can’t open system settings on budgie. I remember the settings crashed after clicking the multitasking option, and I haven’t been able to open them since!

(gnome-control-center:42203): GLib-GIO-ERROR **: 09:35:24.759: Settings schema 'org.gnome.shell.app-switcher' is not installed
[1]    42203 trace trap (core dumped)  gnome-control-center

One thing I’ve noticed after installing kernel 5.15 from this update is that my load averages increase from their normal 0-3 to as much as 30.
I’ve raised this issue in the kernel forum in case anyone else needs to follow this problem.

6 posts were split to a new topic: Virtual Machine Manager cannot connect to my one VM

I have a NAS I use regularly mounted as a normal drive in my Computer.
After update I could not copy or move any files from or to my NAS. I could copy/move empty folders and edit existing data; but no files… strange!
The reason was obviously that I still had Kernel 4.19 running. Now I Installed 5.10 and everything is fine again.
Luckily I found this Topic in the forum

Did you figure it out? See my post in Support.

OK, I finally found what was preventing Xorg to start after the upgrade: VNC.
I had to remove these packages:

Now everything is back to normal with the latest Xorg.
Hope it’s useful for somebody.


1 Like

I have 2 problems.
1 - when updating kernel 5.15, the computer does not respond when restarting or shutting down, the screen is black. If you turn off the screen but not the cpu when you turn off. the same is not the case with older kernels.
I tried kde and cinnamon and the same thing happens in both cases.

2 - when the cpu starts up, the plasma desktop (x11) is loaded without a wallpaper and the desktop functions do not respond, but the menu and taskbar do. I did the same with wayland and the desktop loads normally.

There is an open ticket in xorg to handle this bug:

Some days after update my KDE Plasma is changing my desktop and set all things related to it as defaults. a bit strange.

It might also be related to clean KDE plasma cache, but I didn’t found the command line to do it.

Here is a list of known issues with the latest Xorg-Server 21.1 series …

1 Like

I can’t login anymore…I performed the update but it got stuck during the installation with the message that plasma-desktop is already present in Breaze. So to continue the installation I removed Plasma-desktop to be able to reinstall it later. and that’s where it got stuck … Plasma desktop refuses to reinstall again and I’m stuck at login password!

Hmm, it might have been a better idea to post the update blocking details before uninstalling plasma… but that doesn’t help you where you are right now.

As I’m still learning myself my advice may not be perfect, but I suspect one of two solutions to “recover gracefully” I’ve heard others mention before and two “less graceful” options:

  1. Once you get to the login prompt you can’t pass… try switch to a tty (i.e. Ctl-Alt-F2), log in, and try run pacman from there to try reinstall plasma… and if successful reboot to try login normally again
  2. If that doesn’t work, you may need to boot from a Live USB to use chroot to try accomplish the same thing… but I don’t know enough about it to make a recommendation of steps to follow in this case.
  3. If you have a Timeshift backup before the upgrade, this may be an option… but as it defaults to not backup home, it’s really only an option if you have a “Home” dir backup as well to “downgrade” all your settings as so much changed with plasma, kde, etc… with this update
  4. The last resort may be to reinstall Manjaro (previous version; similar issue to #3) and reload your Home dir backup… but let’s hope #1 helps you

Post update I noticed the audio device for my usb headset under KDE system settings>Audio>‘playback devices’ was reporting as a mono output. I was looking around and toggled the alsa profile to off from ‘alsa default’ and the device winked out of existence.

  1. Would that be the expected behavior?
  2. Can the device be recovered/reset? pacmd?

I still have the device for the headset input.

Edit: Not having sound is super annoying so I just reverted to a backup for the time being, if anyone has insight on what was happening it would still be appreciated though.

Edit Edit: Audio devices disappear in Kernels 5.14 & 5.15

update was mostly ok. The only problem was that I needed to reinstall python 3.7 from pyenv. This was because it could not import libffi anymore (needed for proton). I’m mentioning this in case anyone else runs into it.

I also upgraded from kernel 5.14 to 5.15 at the same time. No issues observed.

The new pipewire pushed in this release also has a commit from me. It’s a very simple one-liner, but your first time is always special :slight_smile:


You shoul not have done that.
Switch to tty and reinstall it.
Open a new thread detailing what you did, if further help is needed.

1 Like

Thank you, it work again. I just follow your 1st instructions !

Thanks. It worke again after the réinstallation of plasma

1 Like

Just sharing if anyone is getting the same problem below, please comment here for fixes or comments

After the update, if I suspend PC and then turn on, bluetooth is ‘dead’ and I have to manually run
systemctl start bluetooth
I use a chinese dongle as a bluetooth and never had any issue, Manjaro recognizes it automatically, but this thing is a bit annoying.
Has no issues with 5.4 kernel, but always dies with 5.10 and 5.15 kernels

1 Like