[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

After upgrading my Logitech MX Master didn’t worked anymore. According to this reddit post this is due to changes in bluez. Therefore the mouse cannot connect to the computer. Possible solution could be to downgrade bluez.

From reddit post: pacman -U https://archive.archlinux.org/packages/b/bluez/bluez-5.56-2-x86_64.pkg.tar.zst

1 Like

Hello there,
After last Upgrade I expiriance in gnome desktop problems with my task bar. Icons seems to be duplicated and hidden, what the taskbar expands with black symbols. You can see here: At the black part of the bar, I can click and the icons will react, but I cant see them:

I already tried to delete ~/.config/dconf/user .
That reset my desktop but the error appears again. If I start a new session, reboot, logout etc everything is normal. But some time it happens again.
That is since the upgrade.

Any Ideas?

Thank you very much.

All sorted now, thanks for the assistance.


Help much appreciated.

Thanks! After removing the other display and adding the Standard space sRGB the colors are back to normal.

1 Like

Updated from Pamac. Went over well. Had to switch from 5.13 to 5.10 in GRUB because I lose sound with 5.13, but that is an old issue and there’s already a thread for it (unsolved, though, maybe it would be better to use a newer kernel, but I never got round to cracking this issue).

I use Plasma and I think my scroll bars got a bit bigger, too, as some have already mentioned.

I tried this and restarted, but it didn’t change the scroll bars:

I think I can get used to the big scroll bars, but I’d be grateful if anybody had another piece of advice.

Are there any risks to running rm -rf ~/.cache/*? What happens if the cache is cleared?

Anyone else’s keyboard shortcuts broken? My Super key shortcuts for tiling windows to the left or right, plus screenshot shortcuts don’t work. This happened after the update came out.

Also my games performance seems to have suffered.

Manjaro preview 21.2 KDE version installed for tests. No issues during installation. I will do tests in next days and after that I will do a true install.

There’s an open issue about it. Try the following and/or remap the keyboard shortcuts:

killall -9 gsd-media-keys
1 Like

The update well and truly broke my hybrid graphics situation in my Lenovo X1 Extreme gen 2 (GTX 1650 / HD 630).

When trying to use the nvidia card (either with manual xorg.conf or optimus-manager), the GPU can no longer detect the internal screen:

[  1154.688] (--) NVIDIA(GPU-0): DFP-0: disconnected
[  1154.688] (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[  1154.688] (--) NVIDIA(GPU-0): DFP-0: 2660.0 MHz maximum pixel clock
[  1154.688] (--) NVIDIA(GPU-0): 
[  1154.688] (--) NVIDIA(GPU-0): DFP-1: disconnected
[  1154.688] (--) NVIDIA(GPU-0): DFP-1: Internal DisplayPort
[  1154.688] (--) NVIDIA(GPU-0): DFP-1: 2660.0 MHz maximum pixel clock
[  1154.688] (--) NVIDIA(GPU-0): 
[  1154.732] (--) NVIDIA(GPU-0): SAMSUNG (DFP-2): connected
[  1154.732] (--) NVIDIA(GPU-0): SAMSUNG (DFP-2): Internal TMDS
[  1154.732] (--) NVIDIA(GPU-0): SAMSUNG (DFP-2): 600.0 MHz maximum pixel clock
[  1154.732] (--) NVIDIA(GPU-0): 
[  1154.821] (==) NVIDIA(0): 
[  1154.821] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1154.821] (==) NVIDIA(0):     will be used as the requested mode.
[  1154.821] (==) NVIDIA(0): 
[  1154.823] (II) NVIDIA(0): Validated MetaModes:

The DFP-2 here is my HDMI port, and the DFP 0-1 seem to be the USB-C outputs. The X server actually does launch, but only on the external screen, if its connected. The internal screen seems to be handled by iGPU, although I am not 100% sure about that one:

  1154.917] (--) intel(G0): Integrated Graphics Chipset: Intel(R) HD Graphics
[  1154.917] (--) intel(G0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 6 threads
[  1154.917] (==) intel(G0): Depth 24, (--) framebuffer bpp 32
[  1154.917] (==) intel(G0): RGB weight 888
[  1154.917] (==) intel(G0): Default visual is TrueColor
[  1154.917] (**) intel(G0): Option "VirtualHeads" "2"
[  1154.917] (II) intel(G0): Output eDP1 has no monitor section
[  1154.918] (**) intel(G0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[  1154.918] (II) intel(G0): Enabled output eDP1
[  1154.918] (--) intel(G0): Using a maximum size of 256x256 for hardware cursors
[  1154.918] (II) intel(G0): Output VIRTUAL1 has no monitor section
[  1154.918] (II) intel(G0): Enabled output VIRTUAL1
[  1154.918] (II) intel(G0): Output VIRTUAL2 has no monitor section
[  1154.918] (II) intel(G0): Enabled output VIRTUAL2
[  1154.919] (II) intel(G0): EDID for output eDP1
[  1154.919] (II) intel(G0): Manufacturer: BOE  Model: 809  Serial#: 0
[  1154.919] (II) intel(G0): Year: 2018  Week: 30
[  1154.919] (II) intel(G0): EDID Version: 1.4
[  1154.919] (II) intel(G0): Digital Display Input
[  1154.919] (II) intel(G0): 10 bits per channel
[  1154.919] (II) intel(G0): Digital interface is DisplayPort
[  1154.919] (II) intel(G0): Max Image Size [cm]: horiz.: 35  vert.: 19
[  1154.919] (II) intel(G0): Gamma: 2.20
[  1154.919] (II) intel(G0): No DPMS capabilities specified
[  1154.919] (II) intel(G0): Supported color encodings: RGB 4:4:4 

This gives me the weird situation which is not at all intended by the xorg configs - the internal screen works on iGPU (and only after I log in to plasma!), and the external is handled by the dGPU. This is super laggy and inefficient.

How do I fix all this nonsense and get back to my cozy optimus-manager setup where only 1 GPU is active at a time?

I’ve tried kernels 5.13 and 5.15, and both drivers 470 and 495.

Can’t open system settings on budgie. I remember the settings crashed after clicking the multitasking option, and I haven’t been able to open them since!

(gnome-control-center:42203): GLib-GIO-ERROR **: 09:35:24.759: Settings schema 'org.gnome.shell.app-switcher' is not installed
[1]    42203 trace trap (core dumped)  gnome-control-center

One thing I’ve noticed after installing kernel 5.15 from this update is that my load averages increase from their normal 0-3 to as much as 30.
I’ve raised this issue in the kernel forum in case anyone else needs to follow this problem.

6 posts were split to a new topic: Virtual Machine Manager cannot connect to my one VM

I have a NAS I use regularly mounted as a normal drive in my Computer.
After update I could not copy or move any files from or to my NAS. I could copy/move empty folders and edit existing data; but no files… strange!
The reason was obviously that I still had Kernel 4.19 running. Now I Installed 5.10 and everything is fine again.
Luckily I found this Topic in the forum

Did you figure it out? See my post in Support.

OK, I finally found what was preventing Xorg to start after the upgrade: VNC.
I had to remove these packages:

Now everything is back to normal with the latest Xorg.
Hope it’s useful for somebody.


1 Like

I have 2 problems.
1 - when updating kernel 5.15, the computer does not respond when restarting or shutting down, the screen is black. If you turn off the screen but not the cpu when you turn off. the same is not the case with older kernels.
I tried kde and cinnamon and the same thing happens in both cases.

2 - when the cpu starts up, the plasma desktop (x11) is loaded without a wallpaper and the desktop functions do not respond, but the menu and taskbar do. I did the same with wayland and the desktop loads normally.

There is an open ticket in xorg to handle this bug:

Some days after update my KDE Plasma is changing my desktop and set all things related to it as defaults. a bit strange.

It might also be related to clean KDE plasma cache, but I didn’t found the command line to do it.

Here is a list of known issues with the latest Xorg-Server 21.1 series …

1 Like