[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

Hey, I use f.lux with wine. You can set different colors for day-time, sunset and bed-time.

1 Like

Anyone else getting a black screen when waking up after setting the screen to blank after a period of time?

1 Like

I’m already updated and I don’t have such problem. Actually I was using a couple of USB sticks when I saw your post.

Highly suggest you use redshift instead

A post was split to a new topic: Gdm and nvidia after update

Again :man_shrugging: no GUI after the update. I had to remove 2 files :man_factory_worker: in /usr/share/X11/xorg.conf.d/ to get a working GUI again (XFCE multiseat nouveau, without xorg.conf) :sunglasses:

1 Like

Yes, I had made the changes before the update and all went fine with GT9400M, nvidia-340xx-dkms and 5.10 kernel.
(I did not try to update without making them, though.)

Hi there, so first of all thanks for this update and the great work so far. The update went fine but I now have some Issues (I think because of the proprietary Nvidia drivers)

The thing is that I have a rather unusual setup. I have 2 monitors connected to my GTX 1050 and one connected to the integrated Intel Graphics. For this reason I have the video-hybird-intel-nvidia-prime driver. I using Gnome on kernel 5.15.

The problem is that Wayland doesn’t recognize my GTX 1050 and so only one display is on (the other ones are just black). I’m now using Gnome on Xorg but the monitor that is connected to the integrated graphics has a pink-ish image (didn’t have that on Wayland).

If you need any more technical information let me know. Maybe someone knows a fix.
Anyways have a nice day :wink:

Hey @TecCheck

For the pinkish tint you can check Settings > Color and then turn off the color profile for your monitor connected to the integrated graphics.

I changed it to a sRGB profile. Now it’s fine. Thank you!

A post was split to a new topic: Megasync-nopdfium: could not satisfy dependencies

You read the update announcements:

Hi guys…black screen problem…when the update was almost done my laptop screen became black and unresponsive…then the laptop did not boot…thankfully i had timeshift backup…so i booted from USB and made a rollback and now the laptop is ok…but i am afraid to do the update…i used pacman…i will try with yay next time.

Manjaro Hello and virt-manager no longer run on my system after the update citing missing libffi7. I think it was upgraded to a more recent version during the update which broke compatibility.

Installing the AUR version of the package libffi7 solved the problem.

Use pamac instead. I did, had no, zero, ziltch, 0 problems.

1 Like

Tried to install manjaro-xfce-21.2pre1-minimal-211119-linux515.iso. After completing installation no boot device. Went back to fresh install 21.06 and was able to boot and upgraded to qonos. Did the installation from nvme with ventoy.

inxi

Summary
System:    Host: manjaro Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0
           tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 dm: LightDM 1.30.0 Distro: Manjaro Linux
           base: Arch Linux
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
           Mobo: ASUSTeK model: ROG STRIX B560-F GAMING WIFI v: Rev 1.xx serial: 210484691301521
           UEFI: American Megatrends v: 1017 date: 07/12/2021
Memory:    RAM: total: 31.12 GiB used: 7.96 GiB (25.6%)
           Array-1: capacity: 64 GiB slots: 4 EC: None max-module-size: 16 GiB note: est.
           Device-1: Controller0-ChannelA-DIMM0 size: No Module Installed
           Device-2: Controller0-ChannelA-DIMM1 size: 16 GiB speed: spec: 2133 MT/s actual: 3600 MT/s type: DDR4
           detail: synchronous bus-width: 64 bits total: 64 bits manufacturer: Corsair part-no: CMK32GX4M2D3600C18
           serial: N/A
           Device-3: Controller0-ChannelB-DIMM0 size: No Module Installed
           Device-4: Controller0-ChannelB-DIMM1 size: 16 GiB speed: spec: 2133 MT/s actual: 3600 MT/s type: DDR4
           detail: synchronous bus-width: 64 bits total: 64 bits manufacturer: Corsair part-no: CMK32GX4M2D3600C18
           serial: N/A
CPU:       Info: 8-Core model: 11th Gen Intel Core i7-11700K bits: 64 type: MT MCP arch: Rocket Lake rev: 1 cache:
           L1: 640 KiB L2: 16 MiB L3: 16 MiB bogomips: 115232
           Speed: 800 MHz min/max: 800/4900 MHz volts: 1.0 V ext-clock: 100 MHz Core speeds (MHz): 1: 800 2: 801
           3: 800 4: 800 5: 801 6: 801 7: 801 8: 801 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800 16: 800
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2
           avx512_bitalg avx512_vbmi2 avx512_vnni avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f avx512ifma
           avx512vbmi avx512vl bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de
           ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr
           gfni ht hwp hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
           invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae
           pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp
           rep_good sdbg sep sha_ni smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
           tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid x2apic
           xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
Graphics:  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: ASUSTeK driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
           Display: server: X.Org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver: loaded: modesetting
           alternate: fbdev,vesa s-res: 1920x1080 s-dpi: 96
           OpenGL: renderer: Mesa Intel Graphics (RKL GT1) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:43c8 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
Network:   Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0
           class-ID: 0280
           IF: wlo1 state: down mac: 06:fc:63:62:84:50
           Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: N/A bus-ID: 03:00.0
           chip-ID: 8086:15f3 class-ID: 0200
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: fc:34:97:c2:fc:f0
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:8 chip-ID: 8087:0026
           class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: N/A rfk-block: hardware: no software: yes
           address: see --recommends
Drives:    Local Storage: total: 7.28 TiB used: 3.95 TiB (54.2%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB speed: 63.2 Gb/s lanes: 4
           type: SSD serial: S5GXNF0R725098N rev: 3B2QGXA7 temp: 30.9 C scheme: GPT
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB speed: 63.2 Gb/s lanes: 4
           type: SSD serial: S5GXNF0R725104F rev: 3B2QGXA7 temp: 28.9 C scheme: GPT
           ID-3: /dev/sda vendor: Western Digital model: WD60EFAX-68JH4N1 size: 5.46 TiB speed: 6.0 Gb/s type: HDD
           rpm: 5400 serial: WD-WX22DC0LVJCJ rev: 0A83 scheme: GPT
           Message: No optical or floppy data found.
Partition: ID-1: / size: 50 GiB used: 9.28 GiB (18.6%) fs: btrfs dev: /dev/nvme0n1p2 label: N/A
           uuid: 7d23a60b-aae1-447f-844d-176f75aca996
           ID-2: /boot/efi size: 299.4 MiB used: 568 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 label: NO_LABEL
           uuid: 33E5-BAE7
           ID-3: /data size: 781.22 GiB used: 263.82 GiB (33.8%) fs: btrfs dev: /dev/nvme0n1p4 label: N/A
           uuid: c58d45cd-ba0e-4d92-95cd-9458d1b2dd0a
           ID-4: /home size: 100 GiB used: 11.72 GiB (11.7%) fs: btrfs dev: /dev/nvme0n1p3 label: N/A
           uuid: f8f64ee0-e431-417a-8c2e-de37d5b3e78c
           ID-5: /storage size: 931.51 GiB used: 516.81 GiB (55.5%) fs: btrfs dev: /dev/nvme1n1p1 label: N/A
           uuid: f5595500-d6b5-428a-a9dc-4114a2692e4c
           ID-6: /var/cache size: 50 GiB used: 9.28 GiB (18.6%) fs: btrfs dev: /dev/nvme0n1p2 label: N/A
           uuid: 7d23a60b-aae1-447f-844d-176f75aca996
           ID-7: /var/log size: 50 GiB used: 9.28 GiB (18.6%) fs: btrfs dev: /dev/nvme0n1p2 label: N/A
           uuid: 7d23a60b-aae1-447f-844d-176f75aca996
           ID-8: /wd6tb size: 5.46 TiB used: 3.16 TiB (58.0%) fs: btrfs dev: /dev/sda1 label: N/A
           uuid: cc4d8185-6f7c-4009-8574-ef2f3f65aa10
Swap:      ID-1: swap-1 type: zram size: 2 GiB used: 768 KiB (0.0%) priority: 32767 dev: /dev/zram0
Unmounted: Message: No unmounted partitions found.
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A
           Fan Speeds (RPM): N/A
Repos:     Packages: pacman: 1028
           Active pacman repo servers in: /etc/pacman.d/mirrorlist
           1: https://ftp.nluug.nl/pub/os/Linux/distr/manjaro/stable/$repo/$arch
           2: https://mirror.koddos.net/manjaro/stable/$repo/$arch
           3: https://mirror.cyberhost.uk/sites/manjaro/stable/$repo/$arch
           4: https://mirror.netcologne.de/manjaro/stable/$repo/$arch
           5: https://mirror.23m.com/manjaro/stable/$repo/$arch
           6: https://mirrors.gethosted.online/manjaro/repos/stable/$repo/$arch
           7: https://mirror.init7.net/manjaro/stable/$repo/$arch
           8: https://www.mirrorservice.org/sites/repo.manjaro.org/repos/stable/$repo/$arch
           9: https://mirror.alpix.eu/manjaro/stable/$repo/$arch
           10: https://mirrors.dotsrc.org/manjaro/stable/$repo/$arch
           11: https://ftp.halifax.rwth-aachen.de/manjaro/stable/$repo/$arch
           12: https://ftp.gwdg.de/pub/linux/manjaro/stable/$repo/$arch
           13: https://manjaro.moson.eu/stable/$repo/$arch
           14: https://ftp.lysator.liu.se/pub/manjaro/stable/$repo/$arch
           15: https://mirror.moson.org/manjaro/stable/$repo/$arch
           16: https://ftpmirror1.infania.net/mirror/manjaro/stable/$repo/$arch
           17: https://mirror.zetup.net/manjaro/stable/$repo/$arch
           18: https://manjaro.osmir.ch/stable/$repo/$arch
Processes: CPU top: 5 of 430
           1: cpu: 47.0% command: virtualboxvm pid: 3801 mem: 1969.9 MiB (6.1%)
           2: cpu: 16.8% command: virtualboxvm pid: 3741 mem: 1188.8 MiB (3.7%)
           3: cpu: 4.1% command: xorg pid: 991 mem: 101.8 MiB (0.3%)
           4: cpu: 2.7% command: pulseaudio pid: 1318 mem: 14.9 MiB (0.0%)
           5: cpu: 1.3% command: xfce4-terminal pid: 6988 mem: 53.8 MiB (0.1%)
           Memory top: 5 of 430
           1: mem: 1969.9 MiB (6.1%) command: virtualboxvm pid: 3801 cpu: 47.0%
           2: mem: 1188.8 MiB (3.7%) command: virtualboxvm pid: 3741 cpu: 16.8%
           3: mem: 172.3 MiB (0.5%) command: virtualbox pid: 3623 cpu: 0.3%
           4: mem: 101.8 MiB (0.3%) command: xorg pid: 991 cpu: 4.1%
           5: mem: 97.4 MiB (0.3%) command: xfwm4 pid: 1308 cpu: 0.7%
Info:      Processes: 430 Uptime: 1h 55m wakeups: 0 Init: systemd v: 249 Compilers: gcc: 11.1.0 Shell: Bash (sudo)
           v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.08

i will…thanks

Thanks for the troubleshoot post.
I have a GT710 and today I applied the updates and obviously it “broke” my system (couldn’t log to graphical session)
I should’ve read the post before reinstalling my system, but well… I did expect a somewhat regular update.
Nevertheless, I think I lost nothing of value and was able to save my recently installed system following the steps in the post

1 Like

I also learned the hard way to read the update announcements before performing the update.

So, welcome to the club! We have a support group. We meet on the day after the update was released, and watch the Forum like you’d watch a movie. Can be quite entertaining. Bring snacks!

1 Like

After this update, I still have lightdm issue:

After Stable Update 2021-09-24 LightDM no longer automatically start - #34 by D.Dave