[Stable Update] 2021-10-16 - Haskell, Python, KDE Gear, KDE Framework, Thunderbird

@LordTermor post your Info Centre info please also

Do I need still? It’s upstream bug that’s fixed in 5.23.



Latte dock 0.10.3 is released. Can we have that one in the stable branch soon ?


1 Like

I’m pretty sure you’ve been around long enough to know how things work. :wink:


Well, I see that Latte dock 0.13.3 is in the testing branch. No problem, I will waiting that it be available in the next stable branch. :wink:

After update soundcard is not detected. Bluetooth audio works fine but no onboard devices, neither speaker nor mic.
I tried to switch to pipe wire but this made no difference.
Installing sof-firmware brought audio back but audio control keys are not working; speaker mute, mic mute, volume up, volume down.
I suspect this is kde related but I don’t know which package(s) to downgrade.

EDIT: So above was all done late last night, or rather early this morning. Testing now after after a few hour of sleep it is all working. The solution is to install sof-firmware


AltGr +shift + z(or x) does not show less than and greater than symbols anymore.

I am using gnome 40 Wayland sesion and a spanish keyboard with Spanish layout (Spain) 3 weeks ago, before the update the symbols < and > use to work just fine but after the update there changed to the “smaller” versions used for quotes ‹ and ›

Haven’t been able to fix this. Any suggestions?

edit: My keyboard cannot write < > with AltGr+shift+z/x

I have errors like these at logout, that weren’t there before. Typically ‘ICE default’, ‘sddm-helper crashed’, then optionally some more services ‘failed with exit-code’, then ‘QProcess destroyed while sddm-helper still running’. Don’t seem to affect anything on practice (for now?), but still something to take note of.

Nov 08 11:53:43 hostname org.kde.LogoutPrompt[1591]: Xlib:  extension "NV-GLX" missing on display ":0".
Nov 08 11:53:54 hostname org.kde.kdeconnect[1602]: ICE default IO error handler doing an exit(), pid = 1602, errno = 11
Nov 08 11:53:54 hostname sddm[699]: Authentication error: "Process crashed"
Nov 08 11:53:54 hostname sddm[699]: Auth: sddm-helper crashed (exit code 15)
Nov 08 11:53:54 hostname sddm[699]: Authentication error: "Process crashed"
Nov 08 11:53:54 hostname sddm[699]: Auth: sddm-helper exited with 15
Nov 08 11:53:54 hostname systemd[1024]: openrazer-daemon.service: Failed with result 'exit-code'.
Nov 08 11:53:54 hostname systemd[1024]: obex.service: Failed with result 'exit-code'.
Nov 08 11:53:55 hostname sddm[699]: Signal received: SIGTERM
Nov 08 11:53:56 hostname sddm[699]: QProcess: Destroyed while process ("/usr/lib/sddm/sddm-helper") is still running.

Might be worthwhile to check upstream (KDE and SDDM) and report?

I pushed more packages to the staging branch: [Stable-Staging Update] 2021-11-11 - Kernels, Haskell, Nvidia, Maui, Python, FireFox, Thunderbird, KDE Gear, LibreOffice


Just adding, I installed Olive flatpak from Flathub via pamac GUI. I open it but nothing shows up so I right click the icon on the dock and my whole laptop freezes, only way to save it is if I hard restart. Does this happen to anyone else?

Manjaro Gnome

Was it once under some complicated circumstances or you saw it once again after you made the restart?
May be to save all your data before to try again (if you did not) and on some free time have a look into [HowTo] reboot / turn off your frozen computer: REISUB/REISUO

Also, what journalctl -p 3 reports on that first time you saw it (if it was the previous boot up, then add -b -1 argument)?

Hi there. For some reason my box isn’t updating, even though I have updated the mirrors etc. I tried setting it to favour the Germany mirrors but still it came back as “system up to date”. I suddenly feel like my Linux newbie self of 8 years ago! Thanks, Ruziel :slight_smile:


This update was from the 16th October, you have probably already updated since then.

LOL, how did I miss that it was October!! Apologies, of course. I was expecting a stable update to land this week & saw what I wanted to see. Thanks :slight_smile:

So basically whenever I run the Olive app (flatpak), my laptop freezes. Only a force restart works, nothing else.

You can always switch to testing branch and help out.

my touchpad is not working properly after this update
changed the kernel and still the same issue
my driver is libinput
there is no warnings or errors in journalctl

Hehe, don’t read “expecting”, as in “why hasn’t it arrived yet?”, but more in the guestimating sense.

I run my business on Manjaro & don’t have the skills to run testing on that basis, but I appreciate everyone that does.

Thanks, R.