[Stable Update] 2021-09-24 - Kernels, LibreOffice, Browsers, Pipewire, RHVoice, KDE Frameworks, Mesa

Hello community,

Another stable branch update with some usual updates for you.

  • Most of our Kernels got updated. Note: 5.13 series is now marked EOL
  • Mesa got renewed to 21.2.2
  • ZFS is now at 2.1.1
  • NetworkManager is at 1.32.12
  • Regular KDE-git updates
  • Another beta release of Firefox got added
  • Pipewire is now at 0.3.37
  • The current version of LibreOffice is now at 7.2.1
  • rhvoice got added
  • gstreamer is now at 1.18.5
  • KDE Frameworks got updated to 5.86.0, which brings enhancements to Wayland-Support for Nvidia drivers
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.284
  • linux49 4.9.283
  • linux414 4.14.247
  • linux419 4.19.207
  • linux54 5.4.148
  • linux510 5.10.68
  • linux512 5.12.19 [EOL]
  • linux513 5.13.19 [EOL]
  • linux514 5.14.7
  • linux515 5.15-rc2
  • linux510-rt 5.10.52_rt47

Package Updates (Thu Sep 23 11:31:52 CEST 2021)

A list of all package changes may be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Pahvo 21.1.4 got released!


Download XFCE





Minimal (linux54)


Download GNOME





Minimal (linux54)


Download KDE





Minimal (linux54)



Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

New issues:

Update breaks dependencies
  • The first port of call when having dependency problems is to try to update your mirrors then try again.

  • The quick solution:

    sudo pacman-mirrors --geoip && sudo pacman -Syyu
  • The long-term solution:

    • Check the mirrors for your country and the closest neighbouring country

    • Execute:

      sudo pacman-mirrors --country YourCountry,NeighbouringCountry --interactive
    • select the green mirrors that are fastest with and on your keyboard and space to select them

    • Tab to the OK button

    • Press Enter

    • Execute:

      sudo pacman -Syyu
      pamac upgrade
    • Check again for no errors, hit Y Enter

    • :hourglass_flowing_sand: :wink:

QTile minimizes windows

floating_layout rules in a dict was deprecated a while ago

KDE Window Decorations UI with Drag&Drop broken

When going to System-SettingsWindow DecorationsTitlebar Buttons the UI interface doesn’t allow you to drag and drop buttons any more.

Firefox mixes languages
  • Clear your profile cache : HelpMore troubleshooting informationClear startup cache
  • If that does not work, create a new profile. See here how to do so while keeping your bookmarks, extensions and customization.
Brave segfaults / crashes

Reinstalling Brave fixes the issue.

Older Issues:

You might have issues to install this update by missing Maintainers keys

A possible solution might be:

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv
nVidia 4xx PRIME on kernel >= 5.5 has no audio

If you are using an nVidia card with the proprietary prime driver and you get no audio through the HDMI port or the USB devices of the card don’t work it’s because they have been disable due to a power management bug in the kernel. This bug has been fixed in recent updates, so if you are running a kernel with version >= 5.5 and the 4xx version nVidia driver you can fix those problems by editing the file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules and commenting the following lines in this way.

  • To go from this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • to this:

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"
    # Remove NVIDIA USB Type-C UCSI devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"
    # Remove NVIDIA Audio devices, if present
    #ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"
  • execute this:

    sudo sed -Ei '/"0x040300"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c8000"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
    sudo sed -Ei '/"0x0c0330"/s/^/#/' /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules
Freetype2 update may break applications
You might be blocked updating when using pacman due to some libcanberra packages.

Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. We recommend to use pamac anyway, which does this automatically: pamac update

Compiz packages got dropped from our repositories
wget now always outputs “SSL_INIT” to stderr every time it is run.

Issue tracked here: GNU Wget - Bugs: bug #61125

vboxdrv error messages of systemd from log `journactl -b -p 3`

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.

Firefox VAAPI doesn't work

Can be fixed by removing the entire Firefox profile and settings
:warning: All Firefox settings will be reset to default!


Even older issues:

`signal-desktop-beta` doesn't want to build and fails with an error


     pamac remove signal-desktop-beta
     pamac install signal-desktop 
Steam breaks completely and only shows a black screen

Steam only displays a black screen in place of WebView elements such as the store & library panels. The issue is caused by an update to freetype2, so the easiest way to solve the problem is to opt into the Steam beta client
:warning: Downgrading the freetype2 to version 2.10.4 would be a bad idea with something as important as freetype2 as other packages may break.

Icon handling in `obmenu-generator` is broken

Error message:

obmenu-generator -i
Can't locate object method "init" via package "Gtk3" at /bin/obmenu-generator line 386.


     pamac install perl-gtk3
No audio after Pulseaudio v15 update

Try clearing the databases in your home folder of any old settings by executing:

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

Reboot afterwards.

Nextcloud problem and workaround

After upgrading mariadb to 10.6.3-1 and executing

sudo systemctl restart mariadb.service && sudo mariadb-upgrade -u root -p

Nextcloud doesn’t work anymore showing several errors, all of them related to “InnoDB refuses to write tables with ROW_FORMAT=COMPRESSED or KEY_BLOCK_SIZE.

In /etc/my.cnf.d/server.cnf under section [mariadb] put:


Workaround found here: Arch Forum - [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

KDE logo in splash screen instead of Manjaro logo
  • Backup / remove the old ksplashrc file
  • mv ~/.config/ksplashrc ~/.config/ksplashrc.bak
  • Go to System Settings
  • Type in Splash
  • Click on Splash Screen
  • Select and Apply your desired splash screen
Telegram fails to open

Telegram fails with:

(telegram-desktop:6166): Telegram-WARNING **: 15:46:00.533: Application was built without embedded fonts, this may lead to font issues.
(telegram-desktop:6166): GLib-GObject-WARNING **: 15:46:00.619: cannot register existing type 'GtkWidget'
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(telegram-desktop:6166): GLib-GObject-WARNING **: 15:46:00.619: cannot register existing type 'GtkBuildable'
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed
(telegram-desktop:6166): GLib-CRITICAL **: 15:46:00.619: g_once_init_leave: assertion 'result != 0' failed
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_register_static: assertion 'parent_type > 0' failed

Upgrade to at least version Version 2.8.11-2.0 as that should fix the bug by executing:

pamac upgrade
KDE krunner and Alt+F1 issues


  • krunner does not work, no popup when typing on empty desktop and Alt+F2 shows an empty transparent window within a subdued black frame.
  • application launcher doesn’t open with Alt+F1, and when opened with mouse, the entries in the menu don’t work (restart, shutdown etc.).


  • Reboot through sudo reboot
  • remove from ~/.config :
    • kglobalshortcutsrc
    • krunnerrc
    • plasma-org.kde.plasma.desktop-appletsrc
  • change global theme and login screen to Breeze and reboot
  • login on tty and rm -rf ~/.cache
  • login on graphical screen
  • change global theme and login screen to Breath2 and reboot
KDE Plasma theme uses low contrast colors, harder to read


  • You normally use a dark Plasma theme and notice that text on your Plasma menus, widgets, and tray are more difficult to read due to a lower contrast (light grey on dark grey).

  • This is due to the newly applied Breath2 2021 Dark Plasma theme.

  • breath2-2021-dark


  • Switch back to your previously used Breath2 Dark or Breath Dark theme to bring back higher-contrast text.

  • System SettingsAppearancePlasma Style

  • breath2-original-dark

Dolphin fails to open Konsole using context menu action

Install kinit package.

pamac install kinit

3 posts were split to a new topic: Update breaks dependencies

After the update, whenever I open a new window/application, it seems to be minimized. I use Qtile on a KDE Plasma installation, but load up Qtile instead (when choosing my login). It wasn’t an issue since I installed Qtile 7 months ago or so. This is pretty bad right now. Not sure how to test what caused it.

Kernel: 5.13.19-2-MANJARO
CPU: Intel Xeon E3-1230 v3 (8) @ 3.7GHz
GPU: Nvidia GeForce GTX 1070
DE: KDE Plasma 5.22.5

Just for the record, I downgraded Qtile to the previous version and immediately the windows behave normal again. Right now this is what I have installed.

1 available update:
qtile 0.18.0-2 → 0.18.1-2 community

If the Manjaro team did not edit anything in qtile, then I assume the mainline is affected and I will bug report there.

Solution: v0.18.1 update completely breaks Bsp layout · Issue #2799 · qtile/qtile · GitHub - I missed the solution before posting here, because didn’t look for the correct words in the issues. The Qtile config.py needs to be updated, then it should work.

1 Like

It seems to be an error in the header of the post:

Current stable Nvidia driver wasn’t updated because of GSync bug. Correct me if I am not right


Good catch, edited.


The vertex-maia icons seem to have broken in (xfce) this latest update. I’ve had to swap to the papirus ones which i’m absolutely not a fan of.

Whats the default manjaro XFCE theming nowadays?

The notes app icon is broken too. (In every icon theme) <–This was fixed with a reboot.


4 posts were merged into an existing topic: Update breaks dependencies

Maybe this isn’t the biggest error in the world, but when I open Discord I will get open the “canary” version (yes, i had both installed, just in case if one of the two broke and have to change it quickly to a stable version). I solved this problem removing the “canary” version.
Again, maybe not the biggest issue, but an issue after all I think. If you think this is worthless and have to remove it I don’t have any problem

1 Like

A post was split to a new topic: Question about kernel updates

After the Update brave browser stopped working and its not opening…
when i tried to start with terminal this is the op

/usr/bin/brave: line 27:  9133 Segmentation fault      (core dumped) /usr/lib/brave/brave "$@" $SANDBOX_FLAG $PEPPER_FLASH_FLAG $USER_FLAGS

[Solution]Actually re-installing the brave browser fixed it

1 Like

A post was merged into an existing topic: Update breaks dependencies

Same here.
XFCE with vertex-maia: Desktop Background gone, several icons only monochrome-colored.
Anyone has advice for a similar plain, not clunky icon theme?

Edit: for now I replaced vertex-maia with the arc icon theme

Boot/sddm problem when I went to reboot after update my hard drive with the os completely disappeared had to do a hard reset to put my mother board in safe mode “ASUS mother board”, then do a reset to recover system. FIX I reinstalled sddm, sudo pacman -S sddm and so far so good hope this helps. This only worked for a few reboots. I am trying something else that is working for now, but will wait to post it as a fix to make sure

AUR packages may need to be rebuilt after an update.

1 Like

A post was merged into an existing topic: [Stable Update] 2021-09-24: no more graphical login

A post was split to a new topic: Converted to personal message

A post was split to a new topic: System dead after last update

A post was split to a new topic: KDE Titlebar buttons missing after last update