[Stable Update] 2021-09-16 - Kernels, Steam, Pipewire, Firefox, Thunderbird, Pamac, Pacman

The server is maintained by the university I work for and the version of the ownCloud-client is used on windows and mac for some time already, I guess, and I do not know of anyone else having any problems. So I doubt, that the server version is too old, though I cannot rule that out for sure.

warning: gnome-shell-extension-nightthemeswitcher: local (52-1) is newer than community (51-2)

Ok, thanks, I will look further into that, when I am back at work. Though I thought, if I uninstall the app and re-install it, also the config should get renewed. Also I would suspect this issue shows up for colleagues on Windows and Mac when they had the switch to 2.9.

Did you have a look above at " Known issues and solutions"?. That might sort it out.

1 Like

That’s removing all firefox profiles and should come with a warning to backup bookmarks and whatnot beforehand.

1 Like

I got the error messages of systemd from log journactl -b -p 3 after this update:

 systemd-udevd[329]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[335]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu".
 systemd-udevd[338]: vboxnetctl: /usr/lib/udev/rules.d/60-vboxdrv.rules:3 Only network interfaces can be renamed, ignoring NAME="vboxnetctl".
 systemd-udevd[322]: vboxdrv: /usr/lib/udev/rules.d/60-vboxdrv.rules:1 Only network interfaces can be renamed, ignoring NAME="vboxdrv".
 systemd-udevd[343]: vboxdrvu: /usr/lib/udev/rules.d/60-vboxdrv.rules:2 Only network interfaces can be renamed, ignoring NAME="vboxdrvu"..


Edit the file /lib/udev/rules.d/60-vboxdrv.rules

#KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
#KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

KERNEL=="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

or ignore these messages from the log.


Seems that LibreOffice (Fresh) start page is taking a huge time to load - stuck at the end of the loading bar, I guess something changed in the way it requests recently opened documents as I have online ones in it. No such delay with a direct Writer or Calc opening so it’s not a blocker.

1 Like

The update installed and selected a newer version of the kernel. The newer versions of the kernel leave me without sound. I went back to the 5.10 kernel via GRUB menu and now the sound is back.

1 Like

A post was merged into an existing topic: Manjaro mirrors not updating

manjaro KDE: after this update… when install a software either using pacman or pamac i can’t find the software in application launcher. try few different laucnher/menu but still the same result. i can only run the software via terminal or launch via pamac gui.

octave installed but not appeared

I can’t update because there are 2 dependency errors:

> $ sudo pacman -Syu                                                                                               
:: Synchronizing package databases...                                                                              
 core is up to date                                                                                                
 extra is up to date                                                                                               
 community is up to date                                                                                           
 multilib is up to date                                                                                            
:: Starting full system upgrade...                                                                                 
resolving dependencies...                                                                                          
looking for conflicting packages...                                                                                
error: failed to prepare transaction (could not satisfy dependencies)                                              
:: installing libcap (2.56-1) breaks dependency 'libcap=2.53' required by lib32-libcap                             
:: installing libnsl (2.0.0-1) breaks dependency 'libnsl=1.3.0' required by lib32-libnsl 

Using pamac update I also get the following hint: if possible, remove lib32-libpulse and retry.
Removing lib32-libpulse is obviously not an option, if I want to listen to any audio…

Any suggestions?

A post was merged into an existing topic: Manjaro mirrors not updating

This should be added to the “known issues” list: wget now always outputs “SSL_INIT” to stderr every time it is run. Issue tracked here: GNU Wget - Bugs: bug #61125, Output SSL_INIT to stderr even... [Savannah]

1 Like
  1. uninstall those packages and note which applications need them as they will be uninstalled as well.
  2. upgrade
  3. reinstall the applications that were removed in step 1


A post was split to a new topic: Converted to Personal Message

A post was split to a new topic: Converted to personal message

Yesterday I got the notification in Pamac system tray that 107 updates were available, then I did refresh mirrors using Pamac and shutdown my laptop. Today I get no notification and Pamac shows everything is up to date !

Thanks, but I don’t think that’s feasible.

libcap is apparently required by systemd, ntp, bind, libpulse, zsh, …
I don’t feel comfortable uninstalling systemd :sweat_smile:
Similar situation with libnsl.

Edit: Apparently, I’m did not get the correct signature file for lib32-libcap and lib32-libnsl

error: failed retrieving file 'lib32-libcap-2.53-1-x86_64.pkg.tar.zst.sig' from manjaro.re : The requested URL returned error: 404

I’ll try the solutions in known issues.
Edit 2: Those didn’t work.
Edit 3: However, I can retrieve the .sig file just fine using my browser: http://manjaro.re/stable/multilib/x86_64/lib32-libcap-2.56-1-x86_64.pkg.tar.zst.sig For some reason pacman still requests .sig files for libcap version 2.53 instead of 2.56 and libnsl instead of

I concur! :sweat_smile:

Have a look at this and then perform a:

sudo pacman-mirrors --country YourCountry,NeighbouringCountry --interactive

and take all the ones that are green and fast and try again.



This bug (outdated udev rules that disables important features from nvidia cards: audio over hdmi, USB xHCI Host Controller and USB Type-C UCSI devices) is still present (or at least my file /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules has not been updated).
If this is supposed to work only on new installations (but i think that the two usb devices are still not enabled in the last mhwd-db version) then we probably need to add an entry on the “Known issues and solutions” wiki that explain which lines comment/delete from /etc/udev/rules.d/90-mhwd-prime-powermanagement.rules, otherwise everyone who hasn’t a fresh installation from the new iso will keep this bug forever (or add a script in a new update that patches the current installations).
Here is a possible fix that can use in a feature update/add to the issues wiki (use the same command twice again changing 0x40300 to 0x0c0330 and 0x0c8000 if you also want to enable the usb devices of your card).