[Stable Update] 2021-09-16 - Kernels, Steam, Pipewire, Firefox, Thunderbird, Pamac, Pacman

3 posts were split to a new topic: Manjaro mirrors not updating

Part of the update was the ownCloud Client from 2.8 to 2.9, which does not seem to be able to connect to the ownCloud server anymore. Generic error: “No owncloud connection configured.” Both here and on the ARM R-Pi update as well. Simple solutions of logging off and on again or re-install and all that does not help. If there is no fix, can we go back to the old 2.8 version. This is really crucial for work for me.
But apart from that, smooth sailing!

Edit: So as far as I can see there seems to be a problem with the 2.9 version of the ownCloud Client that is not fixed yet: Migration from 2.8.1 to 2.9.0 fails silently · Issue #9019 · owncloud/client · GitHub
So as long as the 2.9 version can hardly be called stable, maybe the 2.8 version is the better choice for the stable release as for now.

1 Like

Kernel 5.13 works very well but 5.14 give me only dummy output on sound (no soundcard were recognized) and if i want to restart the machine it takes a long time with error messages (systemd-shutdown SIGTERM/SIGKILL to PID… waiting for process pulseaudio). Tried deleting config and cookies from pulse, but doesn’t working

arecord -l

Zusammenfassung
arecord -l                                                       ✔ 
**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 0: Intel [HDA Intel], Gerät 0: ALC888 Analog [ALC888 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: Intel [HDA Intel], Gerät 2: ALC888 Alt Analog [ALC888 Alt Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: DSP [Hammerfall DSP], Gerät 0: RME Hammerfall HDSP 9632 [RME Hammerfall HDSP 9632]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0

lspci

Zusammenfassung
lspci                                                            ✔ 
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6111/6121 SATA II / PATA Controller (rev b2)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)
05:00.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall DSP (rev 9a)

sudo dmesg | egrep -i ‘(snd|sof|alsa|hda)’

Zusammenfassung
sudo dmesg | egrep -i '(snd|sof|alsa|hda)'              1 ✘  5s  
[    0.313884] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    0.340287] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.340288] software IO TLB: mapped [mem 0x00000000bbfb0000-0x00000000bffb0000] (64MB)
[    8.081089] snd_hda_intel 0000:01:00.1: Disabling MSI
[    8.081097] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    8.317145] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC888: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    8.317151] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    8.317153] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    8.317155] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    8.317156] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[    8.317158] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    8.317159] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    8.317161] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[    8.317162] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[    8.331281] input: HDA Intel Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[    8.331341] input: HDA Intel Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[    8.331394] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[    8.331456] input: HDA Intel Line Out Front as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
[    8.331504] input: HDA Intel Line Out Surround as /devices/pci0000:00/0000:00:1b.0/sound/card0/input16
[    8.331552] input: HDA Intel Line Out CLFE as /devices/pci0000:00/0000:00:1b.0/sound/card0/input17
[    8.331601] input: HDA Intel Line Out Side as /devices/pci0000:00/0000:00:1b.0/sound/card0/input18
[    8.331647] input: HDA Intel Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input19
[    8.341399] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input20
[    8.341448] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input21
[    8.341493] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input22
[    8.341541] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input23
[    8.341586] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input24
[    8.341629] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input25
[    8.341673] input: HDA NVidia HDMI/DP,pcm=12 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input26
[   20.033865] RIP: 0010:snd_dma_buffer_mmap+0x5/0x40 [snd_pcm]
[   20.033906]  snd_pcm_mmap_data+0x127/0x140 [snd_pcm]
[   20.033959] Modules linked in: squashfs loop mousedev joydev rfkill snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic iTCO_wdt intel_pmc_bxt iTCO_vendor_support ledtrig_audio coretemp gpio_ich kvm_intel snd_hdsp snd_hda_intel snd_intel_dspcfg snd_intel_sdw_acpi snd_hda_codec r8169 kvm snd_rawmidi snd_hda_core snd_seq_device snd_hwdep snd_pcm irqbypass snd_timer realtek snd mdio_devres libphy intel_agp soundcore intel_gtt i2c_i801 i2c_smbus lpc_ich agpgart nvidia_drm(POE) mac_hid pcspkr nvidia_modeset(POE) drm_kms_helper cec syscopyarea sysfillrect sysimgblt fb_sys_fops nvidia(POE) fuse drm crypto_user ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 ata_generic pata_acpi usbhid pata_marvell
[   20.034010] RIP: 0010:snd_dma_buffer_mmap+0x5/0x40 [snd_pcm]

systemctl --user status pulseaudio.service

Zusammenfassung
systemctl --user status pulseaudio.service                       ✔ 
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor>
     Active: active (running) since Thu 2021-09-16 20:45:47 CEST; 22min ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 1242 (pulseaudio)
      Tasks: 6 (limit: 9519)
     Memory: 6.4M
        CPU: 79ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulsea>
             ├─1242 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─1265 /usr/lib/pulse/gsettings-helper

Sep 16 20:45:46 HAL-IIOXX1-p35-7345 systemd[1110]: Starting Sound Service...
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to open cookie fil>
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to load authentica>
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to open cookie fil>
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to load authentica>
Sep 16 20:45:47 HAL-IIOXX1-p35-7345 pulseaudio[1242]: stat('/etc/pulse/default.>
Sep 16 20:45:47 HAL-IIOXX1-p35-7345 systemd[1110]: Started Sound Service.
Sep 16 20:46:11 HAL-IIOXX1-p35-7345 pulseaudio[1242]: GetManagedObjects() faile>
lines 1-20/20 (END)...skipping...
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor>
     Active: active (running) since Thu 2021-09-16 20:45:47 CEST; 22min ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 1242 (pulseaudio)
      Tasks: 6 (limit: 9519)
     Memory: 6.4M
        CPU: 79ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulsea>
             ├─1242 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─1265 /usr/lib/pulse/gsettings-helper

Sep 16 20:45:46 HAL-IIOXX1-p35-7345 systemd[1110]: Starting Sound Service...
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to open cookie fil>
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to load authentica>
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to open cookie fil>
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to load authentica>
Sep 16 20:45:47 HAL-IIOXX1-p35-7345 pulseaudio[1242]: stat('/etc/pulse/default.>
Sep 16 20:45:47 HAL-IIOXX1-p35-7345 systemd[1110]: Started Sound Service.
Sep 16 20:46:11 HAL-IIOXX1-p35-7345 pulseaudio[1242]: GetManagedObjects() faile>
~
~
~
~
lines 1-20/20 (END)
pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
     Active: active (running) since Thu 2021-09-16 20:45:47 CEST; 22min ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 1242 (pulseaudio)
      Tasks: 6 (limit: 9519)
     Memory: 6.4M
        CPU: 79ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             ├─1242 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─1265 /usr/lib/pulse/gsettings-helper

Sep 16 20:45:46 HAL-IIOXX1-p35-7345 systemd[1110]: Starting Sound Service...
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to open cookie file '/home/lir/.config/pulse/cookie': Datei oder Verzeichnis nicht gefunden
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to load authentication key '/home/lir/.config/pulse/cookie': Datei oder Verzeichnis nicht gefunden
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to open cookie file '/home/lir/.pulse-cookie': Datei oder Verzeichnis nicht gefunden
Sep 16 20:45:46 HAL-IIOXX1-p35-7345 pulseaudio[1242]: Failed to load authentication key '/home/lir/.pulse-cookie': Datei oder Verzeichnis nicht gefunden
Sep 16 20:45:47 HAL-IIOXX1-p35-7345 pulseaudio[1242]: stat('/etc/pulse/default.pa.d'): Datei oder Verzeichnis nicht gefunden
Sep 16 20:45:47 HAL-IIOXX1-p35-7345 systemd[1110]: Started Sound Service.
Sep 16 20:46:11 HAL-IIOXX1-p35-7345 pulseaudio[1242]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy >

journalctl

Zusammenfassung
journalctl -p2 -b -0                                                                                                                                                                                                               INT ✘ 
-- Journal begins at Mon 2021-09-13 12:39:41 CEST, ends at Thu 2021-09-16 21:25:03 CEST. --
Sep 16 20:45:28 HAL-IIOXX1-p35-7345 kernel: BUG: kernel NULL pointer dereference, address: 0000000000000000
Sep 16 20:45:28 HAL-IIOXX1-p35-7345 kernel: #PF: supervisor read access in kernel mode
Sep 16 20:45:28 HAL-IIOXX1-p35-7345 kernel: #PF: error_code(0x0000) - not-present page

A post was split to a new topic: After the last update I get VBOX warnings

I had a small issue where dnscrypt-proxy was not working upon reboot. I had to remove my old dnscrypt-proxy.toml file and edit my dnscrypt-proxy.toml.pacnew file accordingly and remove the .pacnew suffix.

1 Like

Please read this:

Especially the Linux has multiple kernels section and then install an LTS kernel.

:bowing_man:

A post was merged into an existing topic: OpenGL not working after system update

2 posts were split to a new topic: After last update I got a new kernel

A post was split to a new topic: Keyring error on last update

A post was split to a new topic: Converted to personal message

Maybe the server version is too old now?

Found the forum thread that explained the key-ring “issue” I reported…

You might want to check the owncloud client change log. Perhaps they made a change from 2.8 to 2.9 that is no longer compatible with your owncloud config.

“Bugfix - Removed support for client side certificates”
“Change - Don’t ask the user to switch to http”
“Change - Remove support for http redirects”
“Change - We no longer try to locate an ownCloud install at /owncloud”

1 Like

Having that same issue with the keyring, no suggested solution for keyring issues helped with it.

I mean idk if it matters or not, since I’m not seeing any side effects from those errors, but since they are errors and not just warnings it’s a little alarming

I have an issue, suddenly firefox vaapi doesn’t work.

I’ve checked the whole config as per Firefox - ArchWiki
and I have changed nothing, but now it doesn’t work.


[Child 4440: MediaPDecoder #1]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: MediaPDecoder #1]: D/PlatformDecoderModule Initialising VA-API FFmpeg decoder
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x32315659 -> yuv420p.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x30323449 -> yuv420p.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x3231564e -> nv12.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x32595559 -> yuyv422.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x59565955 -> uyvy422.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x48323234 -> yuv422p.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x58424752 -> rgb0.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x58524742 -> bgr0.
[AVHWDeviceContext @ 0x7ff34a2a0580] Format 0x30313050 -> p010le.
[AVHWDeviceContext @ 0x7ff34a2a0580] VAAPI driver: Intel i965 driver for Intel(R) Haswell Server - 2.4.1.
[AVHWDeviceContext @ 0x7ff34a2a0580] Driver not found in known nonstandard list, using standard behaviour.
[h264 @ 0x7ff34ea1a800] nal_unit_type: 7(SPS), nal_ref_idc: 3
[h264 @ 0x7ff34ea1a800] log2_max_frame_num_minus4 out of range (0-12): 32
[h264 @ 0x7ff34ea1a800] SPS decoding failure, trying again with the complete NAL
[h264 @ 0x7ff34ea1a800] log2_max_frame_num_minus4 out of range (0-12): 32
[h264 @ 0x7ff34ea1a800] log2_max_frame_num_minus4 out of range (0-12): 32
[h264 @ 0x7ff34ea1a800] SPS decoding failure, trying again after escaping the NAL
[h264 @ 0x7ff34ea1a800] nal_unit_type: 7(SPS), nal_ref_idc: 3
[h264 @ 0x7ff34ea1a800] log2_max_frame_num_minus4 out of range (0-12): 32
[h264 @ 0x7ff34ea1a800] SPS decoding failure, trying again with the complete NAL
[h264 @ 0x7ff34ea1a800] log2_max_frame_num_minus4 out of range (0-12): 32
[h264 @ 0x7ff34ea1a800] log2_max_frame_num_minus4 out of range (0-12): 32
[h264 @ 0x7ff34ea1a800] nal_unit_type: 8(PPS), nal_ref_idc: 3
[h264 @ 0x7ff34ea1a800] sps_id 0 out of range
[h264 @ 0x7ff34ea1a800] SPS decoding failure, trying again after escaping the NAL
[h264 @ 0x7ff34ea1a800] nal_unit_type: 8(PPS), nal_ref_idc: 3
[h264 @ 0x7ff34ea1a800] sps_id 0 out of range
[Child 4440: MediaPDecoder #1]: D/PlatformDecoderModule VA-API FFmpeg init successful
[Child 4440: Main Thread]: D/PlatformDecoderModule Sandbox RDD decoder supports requested type
[Child 4440: Main Thread]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: Main Thread]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: Main Thread]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: Main Thread]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: Main Thread]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: MediaPDecoder #1]: D/PlatformDecoderModule Sandbox RDD decoder rejects requested type
[Child 4440: MediaPDecoder #1]: D/PlatformDecoderModule Initialising VA-API FFmpeg decoder
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x32315659 -> yuv420p.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x30323449 -> yuv420p.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x3231564e -> nv12.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x32595559 -> yuyv422.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x59565955 -> uyvy422.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x48323234 -> yuv422p.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x58424752 -> rgb0.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x58524742 -> bgr0.
[AVHWDeviceContext @ 0x7ff34889c480] Format 0x30313050 -> p010le.
[AVHWDeviceContext @ 0x7ff34889c480] VAAPI driver: Intel i965 driver for Intel(R) Haswell Server - 2.4.1.
[AVHWDeviceContext @ 0x7ff34889c480] Driver not found in known nonstandard list, using standard behaviour.
[h264 @ 0x7ff348822800] nal_unit_type: 7(SPS), nal_ref_idc: 3

:warning: The following fix will remove all Firefox settings and profiles so everything will be rested to default!

Removing

~/.mozilla
~/.cache/mozilla
~/.pulse

will fix it though…

2 Likes

During and after upgrade, i got an issue with archlinux keyring and manjaro keyring. Then after reboot i got an " attempt to read or write outside of disk ‘hd0’ ". I had to shutdown my oldie laptop with it’s on/off button, after that in grub options i select initramfs and that’s how i’m writing here. I don’t know what could happen and less if it have a solution. The first thing i tried before writing here in the forum was to prove if the system was update, and for my own disgrace it was.

I can’t speak for others, but on my end in Germany I often get the update before even a post in this forum was made (at least based on the RSS Feed for the stable announcements). But today I still don’t have the update on my PC.

5 posts were merged into an existing topic: Manjaro mirrors not updating

The server is maintained by the university I work for and the version of the ownCloud-client is used on windows and mac for some time already, I guess, and I do not know of anyone else having any problems. So I doubt, that the server version is too old, though I cannot rule that out for sure.

warning: gnome-shell-extension-nightthemeswitcher: local (52-1) is newer than community (51-2)