[Stable Update] 2021-08-09 - Kernels, Xorg-Server, Systemd, Virtualbox, Mesa, Plasma, Pipewire

Only issue I had with this update was with Visual Studio Code (VSCode) from Snap.
Had to install the Flatpak version, which I don’t like to do…

This is because the Snap version was published using classic confinement.

The error message when installing is:

cannot install “code”: classic confinement requires snaps under /snap or symlink from /snap to /var/lib/snapd/snap


Do not like versions in our repo and AUR?

$ pacman -Si code
Repository      : community
Name            : code
Version         : 1.58.0-1
Description     : The Open Source build of Visual Studio Code (vscode) editor

Binary releases of VS Code without MS branding/telemetry/licensing: http://aur.archlinux.org/packages/vscodium-bin

1 Like

I removed the packages and other similar pulseaudio packages which were giving me trouble.
I removed pulseaudio-equaliser; pulseaudio-jack; pulseaudio-lirc; pulseaudio-rtp and pulseaudio-zeroconf only then was I able to update.
Now on doing so, my GNOME doesn’t have audio anymore. On battery connection, increasing volume and other GNOME sounds aren’t there.
How do I solve this? The above packages were required for GNOME for the audio.
(Audio from Spotify, Chrome etc works fine, only GNOME audio is gone)
I installed pipewire-pulse recently, could this have something to do with it?

Yes it does - it conflicted with your pulseaudio-* packages. Just look at the initial error message you posted.
I assumed your system used pipewire for audio and that pulseaudio-equalizer package was a leftover/oversight of a switch from pulseaudio to pipewire.
Try (completly) installing pipewire support:

$ sudo pacman -Syu manjaro-pipewire

If this doesn’t bring your audio back, please open a new thread for the problem.

1 Like

There was a mini update today, “manjaro-kde-settings” , version 20210812-1.
The color function got disabled after the update.


A post was split to a new topic: Gnome Development ISO installation problems

Moreover, Yakuake does not autostart for me after this update, and when it’s launched manually, its icon looks differently. All of these problems are fixed after downgrading to manjaro-kde-settings-20210806-1.

I know, that’s what I ended up doing. :wink:

I ended up switching to a different color theme, then switching back to my original color theme (Breath2 Dark) and this resolved the problem for me. I didn’t need to downgrade any packages.

After doing this, then logging out, then logging back in, my colors are back to how they originally were. :slight_smile:

It appears the update triggered a new naming schema for color themes, perhaps?

Looks like something changed under

  • $HOME/.kde4/share/apps/color-schemes/
  • $HOME/.kde4/share/config/
1 Like

I had some problems with the stability of digiKam + database compatibility when coning from digikam 7.2 and it looks that my database even was still in version 12 (I do use the integrated MySQL option (mariadb)).

That’s what happened:
When starting digiKam 7.3 the error came up that my DB is still on version 12 and it failed to be updated to version 13.
This is a known error which is fixed in digiKam 7.4! ([digikam] [Bug 440212] New: Digikam 7.3.0 fails to update the database schema from version 12 to version 13). Workaround by manually editing version information in DB and then executing a migration to SQLite und back to MySQL was not working because digiKam was crashing a few seconds when is started to working with the DB.

So I executed a downgrade back to digiKam 7.2.0-5… Starting digiKam was possible again, but when the database was utilized the whole programmed crashed again.

in user log I found something like this (partial copy& paste)

Aug 13 17:07:24 uranus systemd-coredump[35854]: [🡕] Process 35709 (digikam) of user 1000 dumped core.
                                                Stack trace of thread 35709:
                                                #0  0x00007f1920066953 n/a (libmariadb.so.3 + 0x1f953)
                                                #1  0x00007f192007479c n/a (libmariadb.so.3 + 0x2d79c)
                                                #2  0x00007f192006eca7 n/a (libmariadb.so.3 + 0x27ca7)
                                                #3  0x00007f1920070887 mysql_stmt_fetch (libmariadb.so.3 + 0x29887)
                                                #4  0x00007f19201882ed n/a (libqsqlmysql.so + 0x72ed)
                                                #5  0x00007f1948edfa79 _ZN7Digikam15BdEngineBackend10readToListERNS_16DbEngineSqlQueryE (libdigikamcore.so.7.2.0 + 0x928a79)
                                                #6  0x00007f1948edfba2 _ZN7Digikam15BdEngineBackend17handleQueryResultERNS_16DbEngineSqlQueryEP5QListI8QVariantEPS4_ (libdigikamcore.so.7.2.0 + 0x928ba2)
                                                #7  0x00007f1948ee132b _ZN7Digikam15BdEngineBackend7execSqlERK7QStringRK8QVariantP5QListIS4_EPS4_ (libdigikamcore.so.7.2.0 + 0x92a32b)
                                                #8  0x00007f194936f965 _ZNK7Digikam6CoreDB15getItemPositionEx6QFlagsINS_14DatabaseFields18ItemPositionsFieldEE (libdigikamdatabase.so.7.2.0 + 0xa0965)
                                                #9  0x00007f19493e5d32 n/a (libdigikamdatabase.so.7.2.0 + 0x116d32)
                                                #10 0x00007f19493e645c _ZN7Digikam12ItemPositionC2Ex (libdigikamdatabase.so.7.2.0 + 0x11745c)
                                                #11 0x00007f19493ceb8c _ZNK7Digikam8ItemInfo13imagePositionEv (libdigikamdatabase.so.7.2.0 + 0xffb8c)
                                                #12 0x00007f19493ceea2 _ZNK7Digikam8ItemInfo14hasCoordinatesEv (libdigikamdatabase.so.7.2.0 + 0xffea2)
                                                #13 0x00007f1949b425ab n/a (libdigikamgui.so.7.2.0 + 0x5c05ab)
                                                #14 0x00007f19474064ff _ZN7QObject5eventEP6QEvent (libQt5Core.so.5 + 0x2e64ff)
                                                #15 0x00007f1947eadd62 _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent (libQt5Widgets.so.5 + 0x15ad62)
                                                #16 0x00007f19473d93aa _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x2b93aa)
                                                #17 0x00007f19473dc4a9 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x2bc4a9)
                                                #18 0x00007f19474329a4 n/a (libQt5Core.so.5 + 0x3129a4)
                                                #19 0x00007f193632310c g_main_context_dispatch (libglib-2.0.so.0 + 0x5410c)
                                                #20 0x00007f1936376b99 n/a (libglib-2.0.so.0 + 0xa7b99)
                                                #21 0x00007f1936320871 g_main_context_iteration (libglib-2.0.so.0 + 0x51871)
                                                #22 0x00007f1947431fd6 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x311fd6)
                                                #23 0x00007f19473d7d1c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b7d1c)
                                                #24 0x00007f194983523a _ZN7Digikam14ScanController26completeCollectionScanCoreEbb (libdigikamgui.so.7.2.0 + 0x2b323a)
                                                #25 0x00007f19499c5659 _ZN7Digikam14NewItemsFinder9slotStartEv (libdigikamgui.so.7.2.0 + 0x443659)

cause and solution:
there is an incompatibility with the mariadb version 10.6. A downgrade to mariadb 10.5.11-1 resolved all the trouble. Now digiKam 7.2 works stable again.

I am now converting thew database to SQlite and then upgrade all packages back to current Manjaro stable branch release and wait for digiKam 7.4 for switching back to MySQL as DB system for digiKam.

So two issues:
I came from digiKam version 7.2 a

Since this latest update, libmagick6 keeps wanting to be reinstalled for some reason. I can go through the process below any number of times, but despite reinstalling a number of times it keeps coming up as something that needs to be installed yet again…even though pamac knows that it’s already up to date. This is true on two different systems – a desktop and a laptop.

What should I do to get out of this loop?

sudo pamac upgrade
[sudo] password for jwalsh: 
Warning: Building packages as root
Warning: Setting build directory to /var/cache/pamac
Checking libmagick6 dependencies...
Synchronizing package databases...
Warning: manjaro-hello: local (0.6.7-2) is newer than extra (0.6.6-6)
Warning: libmagick6- is up to date -- reinstalling
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  libmagick6                 AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] 

It was a part of update to fix wrong plasma colors for new users. I’ve changed /etc/xdg/kdeglobals and added colors there hoping Plasma will just override settings from home folder (it was a case for me) for existing users but it looks like some colors don’t work this way. So I reverted this change and added kdeglobals to create per-user on a new user creation.

1 Like

This update broke Carla. Apparently it expects fluidsynth.so.2.

  Python version: 3.9.6
  Qt version:     5.15.2
  PyQt version:   5.15.4
  Binary dir:     /usr/lib/carla
  Resources dir:  /usr/share/carla/resources
Traceback (most recent call last):
  File "/usr/share/carla/carla", line 46, in <module>
    host = initHost(initName, libPrefix, False, False, True)
  File "/usr/share/carla/carla_host.py", line 3201, in initHost
    host = HostClass() if HostClass is not None else CarlaHostQtDLL(libname, loadGlobal)
  File "/usr/share/carla/carla_backend_qt.py", line 96, in __init__
    CarlaHostDLL.__init__(self, libName, loadGlobal)
  File "/usr/share/carla/carla_backend.py", line 2614, in __init__
    self.lib = CDLL(libName, RTLD_GLOBAL if loadGlobal else RTLD_LOCAL)
  File "/usr/lib/python3.9/ctypes/__init__.py", line 374, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: libfluidsynth.so.2: cannot open shared object file: No such file or directory

I checked and found libfluidsynth.so.3 in /usr/lib and /usr/lib32

I have no idea why, but I think grub was broked (maybe it’s only my problem).
Have this update log with yay and it hangs ~20 minutes:
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Canceled w/ Ctrl+C the step, and the update finished w/o any problems.
After this, I tried to run manually update-grub and got same issue it’s hanged os-prob (also try to run this manually for checking output, but got a frozen process).
So I have not rebooted the system yet, but I feel that everything will break, and the grab will not be able to start.
Maybe can someone tell me what I can do before the reboot, so that everything I need is guaranteed to be “registered” in the grub?

My only problem with the OSS version are the extensions.
Some don’t exist for it and lately I’ve been having an error “We cannot connect to the Extensions Marketplace at this time, please try again later”.

But yes, I would prefer your version

I got brave, and updated the “manjaro-kde-settingss-20210813”, and … it worked!

Thanks for fixing it so quick! :slightly_smiling_face:


Thank you. I’m sorry for introducing it in the first place.

WARNING: Possibly missing firmware for module: xhci_pci

[2021-08-14T11:02:20-0700] [ALPM-SCRIPTLET] → Running build hook: [autodetect]
[2021-08-14T11:02:20-0700] [ALPM-SCRIPTLET] → Running build hook: [modconf]
[2021-08-14T11:02:20-0700] [ALPM-SCRIPTLET] → Running build hook: [block]
[2021-08-14T11:02:22-0700] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-08-14T11:02:23-0700] [ALPM-SCRIPTLET] → Running build hook: [keyboard]
[2021-08-14T11:02:24-0700] [ALPM-SCRIPTLET] → Running build hook: [keymap]
[2021-08-14T11:02:24-0700] [ALPM-SCRIPTLET] → Running build hook: [filesystems]
[2021-08-14T11:02:25-0700] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-08-14T11:02:25-0700] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-5.10-x86_64.img
[2021-08-14T11:02:27-0700] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-08-14T11:02:27-0700] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: ‘fallback’
[2021-08-14T11:02:27-0700] [ALPM-SCRIPTLET] → -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64-fallback.img -S autodetect
[2021-08-14T11:02:27-0700] [ALPM-SCRIPTLET] ==> Starting build: 5.10.56-1-MANJARO
[2021-08-14T11:02:27-0700] [ALPM-SCRIPTLET] → Running build hook: [base]
[2021-08-14T11:02:28-0700] [ALPM-SCRIPTLET] → Running build hook: [udev]
[2021-08-14T11:02:28-0700] [ALPM-SCRIPTLET] → Running build hook: [modconf]
[2021-08-14T11:02:28-0700] [ALPM-SCRIPTLET] → Running build hook: [block]
[2021-08-14T11:02:36-0700] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-08-14T11:02:39-0700] [ALPM-SCRIPTLET] → Running build hook: [keyboard]

After upgrade and reboot, everything seems to be working…

$ inxi -Fazy

$ inxi -Fazy
Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64
root=UUID=4d464d76-9602-468d-b8a8-37cc84ee3a5b rw rootflags=subvol=@ quiet
Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: Acer product: Aspire E5-722G v: V1.11 serial:
Mobo: Acer model: Aspire E5-722G v: V1.11 serial: UEFI: Insyde
v: 1.11 date: 03/10/2016
ID-1: BAT0 charge: 35.7 Wh (100.0%) condition: 35.7/37.0 Wh (96.4%)
volts: 17.2 min: 14.8 model: SANYO type: Li-ion serial:
status: Not charging
Info: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics bits: 64
type: MCP arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1
microcode: 7030105 cache: L2: 2 MiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 17572
Speed: 998 MHz min/max: 1000/2200 MHz boost: enabled Core speeds (MHz):
1: 998 2: 998 3: 999 4: 998
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Acer Incorporated ALI
driver: radeon v: kernel alternate: amdgpu bus-ID: 00:01.0
chip-ID: 1002:9851 class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon
520 Mobile]
vendor: Acer Incorporated ALI driver: radeon v: kernel alternate: amdgpu
bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380
Device-3: Sunplus Innovation HD WebCam type: USB driver: uvcvideo
bus-ID: 2-1.2:4 chip-ID: 1bcf:2c81 class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4")
s-diag: 485mm (19.1")
OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.10.56-1-MANJARO LLVM 12.0.1)
v: 4.5 Mesa 21.1.6 direct render: Yes
Device-1: AMD Kabini HDMI/DP Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840
class-ID: 0403
Device-2: AMD FCH Azalia vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000
bus-ID: 02:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0f1 state: up speed: 100 Mbps duplex: full mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel port: 2000 bus-ID: 03:00.0
chip-ID: 168c:0042 class-ID: 0280
IF: wlp3s0 state: down mac:
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb
v: 0.8 bus-ID: 2-1.1:3 chip-ID: 04ca:3015 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 931.51 GiB used: 13.16 GiB (1.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-22JC3T0
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: rev: 1A01 scheme: GPT
ID-1: / raw-size: 30 GiB size: 30 GiB (100.00%) used: 8.27 GiB (27.6%)
fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 37.5 MiB (39.0%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 40 GiB size: 40 GiB (100.00%) used: 4.85 GiB (12.1%)
fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 30 GiB size: 30 GiB (100.00%)
used: 8.27 GiB (27.6%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 10 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda4 maj-min: 8:4
System Temperatures: cpu: 39.0 C mobo: 39.0 C
Fan Speeds (RPM): N/A
GPU: device: radeon temp: 39.0 C device: radeon temp: 37.0 C
Processes: 227 Uptime: 20m wakeups: 1 Memory: 6.74 GiB
used: 1.76 GiB (26.1%) Init: systemd v: 248 tool: systemctl Compilers:
gcc: 11.1.0 Packages: pacman: 1033 lib: 285 Shell: Bash v: 5.1.8
running-in: xfce4-terminal inxi: 3.3.06

You should have accepted the first time. Everyone accepted this.
Not sure what would happen now if you rebooted.

You might try rerunning pamac upgrade

pamac update in tty3 switched to the logged in graphical user interface after downloading and installing and a few scripts. Switching to tty3 was no longer possible using the keyboard. After a restart, the boot entry no longer worked.
Error: “File /boot/vmlinuz-5.10-x86_64 not found.”