[Stable Update] 2021-07-23 - Kernels, Nvidia, Mesa, Wine, Firefox, Thunderbird, Virtualbox

Nextcloud problem and workaround

After upgrading mariadb to 10.6.3-1 and executing

sudo systemctl restart mariadb.service && sudo mariadb-upgrade -u root -p

Nextcloud doesn’t work anymore showing several errors, all of them related to “InnoDB refuses to write tables with ROW_FORMAT=COMPRESSED or KEY_BLOCK_SIZE.

In /etc/my.cnf.d/server.cnf under section [mariadb] put:


Workaround found here: Arch Forum - [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6


Enable User Theme from Extensions.

1 Like
 (telegram-desktop:6166): Telegram-WARNING **: 15:46:00.533: Application was built without embedded fonts, this may lead to font issues.

(telegram-desktop:6166): GLib-GObject-WARNING **: 15:46:00.619: cannot register existing type 'GtkWidget'

(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(telegram-desktop:6166): GLib-GObject-WARNING **: 15:46:00.619: cannot register existing type 'GtkBuildable'

(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(telegram-desktop:6166): GLib-CRITICAL **: 15:46:00.619: g_once_init_leave: assertion 'result != 0' failed

(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_register_static: assertion 'parent_type > 0' failed

good morning everyone and thanks for everything …the update went well but telegram fails to open…with that error from the terminal…version

1 Like
  • Go to System Settings
  • Type Splas
  • Click Splash Screen
  • Take Breath2

5 posts were split to a new topic: KDE Logo in splash screen instead of Manjaro after update

3 posts were split to a new topic: KDE Meta key doesn’t open menu after update

I have the same problem here. On Arch this is already reported as a bug.

The update went well at first glance, but my computer froze twice since I installed it. I had to shut it down by force each time.

Logs : https://paste.ubuntu.com/p/cgXdms3fth/


seems there is a bug at Arch: FS#71541 : [telegram-desktop] telegram-desktop doesn't work after update to 2.8.11-1

I’m using KDE,cannot reproduce,telegram works fine on my machine :thinking:

Please read this:

Have you tried 5.10 LTS (Long Term Support) already?

telegram-desktop version 2.8.11-2.0 should fix the bug.


Same here in Manjaro XFCE. A temporary workaround it to launch it with

QT_QPA_PLATFORMTHEME=fusion telegram-desktop

But this updates includes just that version (2.8.11-2), isn’t it? Also in the Arch bug track one comment says that it persists in 2.8.11-2.

I don’t know if you have more information on the issue, but it seems to me that it is not fixed for everybody in this version?

PS: Mine works fine.

Edit: I can confirm from a friend that the problem persists with 2.8.11-2. (XFCE)

For KDE users who wish to re-apply their preferred login splash screen:

  • Backup / remove the old ksplashrc file:
  • mv ~/.config/ksplashrc ~/.config/ksplashrc.bak
  • Go to System Settings
  • Type in Splash
  • Click on Splash Screen
  • Select and Apply your desired splash screen

Mostly working but I did have a Bluetooth issue. I could not pair with any of my Bluetooth devices after the upgarde. Deleting the paired devices and pairing again seems to have worked. No idea what that was about.

1 Like

good morning everyone…thanks for the information…glad it works on kde(years ago my desktop)but i am on xfce…
it doesn’t matter…it works with the version downloaded from telegram website(2.8.10)
Greetings and a hug

Bildschirmfoto vom 2021-07-23 20-04-10

1 Like

Sorry, I don’t understand. That’s my point precisely. This update includes already the updated package, but some people still have problems.

The update initially came with 2.8.11-2, which is buggy.
It was later updated to 2.8.11-2.0, which does not anymore have the bug (I can confirm it).

The patched version has not reached all the mirrors yet.