[Stable Update] 2021-05-19 - Kernels, Nvidia, KDE Frameworks, Plasma, Systemd, LibreOffice, KDE Gear Mobile, FF, TB

Hello community,

Another stable branch update with some usual updates for you.

You may want to get our latest stable release from here.

  • Most of our Kernels got updated
  • Nvidia got updated to 460.80. More info about possible issues with this driver in our Known Issues and solutions section or the Nvidia Forum
  • We added Plasma Mobile Gear Apps. More info about them here.
  • Gnome Apps got mostly updated to 40.1. We are still shipping 3.38 shell!
  • Maui Apps are now at 1.2.2
  • We updated Systemd to 247.7
  • Firefox 88.0.1 and Thunderbird 78.10.1 got updated.
  • LibreOffice is at 7.1.3
  • KDE Frameworks got updated to 5.82.0
  • KDE Plasma is now at 5.21.5
  • Lot of KDE-git package updates
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.268
  • linux49 4.9.268
  • linux414 4.14.232
  • linux419 4.19.190
  • linux54 5.4.118
  • linux510 5.10.36
  • linux511 5.11.19
  • linux512 5.12.2
  • linux513 5.13-rc1
  • linux54-rt 5.4.106_rt54
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed May 12 09:56:17 CEST 2021)

  • stable community x86_64: 1194 new and 1344 removed package(s)
  • stable core x86_64: 36 new and 34 removed package(s)
  • stable extra x86_64: 691 new and 830 removed package(s)
  • stable kde-unstable x86_64: 360 new and 358 removed package(s)
  • stable multilib x86_64: 25 new and 20 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

New issues:

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • Some Nvidia cards don’t work with the current 460.80 drivers when used with Display Port and/or 4k Monitors. More about the issue at the Nvidia Developer Forum. We recommend to switch to Nouveau driver as needed. If you however need the Nvidia driver, you can get the PKGBUILDs of the 460.73.01 version and build your driver locally with makepkg or use the pre-compiled packages: nvida-utils, dkms and lib32 + precompiled .

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

GDM does not start (black screen when booting gnome edition)

Log into your system via tty and depending on your use of Plymouth or bootsplash-systemd choose a option from this post


Here are some new links via CDN77.com

Download XFCE





Minimal (linux54)


Download GNOME





Minimal (linux54)


Download KDE





Minimal (linux54)



I would have not promoted nvidia 460.80 to stable, knowing about the issues with DP ports…


Still the “old” Pamac GUI ?

Funny to have had a glimpse on the (neat) new one earlier this week (then reversed)

All ok here, thanks for all this ! :slight_smile:

1 Like

@nam1962 you can switch to testing branch to test the new UI out as you wish. Will bring also newer packages.

Update seems o.k. - no error messages, reboot… then blackscreen.

Try to boot older kernel, same issue. Terminal session with Ctrl-Alt-F2 not possible… black is black :woozy_face:
Next I will try to go back with livestick and timeshift - hopefully - it is first time for me.
Perhaps NVIDIA error (GTX 1080)?
System 2 with AMD-GPU (Ryzen 4650G) update seems without problems (nearly same config and apps).


Oh, I see @philm above… 4k not mine, but 3840x1600 and DP. Perhaps here is Screen-Output on HDMI?
What is to do?

1 Like

Hi there.
When trying to update via the GUI I got an error message about conflicting files.

  • plasma-workspace: /usr/share/locale/ta/LC_MESSAGES/kcm_autostart.mo already exists in filesystem (owned by plasma-desktop-primex)

I found a post from three days ago where someone on the testing branch had the same error and it seemed to have been resolved by replacing plasma-desktop-primex with regular plasma-desktop so that’s what I tried.

I’m quite new to this whole Linux thing so I’m probably missing something but a few issues come up that I can’t seem to find solutions for.

  • After updating it prompts me to reboot, but when I try to do so the screen blurs out and nothing more happens. I ended up opening up Yakuake and entering “shutdown now”.
  • After starting up the computer again, my plasma seems to be broken. No desktop background (just completely black and can’t right click on it). No task bar or start menu. alt+ space doesn’t work yet if I move my mouse to the top left corner of the screen I get the activity switcher as usual. I have restored my previous system twice via Timeshift and tried the update again but with no different result.

Any suggestions or help would be very appreciated.

EDIT: Edited for clarity.

1 Like

And so, I tried updating as random crashes in AMD still persist, but when opening Pamac no update was available yet. I refreshed the database, and nothing. Finally I shut down the computer and there seems to be a regression (at least in GNOME), because the system took a good few minutes to shut down (which had not happened in a while).
Due to these problems, I no longer use my laptop as much as I used to, because I spend more time here in the forums than in my actual system. When activating automatic updates in Pamac, are they applied alone, or are they simply downloaded? Since now I am tired to check which version I am in and I do not know if this error is from now, although it had not happened to me since I manually updated the last stable update. I will hope this stabilizes soon.

System seems functional after restore last snapshot with timeshift - but timeshift shows that errors occurs - error message
“If system not boots, try another snapshot”… mmh, it boots… I wait and look…
but @philm, what is the right way, if the prop. driver are needed and why is such a shit in stable?

1 Like

Hello guys, after system update (Manjaro Gnome Desktop) i have issue with Nvidia Driver and system dont boot, what can i do ?

Previous Nvidia Driver 460.79
Now Nvidia 460.80

The below message is before update and restart my PC

(Warning: installing nvidia-utils (460.80-1) breaks dependency ‘nvidia-utils-460.73.01’ required by linux59-nvidia
Add linux59-nvidia to remove)

Nvidia cards don’t work



The last working Nvidia driver with Display Port support was 460.73.01. Then a new version came out, which backports stuff from 465 series. Current 460.80. Seems like the “fixes” for some Display Port issues created a regression. People with issues on the Nvidia driver may report to Nvidia with some constructive feedback and step by step guides so they can reproduce it.

1 Like

Any risen why not all Kernels updated to that which are compiled with gcc11?

I encountered this error:
[ 78%] Linking CXX shared library ../bin/libKF5GuiAddons.so [ 78%] Built target KF5GuiAddons make: *** [Makefile:136: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... error making: kguiaddons-git

Trying to switch to extra/kguiaddons results in:
looking for conflicting packages... kguiaddons and kguiaddons-git are in conflict. Remove kguiaddons-git? [y/N] y error: failed to prepare transaction (could not satisfy dependencies) removing kguiaddons-git breaks dependency 'kguiaddons-git' required by kconfigwidgets-git

Same story if I try to replace kconfigwidgets-git with extra/kconfigwidgets, which leads to:
removing kconfigwidgets-git breaks dependency 'kconfigwidgets-git' required by kiconthemes-git;

which in turn leads to:
removing kiconthemes-git breaks dependency 'kiconthemes-git' required by ktextwidgets-git :: removing kiconthemes-git breaks dependency 'kiconthemes-git' required by kwallet-git

This results in having no panel, no window borders, no desktop, no icons anywhere. I’m not sure what to try next.

Seems you’re having some KDE-git packages for some reason. We dropped them as we have [kde-unstable] repo. You might want to scan your install and replace them with regular packages @jdcard

1 Like

We don’t have GCC11 in this update.

I’d love to replace them with regular packages but my attempts have been unsuccessful:

yay kguiaddons
3 aur/mingw-w64-kguiaddons 5.76.0-2 (+1 0.00) 
    Addons to QtGui (mingw-w64)
2 aur/kguiaddons-git 5.79.0_r337.g88a0716-2 (+21 0.30) (Installed: 5.79.0.r337.g88a0716-1)
    Addons to QtGui
1 extra/kguiaddons 5.82.0-1 (306.5 KiB 771.3 KiB) [kf5] 
    Addons to QtGui
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
resolving dependencies...
looking for conflicting packages...
:: kguiaddons and kguiaddons-git are in conflict. Remove kguiaddons-git? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kguiaddons-git breaks dependency 'kguiaddons-git' required by kconfigwidgets-git
error installing repo packages

Is there some other way of doing this?