[Stable Update] 2021-05-19 - Kernels, Nvidia, KDE Frameworks, Plasma, Systemd, LibreOffice, KDE Gear Mobile, FF, TB

I am still having the same issues and I’m too much of a new Linux user to really know where to even start troubleshooting.

I have tried:

  • Uninstalling plasma-desktop-primex and replace it with plasma-desktop via the pamac gui.
  • Doing the same via console as suggested by philm
  • And I also tried to just do a sudo pacman -S plasma-desktop before updating as usual as posted by fhonb

All of those end up with the same problem:

  • When I at first try to reboot my computer after the update, I get stuck with a blurred out screen from ksmserver-logout-greeting. I can still switch activities or alt+tab and open up Yakuake with f12.
  • The only way I’ve found to actually reboot is via bash command shutdown -r 0 or similar.
  • After rebooting I get my usual auto-started applications but no task bar, start menu etc. I can’t use alt+space to search for and start applications and I seem to have no desktop as it is completely black and can’t be interacted with in any way.

Any help or suggestions would be very welcome as I have no clue where to even start with this. For now I guess I’ll just rewind with timeshift and hold off on the update a while longer.

My issues were solved by replacing some left-over git packages with their non-git counterparts as posted below. (I thought I had done this previously but apperantly there were a few left that I didn’t know about).

1 Like

Now I have problems with stuff like icons missing, other kde features missing like plugins missing… is there any mega package I can install to get everything back?

qbittorrent: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.29’ not found (required by /usr/lib/libtorrent-rasterbar.so.10)

This is upsetting - now Sonarr is stuckkkkkk…

Edit… did ‘paru libtorrent-rasterbar’ and for some reason had the GIT installed!!! OMG - installed community again and everything is hunky dory.

I’m not sure why that happened…

How can I rewind the updates?

I have snapshots in Timeshift from before I updated that I use. I don’t know of any other way.

Found a solution that worked for me:

1 Like

Backups are a lesson you really only have to learn once, I’ve experienced 5 or 6 no-boot breakages with manjaro updates over the 3 or 4 years I’ve used it. Mainline arch didn’t used to break like that, I just cant be bothered to set everything up manually these days.

Download timeshift and timeshift-autosnap from the aur.

You dont have to setup automatic time schedule backups, but with autosnap, every time your system updates it will take a snapshot of right before, and if it breaks you can timeshift --restore to restore it.


Tried nvidia-dkms to build against the kernel with the same result, no-boot blackscreen.

I don’t know why this was promoted to stable, when 1 of the two main display types is broken on it

1 Like

This finally solved my problems! Thanks a lot!

Unfortunately, before I proceed to download the update I get this message on pamac GUI.

conflicting dependencies:
- virtualbox-guest-utils and virtualbox-guest-utils-nox are in conflict

What should be done in this case?

1 Like

Hello, I had the same issue, just try installing plasma-desktop with :
sudo pacman -S plasma-desktop
And when it asks you to replace it because it is in conflict with primex, choose yes.

Hello, i had the nvidia problem with the black screen on boot. Using dual 1440p monitors with DP. Seems that the new nvidia-‘stable’ update pushed is not very ‘stable’ at the end. Well, i’ll downgrading the nvidia drivers when i have a chance.

1 Like


The update went fine but I still have the amd gpu issue and the solution you give doesn’t work for me, it makes my laptop freeze at the asus boot screen, so I had to chroot to bring eveerything back to “normal”, I did this change in /etc/default/grub btw :

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 amdgpu.dc=0"

I haven’t updated yet, but as an nvidia GTX 1080 user with 2 displayport monitors, all these reports make me a bit nervous. Would it be worth holding off on updating until a working driver is released?

My DP monitors are both 1080p by the way, with an additional 1080p monitor connected by DVI. It does seem like most of the people running into issues with DP are either running high resolution or high refresh rate monitors. Can anyone confirm whether 1080p monitors connected via DP are causing problems?

Update: Since installing your build of PipeWire 0.3.28, I’ve had 5 zoom meetings, slept overnight with my PC idle, watched several YouTube videos, switched between my speakers and my headphones many times, rebooted once for an unrelated reason, and been running PulseEffects the whole time, with it affecting both speaker output (equalizer) and microphone input (RNNoise noise reduction). At no time so far has the audio stopped working, with either recording or playback. I think for me personally, it’s safe to say that PipeWire 0.3.28 is significantly more stable and usable than 0.3.26 and 0.3.27 were. I have not had to manually restart it or PulseEffects once.

That being said, I have not tested Bluetooth audio equipment, since I don’t use any Bluetooth audio equipment currently. For audio output (playback), I use 3.5mm jack output directly from my motherboard for my speakers and headphones, and for audio input (recording), I use a small USB sound card with its own 3.5mm jack into which I plug my microphone. So, my test results in this post are for handling USB and motherboard 3.5mm audio jacks only.

1 Like

yea, you have to choose yes.

Also try the following commands, as it looks like that should fix the issue:
sudo pacman -Rdd plasma-desktop-primex
sudo pacman -Syu plasma-desktop

(28/34) Changing NetworkManager Connectivity-Ping to manjaro.org



Thanks. Rebuilt compiz-easy-patch and it still isn’t starting.