[Stable Update] 2021-05-06 - Kernels, Mesa, VirtualBox, LxQt 0.17, Deepin, Gnome Apps 40.1

First, I did say yes to remove python2-twisted…

looking for conflicting packages...
:: python-twisted and python2-twisted are in conflict.
   Remove python2-twisted? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (460.73.01-1) breaks dependency
   'nvidia-utils=460.56' required by linux59-nvidia
:: removing python2-twisted breaks dependency 'python2-twisted'
   required by python2-incremental

Second, I said no the the question

looking for conflicting packages...
:: python-twisted and python2-twisted are in conflict.
   Remove python2-twisted? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python-twisted and python2-twisted are in conflict

Here’s my hardware info:

System:    Host: sphere-0 Kernel: 5.10.23-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: Lenovo IdeaPad Y480 v: Lenovo IdeaPad Y480 serial: <superuser required> 
           Mobo: LENOVO model: Product Name v: Mainboard version serial: <superuser required> UEFI: LENOVO v: 5DCN34WW(V1.11) 
           date: 03/22/2012 
Battery:   ID-1: BAT1 charge: 3.2 Wh (59.3%) condition: 5.4/5.8 Wh (93.2%) 
CPU:       Info: Quad Core model: Intel Core i7-3610QM bits: 64 type: MT MCP cache: L2: 6 MiB 
           Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1210 3: 1197 4: 1199 5: 1197 6: 1196 7: 1197 
           8: 1199 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GF108M [GeForce GT 620M/630M/635M/640M LE] driver: N/A 
           Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting unloaded: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.3.4 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.10.23-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
Network:   Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx 
           IF: enp2s0 state: down mac: dc:0e:a1:e5:e7:cd 
           Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
           IF: wlp3s0 state: up mac: 44:6d:57:41:59:59 
Bluetooth: Device-1: Qualcomm Atheros AR3011 Bluetooth type: USB driver: btusb 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 931.51 GiB used: 819.72 GiB (88.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-00JC3T0 size: 931.51 GiB 
Partition: ID-1: / size: 57.55 GiB used: 54.88 GiB (95.4%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 499.7 MiB used: 640 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 15.63 GiB used: 853.2 MiB (5.3%) dev: /dev/sda9 
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 250 Uptime: 3d 19h 51m Memory: 7.67 GiB used: 2.92 GiB (38.1%) Shell: Bash inxi: 3.3.03 

Xfce version here with legacy 340xx NVIDIA drivers.
After the latest update I have screen tearing even with compositor off.

Refreshing the keys didn’t work for me, but manually downloading and then the pacman -U command worked fine. After that the regular update went fine :smile:

You did rebuild those after kernel update?

Budgie desktop 10.5.3 soon?

After installing them using this guide it does this automatically with each update.

Uninstalling nvidia drivers (back to Nouveau) solved the problem. Maybe the 340.108 no longer get along with the latest updates like that of Mesa.

1 Like

I see, thanks for letting me know! Will subscribe there to see if I can contribute at some point.

Remove whatever package requires those packages, then run the update again.


After the latest stable update, I’m having this problem with my Activities function in Gnome. It wasn’t happening to me before the update. In the thread they point at dash to dock as the possible cause, so I’ll try disabling it for a while and see if the problem persists.

Gnome, 5.4, Intel

Evolution, terminal, virtualbox, timeshift so far will not open. Brave opens, chrome opens, pamac opens.

Why you didn’t use the 5.10?


The solution you provided for amd gpus (with grub) didn’t work for me, when I boot my machine just displays the asus boot screen and freezes on it, I had to chroot in order to make it bootable again.
Just in case, I did this change in /etc/default/grub :

    GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
    ### became : 
    GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3  amdgpu.dc=0"

Updated everything this morning (Manjaro Gnome), about 80-ish packages.

Everything went fine, asked me to reboot so I did.

On boot:

  1. Dell screen
  2. Password for disk encryption
  3. Another Dell screen
    – everything normal up until here –
  4. All black screen, nothing except for my keyboard lighting up when I click.

Tried alt + ctrl + F1 (and F2), nothing happened.

Did a force shutdown (power button for about 10sec.)

Boot again, and now it works. Might take a Timeshift backup next time because I nearly cr*pped my pants :sweat_smile:

Should I be worried or consider this a one time glitch in the maxtrix and forget about it if it doesn’t occur again?

I’m on 5.10 LTS, have the latest NVIDIA drivers (hybrid laptop) with optimus-manager.

After updating my multiseat-setup was broken, so that lightdm would refuse to start. I could start xfce with startx, but only one seat worked.

Today i solved the problem by disabling 2 config-files which were brought by recent updates to /usr/share/X11/xorg.conf.d These configfiles may break all multiseat-setups using loginctl see arch-multiseat

in short all you have to do is disabling these files:

sudo mv /usr/share/X11/xorg.conf.d/10-amdgpu-nvidia-drm-outputclass.conf /usr/share/X11/xorg.conf.d/10-amdgpu-nvidia-drm-outputclass.conx       
sudo mv /usr/share/X11/xorg.conf.d/10-intel-nvidia-drm-outputclass.conf /usr/share/X11/xorg.conf.d/10-intel-nvidia-drm-outputclass.conx

if you are interested in details see the full info at Multiseat-Setup broken by …

1 Like

The firmware for Ravenridge (Zen 1 + Vega APU (2*00U)) in 20210426.fa0efef is faulty again (also was with the last stable update in April/End of March):
It crashes amdgpu within 2 hours of runtime. The messages in the kernellog switching on every crash, so they’re not helpful. Last time I got

amdgpu 0000:04:00.0: amdgpu: [gfxhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process Xorg pid 942 thread Xorg:cs0 pid 981)

, the crash before was throwing:

drm:amdgpu_gart_unbind [amdgpu]] ERROR Timeout waiting for VM flush ACK!

Tried Kernel 5.10.30 – 34 and 5.4.106 – 116 and some new parameters like amdgpu.noretry=0 but the only solution is to copy back the old firmwarefiles (/usr/lib/firmware/amdgpu/) and recreate initramsfs.

Therefore I’m pretty sure the source of this new instability is the new firmware (see also the releasedates of new firmware in AMD’s repository - great, I not allowed to link it -.-’ ).
According to another user from another forum this also concerns Navi 21 (but not Navi 10).

5.11.14 is better

more info here:

The only problem I’ve found is that suddenly my user gets locked out after multiple failed login attempts (sodding capslock!) which has never been a problem before. (And isn’t required behaviour on my home computer anyway).

The solution seems to be to edit /etc/security/faillock.conf, uncomment “deny = 3” and change it to “deny = 0”.

I tested deepin and Budgie then shared problem detailed system report in external topic for not occupying this topic.


grub seems to have borked something, i switched to linux512 and removed linux58 and linux511 but grub still thinks linux58 is installed.

$ mhwd-kernel -li              
Currently running: 5.12.1-2-MANJARO (linux512)
The following kernels are installed in your system:
* linux510
* linux512
* linux54


Found linux image: /boot/vmlinuz-5.8-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.8-x86_64.img
Found initrd fallback image: /boot/initramfs-5.8-x86_64-fallback.img

No, grub sees the kernel and initramfs in /boot. Delete those manually.