[Stable Update] 2021-04-09 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

Thank you @Yochanan! However, that didn’t help here. Does the problem have nothing to do with this update?

I have some issues with the update.

  1. The WiFi “Select Network” pop-up cannot be closed. The “Cancel” button gives no response. Make me should reboot every time I accidentally open the “Select Network” menu.
  2. pacman.log is not found after a fresh boot. So, I have no pamac activities log. Now, I just run touch /var/log/pacman.log every time after I do a fresh boot.

Any advice to deal with these issues?

As marwell said, that didn’t help, unfortunately. None of the information here allowed me to fix the new Java font issue I’ve seen with this particular update. Thank you for trying!

Sorry winnie, just saw your question tonight.
I think Firefox uses the native KDialog, but to be sure i took a screenshot of Kate and Firefox Developer 88.0b4.

Any word on this one?:

No longer able to connect to smb share on the network through nautilus: Other locations → Connect to server - > smb://ip.ad.res.s. (This occurs on all manjaro’s in the household (5x))

I’m having three seemingly common problems with this update:

  • Conflicts related to packages pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf: I had to remove these packages manually before updating
  • No sound cards after update: I applied saurabh’s solution (see below), it worked in my case. Maybe the solution should be written in the wiki at the beginning of the post, but it has been pointed out that it would be better to examine and manually merge pacnew files
  • Problem with fonts in Java applications: they have been replaced with a monospaced font. Still unresolved, unfortunately.

With the latest release and updated Wiki about improving the font rendering, the font rendering is really awesome now, thanks!!! (i’m using truetype interpreter v40 and this is enough for me, but i’ll play with v38 to see the results)

Darn. It doesn’t. :frowning: Your screenshot confirms what I suspected. Firefox is using GTK file-picker dialog, while Kate is using KDialog.

KDialog makes an application more consistent with a Plasma session, and yields better integration.

Yet for some reason after rebooting (and some small recent updates), Chromium, Brave, and Vivaldi are all correctly using KDialog, while Firefox is the “odd one out” in the group, in that it uses GTK file picker dialog.

It’s not such a big deal to me since Firefox is not my primary web browser, but it’s still strange that it sorely sticks out among the others in a KDE desktop.

The upgrade of python-ruamel-yaml broke borgmatic because its current version needs python-ruamel-yaml < 0.17. This has been fixed in borgmatic 1.5.13-2, which is not yet in the stable repo.

I downgraded python-ruamel-yaml, now borgmatic can run again, until it gets upgraded. Hopefully this won’t break another part of the system.

Hi. It seems from the pull that 20% of us are having issues. I don’t know if reported but I’m facing some type of serious bugs:
1: Random Keys and Touchpad do not work correctly at Random Boots or Moments: not an Hardware Issue, mine not as serious as Random keys do not work on inbuilt laptop keyboard. May a Kernel-related issue.
2: System Freezes randomly: at least on AMD Drivers, no matter Kernel versions, DE or activity (it freezes randomly). May because of AMDVLK update be the cause?

Anyway, have a nice day.


Hi there! I’m experiencing random system freezes as well, and think it has something to do with the new AMD GPU drivers. [Here] is a post I wrote a couple of days ago, where some other users and I have been updating our experiences and not-solvers: System frequently crashing after GPU drivers update - #28 by HoneyBear52


There is a way to firefox to integrate more with KDE


Hi, since I’ve updated the day before yesterday, I am having some serious problem again. My Screen freezes and I am also unable to switch TTY. SysRQ + REI get’s me back to lightdm’s login screen, but mehhh this can’t be a viable solution. Does anybody have some intell for me?
Thanks a lot :slight_smile:

kernel: amdgpu 0000:09:00.0: amdgpu: [gfxhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process Xorg pid 1040 thread Xorg:cs0 pid 1114)
kernel: amdgpu 0000:09:00.0: amdgpu: in page starting at address 0x000080010d00a000 from client 27
kernel: amdgpu 0000:09:00.0: amdgpu: VM_L2_PROTECTION_FAULT_STATUS:0x00101031
kernel: amdgpu 0000:09:00.0: amdgpu: Faulty UTCL2 client ID: TCP (0x8)
kernel: amdgpu 0000:09:00.0: amdgpu: MORE_FAULTS: 0x1
kernel: amdgpu 0000:09:00.0: amdgpu: WALKER_ERROR: 0x0
kernel: amdgpu 0000:09:00.0: amdgpu: PERMISSION_FAULTS: 0x3
kernel: amdgpu 0000:09:00.0: amdgpu: MAPPING_ERROR: 0x0
kernel: amdgpu 0000:09:00.0: amdgpu: RW: 0x0
kernel: gmc_v9_0_process_interrupt: 68560 callbacks suppressed


@XRaTiX that did the trick! I’ll share in here exactly what I did to make Firefox integrate better with KDE, and it was much simpler than I assumed! Thank you so much!

@PetervB try this out:

  1. Make sure the packages xdg-desktop-portal and xdg-desktop-portal-kde are installed. (They should be by default on a Manjaro KDE installationn.)
  2. Open up Firefox, and in the address bar type about:config, then hit Enter
  3. If you see a “warning” just proceed. It’s not as dangerous as the warning portrays.
  4. Search for widget.use-xdg-desktop-portal
  5. For the option widget.use-xdg-desktop-portal, change it from false to true (by double-clicking it)
  6. Close Firefox and re-launch it. Try opening or saving files, images, downloads, etc. Enjoy your KDialog seamlessly integrated with your KDE desktop!



For me, testing branch with kernel511 works fine #Gnome

@_thomas I don’t have a fix for it yet, but I posted a similar issue I and a lot of people have been going through here. Hope you can find it useful, or drop any information you find worth mentioning.

1 Like

I’ve just been over to the Mesa site looking at release notes for Mesa 21.01 & 21.02, and unless I don’t know what to look for (very possible) I can’t find mention of this bug. I wonder if this gets fixed? lot of Linux users use older intel hardware, so you’d think this would get addressed.


Just found the Mesa developers working on this, discussion:


Thanks winnie
:+1: :+1: :+1: