[Stable Update] 2021-03-18 - Kernels, Plasma, Frameworks, LibreOffice, Firefox, Systemd

Try to delete the contents of the folder pstore. [/sys/fs/pstore/dmesg-erst]
Then reboot.

Source: https://forum.mxlinux.org/viewtopic.php?t=47491
The second last entry.

http://intelligentsystemsmonitoring.com/knowledgebase/novell/7023245-during-boot-pstore-and-decompression-failed-messages-are-logged/

So far everything fine on my Ideapad 5 14ARE05 (AMD 4600U) with Plasma 5.21.
Since this stable update, I can also safely use kernel 5.11 - previously (5.11.2), resume from sleep would hang the laptop, but it seems fixed now!

1 Like

same here with electron9. I stopped the update and removed electron. Here Bitwarden was relying on electron and also got removed. Reloaded Bitwarden from the offical site as appimage. That works fine too …

1 Like

I had similar problems with the previous update.
The problem turned out to be that PulseEffects is now dependent on pipewire-pulse, which caused that to be installed and the original pulseaudio to be removed.
I removed PulseEffects, then replaced pipewire-pulse with pulseaudio and everything is now working as before.
Obviously not a solution if you actually need PulseEffects, but otherwise I’d recommend it.

Please read this:

:scream:

2 Likes

The dev replied saying “They should restard plasma or use kdeinit5 in a terminal” but kdeinit and plasmashell both give the libKF5KIOCore.so.5 undefined symbol error.

Fixed was an issue of some dependencys being versions built from git rather from the main repositories!

Try this. (being edited into solution wiki above right now)

:+1:

1 Like

The problem is in “known issues and solutions” of the post:

Execute:

pamac install manjaro-pipewire
pamac install gst-plugin-pipewire

OR

pamac install pulseeffects-legacy

pulseeffects-legacy does not depend on Pipewire and does not require removal of PulseAudio packages

You can either switch to pipewire-pulse installing manjaro-pipe or use pulseeffcts-legacy. There is also manjaro-pulse metapackage to switch back to pulseaudio.

I guess you’ve missed that:

1 Like

Definitely NOT sufficient:

https://forum.manjaro.org/search?q=pipewire

Hi everyone,
I update in kernel 5.11, and I have a bug:

"Failed to commit transaction:
conflicting files:
- python-typing_extensions: /usr/lib/python3.9/site-packages/pycache/typing_extensions.cpython-39.pyc already exists in filesystem,

  • if this file is not needed, remove it and retry*
    - python-typing_extensions: /usr/lib/python3.9/site-packages/typing_extensions.py already exists in filesystem,
  • if this file is not needed, remove it and retry*"
    Please help me fix this error!
    Thanks guys so much… <3

Hmm, I have the most curious bug after this update. I don’t see the GRUB menu (just pure black nothingness), but if I click enter or wait 10 seconds Manjaro still boots. For whatever reason GRUB runs, it just doesn’t show up in the screen.

  1. Kernel 5.11 is an experimental kernel: upgrade to 5.4 LTS or 1.10 LTS (Long Time Support) and try that first.

  2. If that doesn’t help, remove the file and try again.

    sudo rm /usr/lib/python3.9/site-packages/typing_extensions.py
    

:man_shrugging:

2 Likes

:slightly_smiling_face: All good now thanks Phil

I just tried and it works good here.
Did you try to reset configuration of pulseeffects? It has a button for that.

Contrary to:

after the update grub-install -V gives “grub-install (GRUB) 2.04~22~manjaro”

Is the 2.06-rc1 a leftover copy-paste from testing?

1 Like

Thank you for caring.
Even if I already uninstalled & deleted config files, I tried this reset right now.
Pulseeffects is still almost ko (filters do about nothing, equalizer is ko)

…and Pulseeffect when running uses 13% of CPU (prior to update, was around 2%)

Bitwarden now uses Electron 11 (electron) so electron9 was dropped from the repos as nothing else requires it. If you need Electron 9 for anything else, install electron9-bin from the AUR. Building electron9 will take hours to build even on a fast computer.

See man pacman | less -p "--overwrite":

sudo pacman -Syu --overwrite \* python-typing_extensions
3 Likes

Update went fine on my Manjaro GNOME using pamac-cli. Thanks for the amazing distro!