[Stable Update] 2021-03-18 - Kernels, Plasma, Frameworks, LibreOffice, Firefox, Systemd

It works. thank you so much

1 Like


after restarting the PC the desktop doesn´t show up. Via F2+alt I can search and start programs, and I do see manjaros mouse and welcoming screen, but there is neither a wallpaper, symbols or a task bar.

Would be happy to get some clues.

1 Like

I couldn’t replicate the issue - Nonetheless I took the extra time to verify all code related to http requests and refactored all to use the Python requests lib - before it was a mix.

v4.20.0-2 has been pushed to unstable.

@linux-aarhus @philm Installed v4.20.0-2 from unstable. works fine for me. Big Thx!

btw: Version still prints:
sudo pacman-mirrors -v
Version 4.19.5

See Known issues and solutions post at the top here:

wget https://archive.archlinux.org/packages/k/kio/kio-5.79.0-1-x86_64.pkg.tar.zst
sudo pacman -U kio-5.79.0-1-x86_64.pkg.tar.zst
sudo echo "IgnorePkg = kio" >> /etc/pacman.conf

Update made my bluetooth headphones choppy. I posted information here:


Update on 12 Systems without Problems.




4 posts were merged into an existing topic: At this stage, Pipewire is a pure disaster. (needed rant !)

Thanks. You saved my biscuits today. All works after following your solution.

1 Like

Sorry,no. See https://www.kernel.org/.


Looks like the popping and slowdown of audio is being reported in the pulseeffects github project. So mahbe best thing we can do is share our experience and help test.

1 Like

Also install pacnew-chaser to recall any updates in conf files and meld them.


Hi! Using “plasmashell 5.21.3” I updated my system, and now my lower panel seems to have frozen. I cannot click on anything. The time too is frozen. This only happened due to the update. How do I fix this? Thank you!

Edit: I must mention that everything else works fine. I can use my terminal and launch apps, update, install packages and everything is normal, it is just that the panel is frozen.

1 Like

This looks like a config issue - Plasma can be temperemental if messed with.

  1. Try a new (test) user - if not clear then update us.
  2. If clear with a test user, start looking at hidden files/folders;

Stuff like .config .local/share/plasma…
Maybe just delete that panel and make a new one.


Thank you so much for you reply Ben, I changed my kernel to 5.4 LTS and now everything seems to work just fine. Thanks again.

Old fart here. Linux kernels used to be on a stable - experimental, cycle so I I still call anything that is not “LTS”’, “experimental”, and you’re correct that the real new denomination is “stable” although the real new usage is still the same as the old usage and that’s “experimental”.

PM me so we can take this off-line.


1 Like

So, this solution worked for me…for the most part. The kdeinit5 failed. Wouldn’t run at all. I had to use the nmcli command to first connect to wifi before I could issue the suggested commands, which isn’t the easiest thing to do if you’re new. Also, the IgnorePkg line failed and I could not get it to work. Invalid permissions I believe was the error. That said, I was able to boot to my desktop and manually choose to not upgrade kio. So I guess my question is, do I just have to manually monitor to see when a new version is available and hope it works? Thanks

This solution worked for me:

pacman -S kcoreaddons kdbusaddons kwindowsystem kcodecs kconfig kirigami2 kquickimageeditor knotifications ki18n

as suggested here:
(KDE could not find theme after update)

It would appear that NeoChat was the culprit in my case as well. Even though I’d removed it, it’s git pulls had remained and caused problems.

Since Systemd 247.4 when using systemd-networkd with wg-quick@.service I have no wireguard connection after resume from suspend. 248rc4 version has the same problem. Had to downgrade to 247.3.

I have applied this update together with the previous two ones (I postponed for too long).

I had to remove packages like pulseaudio-equalizer, pulseaudio-jack and so on because they blocked the update.

Now Plasma says there is no audio device except PulseEffects Sink and PulseEffect Source.

So now I can’t get any audio output from my monitor, which is connected via DisplayPort.

I have already tried the PulseEffects solutions proposed in the know issues section. What can I try to have my audio back?