[Stable Update] 2021-03-08- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

Yes. That did work suprisingly. Tried after posting. Though sudo update-grub was needed to get the other entries back. Thanks.


From a “simple user” standpoint disabling such a feature (no matter for what reason) without informing the user before upgrading is an absolute nogo imho!

Erm…it was in the update announcement. If you didn’t read it, that’s on you. I learnt the hard way to read before I update.

3 Likes

So I have to go manually to this forum to get informations?
I think such important changes (breaking/changing/removing stuff) should somehow get to the user in a different way. More user friendly. At least something like a changelog shown befor installation within the gui update manager. Just my opinion.

Look at this also. I use it as well, and it works well: [APP] - mntray - Manjaro announcements tray app

3 Likes

A Linux-system is not a simple point-and-click adventure. If you really want to use your current Linux-installation and stay updated, then you HAVE TO read each and every announcement in this forum. I also strongly recommend to read each and every post to them even if it doesn’t seem to concern you at first. In case you run into a problem you at least know that you have read about it already and you know that you can search for it.

There is a steep learning curve and the majority of users keep learning about new stuff even years after their first installation.

I bet a million Bitcoins that if you don’t do that you will make your system non-bootable and non-repairable (at least not with “minimal effort”) at one point. There are some helper-tools here and there, so feel free to use them. BTW, timeshift is highly recommended.

I don’t want to push you away from Linux or anything, but there are some things that you surely have to adapt to. So this is more of a warning. :slight_smile:

6 Likes

I understand. I don’t like the thought but maybe Manjaro is not the right OS for me then. But I really do not want to open a great discussion here as it is ot, too. Thanks for your replies. Oh and I have setup timeshift and home backup already. But that does not imply here as I think it’s no solution to revert back with timeshift after updates that “break” stuff and then to circumvate them ^^

Be sure and read the link I sent, that might help. They discuss specifically how to update wine when using the VST

Not having manjaro-pipewire installed caused a dependency sinkhole with pulseaudio to open up and try to swallow me. Thanks for the “new issues” post immediately below the main thread. A simple install simplified everything.

After fixing the GRUB issue, I’m still facing quite severe performance issues.
Browsing in Firefox/Chrome and also opening e.g. LibreOffice uses like 10x more CPU than before. Can’t really relate it to a single common cause. Maybe graphic drivers (I’m on a nvidia / amd hybrid).
Browsing has become quite a bit sluggerish because of this.

Edit: Nvidia/AMD hybrid (newest 460) driver must be the culprit, since the system is perfectly fluent with AMD only. Tested on kernels 5.10 and 5.11.
What now? Quite a bit annoying when doing everyday’s tasks :frowning:

Just red it…

It is the same exact procedure I follow each time there is a wine update. I have only installed wine from the repositories (not wine-mono or wine-gecko) and let wine update itself by downloading wine-mono and installing it.
Unfortunately this time it didn’t help. The problem remains.
I’m convinced there is some libary missing… (removed during this or the previous update) I had never any problems with wine version 6.1 and older ones…

Thanks for your help anyways!

I’m sorry
just my English is at zero and every message I translate by google
as a result I found this message after I wrote my own

Had to uninstall pulseaudio and some of it’s dependencies, also manjaro-pulse. And manually installed pipewire, later I saw there is also a meta package manjaro-pipewire and installed it.

De nada

No, not the whole forum.

Just the update announcements. They are extremely important. So it will do you well to stay abreast of what’s happening.

1 Like

The update failed whith missing signatures:

Fehler: chromium: signature from “Mark Wagie mark@manjaro.org” is unknown trust
Fehler: libupnp: signature from “David Runge dvzrv@archlinux.org” is unknown trust
Fehler: youtube-dl: signature from “Daniel M. Capella polyzen@archlinux.org” is unknown trust

I then performed this and it fixed the issue:

sudo pacman-mirrors 
sudo pacman -Syy 
sudo pacman -S archlinux-keyring manjaro-keyring 
sudo pacman-key --init 
sudo pacman-key --populate archlinux manjaro 
sudo pacman-key --refresh-keys
sudo pacman -Syu

Your thought has been accepted with the latest grub update 2.04-21

1 Like

In any Linux distribution something may break after update, upgrade. There are so many users’ configurations that developers are unable to test every case. There is no distribution where there are no problems at all. And most problems come from upstream. After all, distribution creators are people who only put together components made by someone else. In Manjaro at least you have this forum announcement, which is one of the best features of Manjaro as a distribution. I am not sure if any other distribution has such announcement.

And backup is one of the most important things you need do with your system regardless if it is Linux or other system.

2 Likes

Please help, after upgrading, my laptop boots directly to Manjaro KDE, the grub doesn’t appear at boot, and when running sudo update-grub it doesn’t detect my Windows 10.

Please have a look at this post a view days ago:

https://forum.manjaro.org/t/stable-update-2021-03-08-kernels-plasma-5-21-2-haskell-kodi-grub-kde-dev/56877/19?

1 Like

Thanks, that worked perfectly :slight_smile: