[Stable Update] 2021-02-28 - Kernels, Plasma 5.21.1, Frameworks 5.79, Firefox, Thunderbird, Python

Reminder for anyone that runs kwin-lowlatency to switch to normal kwin from the official repo before upgrading otherwise your gonna get a freeze when you try to login. Had the same issue and it was resolved by installing normal kwin before restarting for the update.

Small screen artifacts when selecting text or clicking buttons (ie. pin button of krunner).
This has not happened before.

I’m currently running 5.11 kernel but I’m unable to remove the 5.10 kernel.
I’m getting this error:

:: removing linux510 breaks dependency 'linux510' required by linux-latest
:: removing linux510-headers breaks dependency 'linux510-headers' required by linux-latest-headers

Shouldn’t linux-latest point to linux511 instead of linux510?

2 Likes

same here.

Same here too

that’s what i thought after looking around a bit and seeing both optimus-manager-qt and optimus-manager got updated on their respective Github page.
do you mind looking at my thread and explain to me why in Pamac, optimus-manager seems to be installed both from Aur and official repos?

Hi, as said on my OP, all dependencies were insalled :slight_smile:

[2021-02-28T16:30:04+0100] [ALPM] installed linux511 (5.11.1-1)
[2021-02-28T16:47:28+0100] [ALPM] installed pipewire-jack (1:0.3.22-1)
[2021-02-28T16:47:28+0100] [ALPM] installed gst-plugin-pipewire (1:0.3.22-1)
[2021-02-28T16:47:28+0100] [ALPM] installed wireplumber (0.3.0-1)
[2021-02-28T16:47:28+0100] [ALPM] installed pipewire-alsa (1:0.3.22-1)
[2021-02-28T16:47:28+0100] [ALPM] installed pipewire-pulse (1:0.3.22-1)
[2021-02-28T16:47:28+0100] [ALPM] installed manjaro-pipewire (20210109-1)
[2021-02-28T16:47:28+0100] [ALPM] installed libpipewire02 (0.2.7-1)
[2021-02-28T16:47:29+0100] [ALPM] installed pipewire-docs (1:0.3.22-1)
[2021-02-28T16:47:29+0100] [ALPM] installed gst-plugin-gtk (1.18.3-1)
[2021-02-28T16:47:29+0100] [ALPM] installed libebur128 (1.2.6-1)
[2021-02-28T16:47:29+0100] [ALPM] installed pulseeffects (5.0.0-1)

Then I had to revert and reinstall legacy :confused:

[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio (14.2-2)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio-modules-bt (1.4-6)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio-jack (14.2-2)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio-zeroconf (14.2-2)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio-rtp (14.2-2)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio-lirc (14.2-2)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseaudio-equalizer (14.2-2)
[2021-02-28T17:17:02+0100] [ALPM] installed gst-plugin-gtk (1.18.3-1)
[2021-02-28T17:17:02+0100] [ALPM] installed libebur128 (1.2.6-1)
[2021-02-28T17:17:02+0100] [ALPM] installed pulseeffects-legacy (4.8.4-3)

At this stage, pipewire-effects is bugged. Can’t use it.

Hi,

Is the mesa-git from AUR updating regularly for you? I installed this a while ago but I noticed it wasn’t updating as much as it should be and saw the mesa-git from the official repo are also installed, which I didn’t install.

Update without problem on a machine with KDE.

Thanks Manjaro-team.

  1. KDE not started with kwin-lowlatency. Only works if you uninstall it and just install kwin.

  2. As always, the brightness control does not work on the OLED screen, but on the 5.9.16 kernel everything worked as it should. Why is OLED no longer supported after the release of this kernel?

SERIOUS PROBLEM: Kernel 5.11 crashes in my computer, it produces a black screen when it boots. For kernel 5.10 I use amdgpu.dc=0 to solve this problem, but this does NOT solve the problem for kernel 5.11, I need help, please!

Yes and no. It’s a “git” package. It doesn’t need to change itself for me to get the latest version (sometimes it does update, when there is need or something changes in the compile process for this package or something, but it’s not always necessary). I just need to reinstall it and it pulls newer git content and compiles it. Contrary to “community” repo pre-compiled mesa-git (which isn’t git at all), which does not do that, and is already stagnant.

Anybody else lost Super shortcut for activating Application Launcher on 5.21? How to restore the shortcut?

Al good on 3 computers using KDE.

While my shortcut is perfectly fine, I believe you’ll find where to se it by Right clicking on the launcher button, choosing the “Configure…” option and selecting the Keyboard shortcuts option on the left side of the popup and then configuring it there.

Or that’s how I did it, at least.

(Oh, and if it makes any difference, I use Excalibur menu, although I’ve checked and it’s the same for the new Application menu.)

1 Like

this is why i always read the change logs and then ill use timeshift before i do the updates just incase something goes wrong and then ill use Konsole to keep an eye on whats downloading and whats being removed. other software depends on certain software! you must absolutely check for no dependencies when deleting certain things :slight_smile:

hey buddy it happened to me also i fixed it by setting it to " ctrl + super and then ii hit the super button (windows key) and it worked fine

Very cool KDE update, clean and snappy! Responsive and faster on my old ass laptop with HDD, too!
Edit: Big noob question, how do you choose wayland to run? Should I use that now?

5.4, vanilla gnome

Mirror list wouldn’t update, some keys were out of date for kernel 4.19 (I keep two LTS kernels). Resolved by running update command over and over until it went through. (Maybe 4 times). I’m guessing it took care of various problems each time.

Not unless it’s marked by the Manjaro devs.

$pacman -Si linux-latest

Repository      : community
Name            : linux-latest
Version         : 5.10-1
Description     : The latest kernel and modules (metapackage)
Architecture    : any
URL             : https://www.manjaro.org/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : linux510
Optional Deps   : None
Conflicts With  : linux318  linux420  linux50  linux51  linux52  linux53  linux55  linux56  linux57  linux58
Replaces        : linux318  linux420  linux50  linux51  linux52  linux53  linux55  linux56  linux57  linux58
Download Size   : 16,32 KiB
Installed Size  : 0,00 KiB
Packager        : Philip Mueller <philm@manjaro.org>
Build Date      : Thu 31 Dec 2020 20:24:00 EET
Validated By    : MD5 Sum  SHA-256 Sum  Signature