[Stable Update] 2021-02-19 - Kernels, AMDVLK, Palemoon, Firefox-dev, Firefox, Haskell, Python

I would just like to say @lectrode and @sawdoctor I love you both equally, as if you were my children. Installing the megasync-bin package and the nautilus-megasync with the glib2-2.66.7-1 package, this setup now is working perfectly.


Smooth update on Manjaro KDE (AMD Ryzen 7 with Renoir iGPU).

Thanks Manjaro team for your great work!


xbacklight is broken for me.

fixed by installing light-git package.

Of course Manjaro has its own kernels and mkinitcpio package. But that also means you have pre-5.9 LTS kernels, while Arch’s LTS is now on ver 5.10.

So the question is whether Manjaro users intending to stay on those older LTS kernels (I’m on 5.4) have to carry out manual intervention?

Or are you saying that I don’t have to manually edit Manjaro’s mkinitcpio.conf file to choose a different compression format and then run:
sudo mkinitcpio -p linux54

because Manjaro will sort out the default compression format automatically for the pre-5.9 user?

On Arch and Arch-based (eg my Anarchy Linux install), the LTS kernel is already at version 5.10, so I didn’t have to bother.

But I’ve been wondering about Manjaro.

Thanks to the team for this update!

I like what Mozilla does but I am quite disappointed by the update of Firefox to its 85.0.2 version. Indeed when I open a new tab, I can now see sponsored sites (©ebay™, but I have read that others have an “advertisement” for ©Amazon™).

In order to disable this new deplorable functionality, according to this post from Cohan Robinson, one should:

  • write about:config in the url bar and

  • accept the risk and go further

  • search for browser.newtabpage.activity-stream.showSponsored

  • set to false the following to false by clicking to an icon on the right hand


I have done and it seems to work on my machine: no sponsored tabs any more!
I hope that it can help others and that Mozilla will stop this very soon!

1 Like

Everything fine on my different operating systems …Thank you very much to the team!

Thank you @Killi.

Strangely I don’t have those sponsored tabs, and Mozilla tells in the FAQ a different way to remove them (I’m guessing that the results are the same):

Just in case someone would like to try a different approach to remove them.



Thanks @Rick! In my “Preferences” menu, this line is darkened in my configuration so I cannot select/unselect it by clicking. Note that removing it by about:config etc. as I described in my post above, results in the unselection of " Sponsored Top Sites", so it does also the job.
Thanks nevertheless for your input!

I did it the lazy way. I installed downgrade package from the repos which is meant for downgrading packages but it also let me upgrade as well

I’m using pamac and I don’t know how to do what you said, but I updated the glib package thought another method:

sudo pacman -U http://ftp.riken.jp/Linux/manjaro/unstable/core/x86_64/glib2-2.66.7-1-x86_64.pkg.tar.zst

where the url is some mirror to the unstable package.

I hope this won’t break anything and the package gets updated automatically on futures manjaro updates…

Edit: the update to glib2-2.66.7-1 worked too :slight_smile: Thanks!

1 Like

You can install the downgrade package through pamac, its in the official repos. You can then run in through cli to downgrade (and upgrade) any package that’s in the repos. Glad you managed to get it fixed :+1::+1:

Yes. Nothing has changed on our end, so there’s nothing to do.

1 Like

Weird, I have those set as “true” but I never see anything. Maybe my other configs/extensions are sabotaging it? Ublock Origin, Privacy Badger and Decentraleyes btw.

Same here. And I think it’s Privacy Badger because that’s the only extension you mentioned that we have in common…

Thanks for your answers @Cheker and @Mirdarthos ! It seems not to be linked with these extensions since I have too Ublock Origin, Privacy Badger, Decentraleyes. In addition, I have Httpseverywhere.

I am not alone to have this problem with Firefox. On this social media, you can read e.g. this post, that other one, and this message, and that one, and this polite reaction.
Finally, the solution is maybe given by a certain Paul:

In order to disable this, I have to Enable Top Sites, and then disable Sponsored Top Sites, and then I can re-disable Top Sites.
Ridiculous, it’s either a bug, or a deliberate dark pattern.

I have indeed this Top Sites functionality disabled too and that is maybe the common denominator for all the people having this issue.

Thank you! :+1:
Can you make that into a #contributions:tutorials ?

Please read the pinned “Tutorial Content Creation Guide” first! :+1:

cc @Rick

1 Like

After update nautilus sometimes freezes, consumes 100% CPU. The only way is to kill it.

Anybody has the same issue?

Do you have megasync or Dropbox nautilus plugins installed?

1 Like

Thanks @Fabby! Here you can find my tutorial. I hope that it can help!

1 Like

yap, have nautilus-dropbox 2020.03.04-4