[Stable Update] 2021-02-09 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice

MS Surface Book usiung Linux-surface 5.10** kernel and nvidia-dkms460.** drivers. Since the update I’ve lost desktop effects and 3D games no longer run. I’ve tried reinstalling the dkms drivers and Linux-surface kernel but no change. Everything else seems to be working well. Didn’t have a timeshift backup prior to the update. Lesson learnt.

update: Rebooting into regular 5.10 kernel with video-linux drivers and Nvidia card disabled and still no desktop effects. Steam now loads however.

update2: So it seems steam games and Linux native games are working fine using the Nvidia card however Desktop effects still not working and games under Wine (eg lutris games) not working.

update 3: Fixed desktop effects by switching Compositor to OpenGL3.1. Only game I’m now having issues with is World of Warcraft. Everything else is working fine now. Happy days.

almost everything went well. Using XFCE/5.10.13-2 on Notebook sporadically screen is staying dark after waking up from hibernation. Only thing to do then is to reboot… :confused:

updated 5 machines (manjaro KDE), all ok with a minor problem on Telegram Desktop. My preferences on Telegram are reset and i had to setup it again, but that’s a telegram issue.

1 Like

And mine didn’t. So it’s also random?

after this update, I still can’t open external links on the browser in GTK applications, as described follow:

Also, please, update Palemoon to version 29.0.1 on stable branch, the update is available from Feb 6th

Well, I ultimately switched back to pulseaudio as the new pulseeffects is approximately mimicking Daffy Duck.

Being a little puzzled to see pipewire in my install and a non working pulseeffects in community I opened a thread :

1 Like

Hi! When upgrading Manjaro Gnome lost the local configuration and did not open the terminal. Solved both problems by adding local in manjaro configuration manager.
Thanks for Manjaro.

1 Like

I have 2 issues after today’s update:

1.) I cannot open no more my documents which were in this laptop before this update. When I try to open a document with updated LibreOffice 7.1; it’s saying I that ‘’ Action to document xyz … was launched with wrong parameter.’’

2.) Update changed the language settings in Nautilus to English. Cannot change back from Manjaro Hello/Gnome Layout Manager, because there stays the old (=correct) language setting in force.

What to do now ? Must I re-install to Manjaro again ?

Known issue:

@maycne.sonahoz @philm Thank you ! Now language settings are now OK and LibreOffice 7.1 works OK and I can open my ‘old’ documents. :slightly_smiling_face:

Before this language problem with laptop I updated Manjaro on 2 other machines (one desktop, one mini) smoothly without any problems. So, I’ll mark the 1st option.

Update went okay.
I only can’t seem to figure out why the laptop boots with the normal kernel instead of the preferred LTS after every kernel update… :thinking:

It boots with the highest numbered kernel. You need to boot once with your preferred kernel and if your grub options are set to “save” it will take that one next time. If the above doesn’t make sense, open a new topic in the #support:installation channel, link to this answer and leave a message in your new topic @Fabby

Update went fine here. Manjaro KDE with Kernel 5.9 on AMD Ryzen 7 with iGPU. So far so good. I’ll give a try to other kernel versions later.

Thanks Manjaro team for the great work!

I’m getting the following errors…

    error: filesystem: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is invalid
    :: File /var/cache/pacman/pkg/filesystem-2021.01.19-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] 
    error: gcc-libs: signature from "Allan McRae <me@allanmcrae.com>" is invalid
    :: File /var/cache/pacman/pkg/gcc-libs-10.2.0-6-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] 
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.

Plasma seems to be broken for me after this update. My application drawer doesn’t work at all, any control actions like Alt+Space or changing sound level from keyboard don’t work and then they randomly happen after a minute or so.
Also, at every reboot, I have to relog to chrome?

Kernel 5.10 and 5.4, nvidia drivers 460

errors I get:

kernel: nvidia-gpu 0000:06:00.3: i2c timeout error e0000000
kernel: ucsi_ccg 0-0008: i2c_transfer failed -110
kernel: ucsi_ccg 0-0008: ucsi_ccg_init failed - -110
systemd-coredump[1788]: Process 1334 (baloo_file) of user 1000 dumped core.

Since the new update Dolphin doesn’t save the previous opened folders after an update and I can’t open any .exe with wine. Steam proton works fine, though

I also had a geoclue issue that I noticed because Redshift gave me an error. Since I didn’t want to set fixed coordinates, I read around a bit. I don’t understand what exactly it is or why it worked before, but the problem was that /usr/lib/geoclue-2.0/demos/agent wasn’t started, apparently.

Since I use i3, I fixed it by adding this to my ~/.config/i3/config:

exec --no-startup-id /usr/lib/geoclue-2.0/demos/agent
1 Like

That needs some more probing so open a new issue in the #support:graphic-cards category and provide more information there and link to this post and mention @Fabby

1 Like

Hi, I’ve got a problem since the update. My touchpad just stopped working.

My current setup:

  • Thinkpad P14 (identical to the T14) with a Ryzen CPU.
  • KDE
  • Kernel: 5.9.16-1

Does anybody encounter a similar issue?

Using version 5.10 of the Kernel solved the issue.

That is due to the latest update of papirus icon theme