[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Can confirm is happen to me as well,it has been reported,i think the new patch is coming January 9th.

Remove pipewire-pulse.

pipewire-alsa, pipewire-pulse, and pipewire-jack are normally not needed unless one wants to use PipeWire as a PulseAudio/JACK replacement.


1 Like

hi @philm I found a small bug in one of the recommended commands:

right after --install has to be either pci or usb, in this case it should be pci. the command was giving an error but in the usage it stated (pci|usb) so I figured it out.

Thanks for you help, was able to fix my system.

the solutions are two:
1- use kernel 5.4 with free drivers
2- Thanks to the explanation that I quote below (using the option to do it by terminal, because using the AUR option in pamac it throws an error and does not finish installing it) I could install the proprietary driver 340 in kernel 5.4 and 5.10 and for now no longer I suffer from slowdowns or frozen.

1 Like

I used Pamac to remove the nvidia drivers. Left mhwd alone. Installed 5.10. Rebooted, went into TTY to sudo mhwd -a pci nonfree 0300.


Update went smooth, but after reboot the graphics are messed up (i3 community edition). After switching resolution to lower and then back to high resolution using xrandr/arandr it works again. My system’s graphics are:

Graphics:  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: Chicony HP HD Camera type: USB driver: uvcvideo bus ID: 1-6:3 
           Display: x11 server: X.Org 1.20.10 driver: intel unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.1 direct render: Yes

But next reboot messes up again. Any idea, how this could be fixed without switching resolution?

Hallo @matt-hires,

I use gnome desktop and so I took the risk and it worked.

Thank you.


any reason why with this update the grub conflicts with grub-customizer ??

See here:

Well, it went pretty well, given my config it’s pretty normal (5.4 LTS kernel , Xfce, Intel processor and Intel graphic chipset). I still had to hack a little to get Ninja-IDE to work (AUR (en) - Accounts & Python 3.9 break ninja-ide · Issue #2112 · ninja-ide/ninja-ide · GitHub) and reinstall all my Python user modules. Only pyarrow (essential for the covidify module) is a problem for me (pyarrow wheel for python 3.9 · Issue #9081 · apache/arrow · GitHub). I have to wait for a wheel to be available for Python 3.9.

Hi, I saw the notification from the homepage, I seem to be affected. can I ask If I’ll have an issue after updating, I’m kinda Noob, still just learning. What must I do before updating?

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_MONETARY = "en_US.UTF-8",
        LC_MEASUREMENT = "en_SG.UTF-8",
        LC_TIME = "en_US.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
System:    Host: Lair Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 5558 v: N/A serial: <superuser/root required> 
           Mobo: Dell model: 0TYKPW v: A00 serial: <superuser/root required> UEFI: Dell v: A17 date: 05/14/2019 
CPU:       Info: Dual Core Intel Core i5-5200U [MT MCP] speed: 1685 MHz min/max: 500/2700 MHz 
Graphics:  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel 
           Device-2: NVIDIA GK208BM [GeForce 920M] driver: N/A 
           Device-3: Suyin Integrated_Webcam_HD type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.2.3 
Network:   Device-1: Intel Wireless 3160 driver: iwlwifi 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
Drives:    Local Storage: total: 1.20 TiB used: 688.13 GiB (56.0%) 
Info:      Processes: 191 Uptime: 1h 16m Memory: 7.69 GiB used: 3.09 GiB (40.1%) Shell: Bash inxi: 3.1.08

It worked (i had no doubt); i installed the rebuild-checker, and performed the system update with the italian mirrors, that are, for some for me unknwon reasons, a lot faster than the -f 3 argument (2-3 mbits against 200-300 kbits); thanks a lot Wollie.

This particular update gave me issues with audio popping/clicking noise when any program started or stopped using my sound card (Intel 7 Series/C216 Family High Definition Audio)… quite annoying with headphones. The “solution” I found was to disable power saving for the snd_hda_intel module, but I’m not too happy about having to do that. It was working fine for almost 2 years, and I haven’t modified my audio settings in those 2 years, so I’m not sure what’s going on.

package grub-customizer is not compatible with this update:

:: grub and grub-customizer are in conflict. Remove grub-customizer? [y/N]

@LS650V, have a look into this thread, it explains, why.

Hi. I gave a second chance to manjaro. After clean installing OS I’m still struggling with the same problem. On first boot after installing whole OS i see in mhwd GUI that there is a 455 version of drivers are available to install. I am such a user that before using system I let the system update itself. That’s what I did, and unfortunately for me in mhwd GUI I lost all NVIDIA driver versions except 390 available to install. I have a GTX 650 Ti Super GPU and according to the NVIDIA website, for the latest released driver (455) my card is supported.

How to fix that to install latest NVIDIA driver 455 via mhwd?

inxi -Fazy
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=c79209d9-8416-47b1-a8a9-472b737df337 rw quiet apparmor=1 
  security=apparmor resume=UUID=d358d149-6ed5-41f5-b20d-7683346173ac 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: MSI model: Z270 PC MATE (MS-7A72) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.A0 date: 07/04/2018 
  Info: Dual Core model: Intel Pentium G4560 bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE 
  L2 cache: 3 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28009 
  Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GK106 [GeForce GTX 650 Ti] vendor: Micro-Star MSI 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:11c6 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2880x900 s-dpi: 96 s-size: 762x238mm (30.0x9.4") 
  s-diag: 798mm (31.4") 
  Monitor-1: DVI-I-1 res: 1440x900 hz: 60 dpi: 89 size: 410x257mm (16.1x10.1") 
  diag: 484mm (19.1") 
  Monitor-2: DVI-D-1 res: 1440x900 hz: 60 dpi: 90 size: 408x255mm (16.1x10.0") 
  diag: 481mm (18.9") 
  OpenGL: renderer: NVE6 v: 4.3 Mesa 20.3.1 direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GK106 HDMI Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0b 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
  v: kernel port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 698.65 GiB used: 9.85 GiB (1.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung 
  model: SSD 970 EVO Plus 250GB size: 232.89 GiB block size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXM7 
  temp: 33.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: KC44 
  ID-1: / raw size: 223.79 GiB size: 219.28 GiB (97.98%) used: 9.85 GiB (4.5%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 27.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1080 
  Processes: 189 Uptime: 45m wakeups: 0 Memory: 7.73 GiB 
  used: 2.15 GiB (27.8%) Init: systemd v: 247 Compilers: gcc: N/A Packages: 
  pacman: 1273 lib: 381 flatpak: 0 Shell: Bash v: 5.1.0 running in: konsole 
  inxi: 3.2.01
find /var/lib/mhwd -type f -name "*.old"
mhwd -la
> All PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
  video-virtualmachine            2020.03.26                true            PCI
          video-sisusb            2020.01.18                true            PCI
           video-linux            2018.05.04                true            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
              video-s3            2020.01.18                true            PCI
            video-vesa            2017.03.12                true            PCI
          video-voodoo            2017.03.12                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
     video-modesetting            2020.01.13                true            PCI
      video-openchrome            2020.01.18                true            PCI
       video-rendition            2020.01.18                true            PCI
     network-rt3562sta            2013.12.07                true            PCI
       network-slmodem            2013.12.07                true            PCI
         network-r8168            2016.04.20                true            PCI
   network-broadcom-wl            2018.10.07                true            PCI

Warning: No USB configs found!

dont care about fisrt post , so you dont read

sudo mhwd -a pci nonfree 0300

I updated my system then rebooted and got the following message on screen:-

Warning: /lib/modules/5.10.2-2-MANJARO/modules.devname not found - ignoring
mount: /new_root: unknown filesystem type ‘ext4’.
You are now being dropped into an emergency shell.
sh: can’t access tty; job control turned off
[rootfs ]#

My keyboard and mouse don’t work when this message is displayed.

Please help

Do you still have another kernel version installed?

Enter grub menu by press and hold ESC key.
In grub, go to advanced options (not sure how exactly it is called) and try the fallback image or another kernel version if installed.

If you get into your system again, reinstall the kernel:

sudo pacman -S linux510

If not, you will need to chroot into you install. Follow @stephane’s link for instructions.

1 Like