[Stable Update] 2020-12-03 - Xorg-Server, Plasma 5.20.4, Cinnamon 4.8.0, Deepin, KDE-git

Just installed it’s as fresh install. System is very laggy and unresponsive. Can’t do anything to be honest. Everything opening slow and freeze. KDE version.

try this sudo balooctl disable this will disable the file indexer, it makes my computer slow

I have to agree with some of the others. My system has been very laggy and just froze on me after the this update. I was watching a video and my screen froze but the audio kept on playing. Had to power off my computer and turn it back on.

Edit: Not sure if it matters, but when I checked my currently installed drivers, the video-linux driver was not installed. Nor was any other driver installed. I did disable balooctl, which was suggested above, then I reinstalled the video-linux driver and then rebooted.

No issues so far with KDE.

Hopefully my plasmashell will stop bugging out and needing to be manually terminated and restarted every so often, but at this point I believe this is an issue with Virtualbox’s vmsvga implementation. (install is a guest on a windows system.)

Also got confused by the package release before the Stable release announcement :confused: but had no problem updating with pamac. :blush: Running 5.9. First impressions doing the Cinnamon jump from 4.6.7 to 4.8.0 worked with no issues for me and feels a bit faster, some icons changed like nemo. So far so good :+1:

Your solution is now part of the “Known issues”! Thanks for feeding back…


Also please read this:


A post was split to a new topic: Issue with menus

Updated, and unusually rebooted, tonight 3. december and after that pamac doesn’t start in cinnamon. Kernel 5.8.18-1.

@fhins and @galeot: do a flatpak update from the console and try to fire up discover again (also from a console). If this does not work try flatpak repair. Let me know if it worked :slight_smile:

KDE Plasma, kernel 5.4.80-2, just finished a quick update. A rapid and very smooth reboot and experiencing no apparent problems.

Cheers :+1:

My Pacman seems buggy on Minimize/Maximize/Close after update to kde 5.20.3 and now 5.20.4!

on Cinnamon some keyboard shortcuts no longer work (even if i change the shortcut for them they still wont work); for me the media keys are not working (Audio Play, Next/Previous) and when i press the Audio Play button it flashes the screen as if it was taking a screenshot without doing so. iv also found that the Prnt Screen key doesn’t take a screenshot either, i have to use alt + prnt screen now.

iv found this issues tracker for it from 5 days ago that has been closed Cinnamon 4.8 breaks media keys · Issue #9732 · linuxmint/cinnamon · GitHub

and for reference im using a Ducky One TKL keyboard

1 Like

I have the same issue. I tried both

  1. flatpak update
  2. flatpak repair

I am still seeing the same issue

** Message: 11:09:08.666: flatpak_plugin.vala:125: last flathub appstream refresh is older than 6

** Message: 11:09:08.666: flatpak_plugin.vala:126: refreshing flathub appstream data

(process:8626): GLib-GIO-WARNING **: 11:09:08.953: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here. Only the non-desktop-specific mimeapps.list file may add or remove associations.

(pamac-manager:8626): GLib-GIO-CRITICAL **: 11:09:08.955: g_application_run: assertion ‘acquired_context’ failed

I have the same issue (pamac-gtk does not launch), with a Manjaro MATE installation.

1 Like

I managed to run pamac again by following the mapac wiki from manjaro.

I did the following:

Dealing with Orphaned Packages

To check to see if there any orphaned packages(packages which are no longer needed) installed you can use:

pamac list -o

To remove all orphans use the command:

pamac remove -o

Cleaning the Cache

When pamac installs packages, it keeps a copy of all the old packages you have downloaded. This cache can be very useful if you have to install older packages in an emergency. However, left unchecked, this cache will grow very large over time.

A safer way to remove old package cache files is to remove all packages except for the latest three package versions using:

pamac clean --keep 3

Finally run


You should see the add/remove program again

If the steps above do not work for you, disable the flatpak and snap plugins for pamac.

remove the pamac-flatpak-plugin and pamac-snap-plugin

Step 1 : Run “pamac remove pamac-flatpak-plugin pamac-snap-plugin” in terminal
Step 2 : Start pamac-manager
Result: pamac-manager application can start

If you still want the plugins and keep them in disabled state, do the following:

Step 1 : Run “pamac install pamac-flatpak-plugin pamac-snap-plugin” in terminal
Step 2 : Start pamac-manager
Result: pamac-manager application can start
Checks: plugins are disabled

Hi @b_quest, thank you for your feedback. For me gnome-sogtware did the trick. A little bit annoying thing: it upgraded a bunch of flatpak packages automatically, without asking nor letting me taking note of what it was doing.

Luckily it worked.

1 Like

Updated with TTY …Desktop-Intel i7 Dual screens
LTS kernel KDE Plasma, Quick check all apps work OK …

Thank You

what happens if you remove the pamac-flatpak-plugin and pamac-snap-plugin?

pamac remove pamac-flatpak-plugin pamac-snap-plugin

We had a similar issue in v10.0 we are currently testing. Seems something changed and affected also the stable release.

You can also disable the plugins like so:

sudo sed -i -e /EnableSnap/d /etc/pamac.conf
sudo sed -i -e /EnableFlatpak/d /etc/pamac.conf

I have an issue after update my system. I use Cinnamon edition, and after update i have NO menu. I only see desktop icons, and can’t access other applications.

To solve this problem:

sudo mv .config .config_NEW

sudo mv .local .local_NEW