[Stable Update] 2020-11-27 - Kernels, Browsers, Maui-Apps, Pamac 10.0-Beta, Gnome, Mesa, Qt

Hello community,

Another stable branch update with some usual updates for you!

Get the latest merch with 25% discount on Black Friday! #stayhome, #staysafe, #stayhealthy

  • Most of our Kernels got renewed
  • Pamac has a new beta you may want to try out
  • Some more fixes to our Gnome packages
  • Qt got updated to 5.15.2
  • Lot of our Browsers got refreshed
  • Maui-Apps are now part of our regular upstream packages
  • Mesa is at 20.2.3

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release candidate! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.246
  • linux49 4.9.246
  • linux414 4.14.209
  • linux419 4.19.160
  • linux54 5.4.80
  • linux57 5.7.19 [EOL]
  • linux58 5.8.18 [EOL]
  • linux59 5.9.11
  • linux510 5.10-rc5
  • linux54-rt 5.4.78_rt44
  • linux59-rt 5.9.1_rt19

Packages Changes (Fri Nov 27 00:48:40 CET 2020)

  • stable community x86_64: 1185 new and 1149 removed package(s)
  • stable core x86_64: 24 new and 24 removed package(s)
  • stable extra x86_64: 363 new and 356 removed package(s)
  • stable multilib x86_64: 18 new and 18 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

For TL3s and up: This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

[Edit according to @banjo’s advice.]

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.

Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/

Older Issues

Please click the ► at the beginning of this line to view the older issues

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.


Update went fine on three computers:
1 * KDE Plasma (kernel 5.4 and 4.19)
2 * XFCE (1 * kernel 5.4/4.19 and 1 * kernel 4.19 and 4.14)


Have I to do this before or after the update?

After the update. Before you have the old paths.


Good, thank you very much!! :grinning:

Update in plasma , all OK.

The XFCE link is bad (does not exist)

Its still being uploaded

EDIT: Its Uploaded now

1 Like

Update on Gnome OK

I voted incorrectly and don’t know how to rescind it. Everything went smoothly. Thx. :wink:

I had a minor problem, pulseaudio-equalizer did not appear in Application menu. I resolved by installing pulseaudio-equalizer-LADSPA plugin. Thanks good job Phil!

Click Show vote under the vote stats.

Issue with Cockpit 233.1-1
Docker containers error with a red “Ooops” in the top right corner of the browser.
It seems jquery.js is missing in /usr/share/cockpit/base1/
Copying the jquery.js file manually in that folder solves the issue.

Pulseaudio update fixed my problem. Headphone is automatically is muted when I plug it. Thank you.

1 Like

Problem with LibreOffice-fresh 7.0.3-2. I can’t launch LibreOffice-fresh 7.0.3-2 under Manjaro Gnome 20.2-rc3 with Wayland. Openjdk 8 installed.

Here are the errors I’ve got (LibreOffice launched in the terminal):

Fatal exception: Signal 11

Note: Unoconv installed but after that I uninstalled it. I uninstalled libreoffice and java components, and install again but I have still the errors.


Xfce, kernel 4.14.
All fine as usual. This update also bringed qt5-base 5.15.2-1 which has solved this problem: Qt5-base package: QMovie: "Unable to read image data"

For the rest, now, I noticed that the haveged service, randomly on startups (doesn’t happen every time) print this warning in the journal log:

systemd[233]: haveged.service: Failed at step NAMESPACE spawning /usr/sbin/haveged: No such file or directory

But such file exists indeed, and despite such warning, haveged starts and works as expected.

…is not sufficient : one also need to start them (or to restart computer as I did :wink: )

apart this point, everything was smooth, thanks for all this ! :clap:


hi there,

it seems since the update I can’t reconnect my bluetooth device, eg: Headphones, Xbox Controller, etc. I says connected, but then keep reconnecting…

Anybody knows how to solve this?

1 Like

The update was ok
But still experiencing No bluetooth on kernel 5.9
Also I can’t login after logout. It just hangs on splash screen and then blank screen
BTW, I use KDE