[Stable Update] 2020-11-27 - Kernels, Browsers, Maui-Apps, Pamac 10.0-Beta, Gnome, Mesa, Qt

The cups renames were mentioned while updating (at least on the terminal but methinks it would be visible in pamac-GUI as well) and one should always pay attention to output while updating.

1 Like

I find it very funny how the maintainer from Arch Linux (it is a package imported from Arch with no modifications) had made a lot of effort to write this whole technical speech in post upgrade on how to do it, without actually doing the job itself in post upgrade by putting the relevant bunch of systemctl commands. The “Arch philosophy” blows my mind on so many levels sometime on how counterproductive it can be.

1 Like

Cinnamon, 5.4, all good. Thanks much.

Not everyone use printers and not every one have this service started, so why package to force you do something that you don’t want to do. It is just philosophy of the package maintenance.

1 Like

Sorry, didn’t catch that one :slight_smile:

The link is correct, it is ceph-libs 15.2.6-1. Its community repo that is in question, AUR is totally different, never mind…

I checked mine /etc/passwd and I don’t have ceph user, nor /run/ceph, nor /usr/bin/ceph.
The package ceph-libs comes with the system I guess. I have it to.

Now why would something create a user, I don’t know, but the system is using this package I think.

sudo find /usr -name 'ceph*'


Hope someone from the team can really help you, 'cause its weird.

In that scenario, systemctl is-enabled UNIT can be used. The exit status will give if the unit is enabled or not on the system and then, according to the exit status, you do the transition or not. You would have something like:

if systemctl is-enabled OLD_UNIT then
    systemctl stop OLD_UNIT
    systemctl disable OLD_UNIT
    systemctl enable NEW_UNIT
    systemctl start NEW_UNIT

Repeat for each unit that needs a transition. Maybe put a for loop if wanted.


or just write message while install package :smiley:

1 Like

Now the Files listing has been refreshed, too.
Everything is fine.

Lessons learned:
Do not trust what you see at first view
Gitlab is a great source of information
but in this case not very helpful.

Because I know my environment very well
in some cases I just want knowing reliably
the hows and whys things change
so I can decide to apply a patch immediately or wait (for example).

Thanks for your hints

Seems manjaro wiki is down with a case of the Vid, or something

5 posts were split to a new topic: Org.cups.cupsd.service not found

Hi philm,

after stable-update-2020-11-18 I had a black screen after boot (Black screen after [Stable Update] 2020-11-18) although I had the latest sddm version. I kept upgrading and this update also did not solve the issue, but downgrading to sddm 0.18.1-3 solved it.

So I think perhaps there might be something that manjaro team can do, so I don’t have to stay on that version “forever”, or do I need to file another sddm bug report?
Perhaps you could add it to the Known issues and solutions section.

This seems to be different from the PAM and PAMBASE issue, since I don’t have a system-auth.pacnew

  • I’m an idiot! :grin:
  • Copy-paste error
  • Edited now
  • Thanks for the feed-back!



For help of others that may experience this its resolved. From sudo rename /home/(user)/.config/audacious folder to something else. Try starting Audacious from the desktop icon. Mine restarted. When you do this Audacious will create a new /.config/audacious folder. Playlists will be empty. In my case one of the things I wanted to save was my playlists. I deleted the Playlists folder in the newly created /config/audacious folder and moved the Playlists folder from the renamed audacious file from .config into the new folder. So far so good, seems to have functionality as before.

Regards & hope this will help someone else.

Hi, after the update I can login but I can’t reach my desktop. I’ve logged in through tty2 and i’ve restored my system with timeshift.
I don’t have any pacnew file in /etc/pam.d and the cups patchs didn’t resolve the problem.
Please tell me what should I do to get some help.


Oh, I forgot to say that after login the system asks for a password to kwallet, but it gets stuck.

Have you tried creating a new user (E.G. indaleto2) and logging in there?
Does this have the same problem?

Hi, thanks for your replay.
Yes I’ve tried and even install xfce on it before the update but the result is the same.

2 posts were split to a new topic: Black screen / emergency shell after update

That command enables the cups.service so it auto starts at boot, the --now part says to also start it right after the command is executed so you don’t need a reboot for it alone.

This is just evidence that some people are still not familiar enough with systemd, you can’t really blame them though because there are so many parts that one needs to get familiar with :wink:

But when it comes to the right way of doing things, then i agree with what @Frog suggested…