[Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

I see… Any possibility of it being packaged? I don’t really wanna downgrade my kernel for this.

THX your solution helped me. After the update there was just the blank screen.
ALT+F3 lead me to TTY, where I could perform your suggestion:

  1. mhwd -r pci video-nvidia-455xx (remove of the nvidia driver)
  2. mhwd -i pci video-nvidia-455xx (install of the nvidia driver)

For me, it seems, that the issue was Kernel 5.9 and the (incompatible) Nvidia driver for kernel 5.8 (my previous kernel)
After remove and install the Nvidia driver, the driver for the 5.9 kernel was installed and plasma (graphical interface) popped up instantly without reboot.

Hope, that helps anyone else …

You have no choice so either you ‘downgrade’ to a kernel which has what you want, or you go the custom route by installing things from the AUR… which is not worth it, do the logic thing, use a current kernel which has your driver, example NOT the latest kernel 5.9

1 Like

Update went fine, everything seems to work OK.

But then I decided to add to already existing kernel 5.4 and 5.8 also kernel 5.9 and 5.10rc and upon reboot, my nice manjaro themed grub menu was gone and was greeted by some horrifying black text only grub menu? (top text does say : GNU GRUB version 2.04~manjaro)
How to get the nice graphical Manjaro grub menu back?

(btw. both 5.9 and 5.10 do seem to work just fine also so far.)

Make sure this line is present in /etc/default/grub


Update Grub and your Manjaro theme should be back again.

Update on 13 Systems without Problems.


cinnamon 5.4, smooth update, thanks to manjaro team.

Will there be a fix for the black screen?

I had this line before. The last grub.pacnew from this very update removed this theme line, so I just in case commented it out instead of removing. Then again it seemed to work nicely without the line, just before I did add the new kernels after the update and few reboots. I guess I have to uncomment it again then.

Ah ofc. Now I see. The update updated system and kernels and everything, updated-grub (with my old /etc/default/grub), added new grub.pacnew. Then I ran pacdiff, and commented the removed line out of /etc/default/grub according to pacnew; however forgot to run update-grub (that’s why it seemed to work perfectly before new kernels); then less than hour later decided to add newer kernels and then the update-grub happened without the theme line. Brilliant. :smiley:

You’ll have to be more specific than that. I suggest opening a new #support topic detailing the issue you’re having.

1 Like

Okay, thanks!

I have just this:

~ >>> ls -l /usr/share/grub/themes/                                                                                                                                                                                    
total 4
drwxr-xr-x 2 root root 4096 Nov 13 21:14 starfield

Nothin changed, no text or anthyng changed with updates.

You do not have grub-theme-manjaro installed … Once you do, check again what @chomsky mentioned and run sudo update-grub

1 Like

I have the same problem for all QT5 applications.

I tracked it down to the qgnomeplatform update. The most recent upstream commit has something to do with the file dialog.

Removing qgnomeplatform helps as a temporary workaround.


Anyone having problems with steam big picture audio on nvidia?
Using nvidia 455.45.01 and can’t get sound in big picture mode through hdmi and steam kinda hangs and needs to be killed by sending KILL signal.
Changing the output to headphones works ok with steam big picture.
HDMI audio appears ok for everything else including games

Steam log entering big picture is:
[ALSOFT] (EE) Failed to set real-time priority for thread: Operação não permitida (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Operação não permitida (1)
[ALSOFT] (EE) Failed to write to stream: -3, Argumento inválido

with the last line repeating endlessly.

All else in the update seems to be working as intended.

1 Like

Thank you for your advice. I tried it with an appimage (although I’m not an expert, so I don’t know, if I did it right. I used a script, I could find. But no dependencies ware added, right?). The problem remained though. In the meanwhile I was able to locate the update in question. It is " lib32-gdk-pixbuf2 2.42.0-2" that destroys the GUI of LibreOffice 4. I hope someone could fix this. In the meanwhile I will try to stick to the previous version (2.40.0+6)…

Concerning your argument “rolling release” I like to opposite, because I experienced, that ONLY a rolling release gave my the chance to use such an old software, because other distros mostly quit multilib already, as far as I encountered… So I definitely will stick to a rolling release…