[Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

[quote=“LA-MJ, post:169, topic:38196”]
Yet I am still annoyed.

After reading of your problem, I tried on my own systems. 1 desktop and 1 laptop. My shortcuts and commands are still there.

As far as I remember kwin (.config/kwinrc) does the windows, desktops and compositing. Look for kglobalshortcutsrc

It works here on both machine but I use amdgpu. Look into your amdgpu/nvidia config for opengl

Hope this will help

Exactly what it says.


I hope, someone can help me to fix my Libreoffice. Last update (2020-11-18) broke the GUI of my Libreoffice in that way, that it doesn’t use the systems theme (arc/Cinnamon) anymore. Instead it looks like old Windows 95/98. Just to tell you, it is an old version of Libreoffice 4.06 and 32-bit I use in a x86_64, because I need it for a certain extension. I had build it from AUR some years ago (lib32-libreoffice-de) and it worked until now with no complains. I’m not able to tell, what update is responsible for this behaviour so far, because it had been rather a lot of updates this time. Until now this problem doesn’t occur on an other installation with archlinux (32-bit) itself.

Thank you for helping me.


Power management is not working properly after update. cannot change display brightness on my dell inspiron 5558 laptop. (KDE) slider moves and popup animation is shown with keyboard shortcuts but does not affect brightness at all.

(I downgraded pulseaudio and its dependency due to ongoing audio port switching issue but I don’t think this should have anything to do with brightness)

A post was split to a new topic: Black screen after update

A post was split to a new topic: Laptop freezes randomly

Hi, I installed the latest stable image of Manjaro KDE on the 15th on a brand new Lenovo T14 and the touchpad was working fine.
After the update the touchpad is not working anymore :frowning:
I tried to downgrade libinput but the problem remains so it might be bigger than that :confused:

Edit: I updated to the 5.9 kernel and the issues remained. I shutdown (not restart) the computer and start again and it worked.
I think the issue came from me rebooting from windows (dual boot), I just read that sometimes the driver for hardware is loaded in the flash memory, which means it’s always recommanded to shutdown and start computer when you want to change the operation sytem used (and not reboot).
So I don’t think my problem was coming from the update (just a bad coincidence). I leave my experience here, just so it can help.

There is solution posted already

OK, I’ve dug into the OpenVPN problems and I’ve found the solution.
The main problem is that the new systemd unit specifies running as user openvpn and group network, whereas the original (pretty sure I didn’t change it, though I may be wrong) didn’t specify a user/group.
So the big problem was the daemon not being able to read config in /etc/openvpn. The solution here is to change the ownership of that directory (and everything under it) to openvpn.

A secondary problem (for me) was that I was specifying AES-256-CBC as the cypher, and this is no longer supported. Changing that to AES-256-GCM fixed the problem (this was also set as one of the alternative options in my client device’s config, so this was safe for me. This may not be the case for everyone).

1 Like

You cloud also add

data-ciphers AES-256-GCM:AES-128-GCM:AES-256-CBC

to the client config.
It is stated in OpenVPN log after connection fails.
I think it would be the “more sensible way” because of the change from --ncp-ciphers to --data-ciphers.

Maybe the following works for you as well?

I am unsure about why there was no pacnew or why quite a few users, including me, somehow apparently must have missed it – the problem is the (silent?) removal of the encrypt hook.

Yes I also had issues with lightdm failing and startx failed also. So I booted to latest kernel in single user mode and followed Phil advice in original post (pamac remove command, etc.). Then I had to reset mirrorlist and make sure downloading OK. Also had to boot into latest kernel and CTRL+ALT+F2 and finish off driver install: Trying to update to nvidia-450xx

1 Like

Updated on GIGABYTE AORUS B550I, Kernel 5.9.8, KDE

  • no Sound on ALC1220-VB (since last Update)
  • no more Bluetooth (that´s a new feature) - blanked on System Settings
  • Back to LTS 5.4 not possible (BlackScreen after GRUB)
    (for information - 5.4 also doesn´t support ETH on B550i - Realtek R8125)

Not updated 2nd PC with GIGABYTE X370 Gaming 5 (also no sound).

Very bad quality - it´s enough!!

1 Like

Maybe you added fsck to HOOKS in /etc/mkinitcpio.conf ?

I don’t even know what does that file do. I never touched it.

Does anyone know?

Please look above, in my two systems it is not fixed. :pensive:

No nvidia 418.xx drivers for Linux 5.9?

If a “pacman -Qi startup-notification” in the terminal says there is no 'required by" packages, you can remove it.
But using “sudo pacman -Rns startup-notification” will show you the dependencies too and you have the option to remove it or not.

Hardware accelerated video decode no longer works in Chromium with kernel 5.9.8.