[Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

i had to uninstall it first with
mhwd -r pci video-nvidia-455xx
and then i installed
mhwd -r pci video-nvidia-450xx

but its also not working.
Kenel 5.9 black screen
Kernel 5.8 emergency mode :rotating_light:

1 Like

libpng warning: iCCP: known incorrect sRGB profile
Now the video is packaged incorrectly, MediaInfo shows incorrect bitrate and fps.

System no longer booting into OS since update.

  • Forgot to check package list so 5.9 was installed (which doesn’t work with nvidia drivers yet)
  • 5.8 no longer works after update
    Failed to start kernel modules
    Failed to start CLI Netfilter Manager
    Failed to mount /boot/efi
    Dependency failed for Local File System

In an attempt to fix it, I booted from usb and tried to do a grub reinstalled (the usual fix when I have boot issue in the past). Now the grub menu no longer shows up and it goes straight to the lastest version that doesn’t work (Failed to load Light Display Manager). Removed linux-latest / 5.9 manually, but grub and 5.8 still doesn’t seem to work anymore (also tried to downgrade grub).

Grub no longer recognize my nvme drive while doing probing (windows dual boot)

Anyone else having similar issue? Any idea on how to fix this?

amd r5 2600x cpu / nvidia 2060 super gpu. nvme boot drive (both os)

A post was merged into an existing topic: Problems with Digikam

Currently experiencing similar issues with 5.9.8-2 and 5.8.18-1.
Booting to 5.4.77-1 seems to work as a temporary solution


A post was split to a new topic: I can’t login after reboot

Wait, sorry, I may be missing the point.

Before the update:

  • /etc/mkinitcpio.conf exists
  • no pacs /etc/mkinitcpio.conf.* exist
  • encrypt hook is evidently set, as everything with initramfs and booting and encryption works

After the update:

  • /etc/mkinitcpio.conf exists
  • no pacs /etc/mkinitcpio.conf.* exist
  • encrypt hook is missing

Where did I miss the chance here to keep whatever I added or even notice that /etc/mkinitcpio.conf may have changed? There’s no pacnew (and I didn’t remove any) and there were, afaik, no notices about this when running the update.

There was a pacnew from the previous stable update.

I recommend:

# update file “/var/lib/pacman-mirrors/status.json”
pacman-mirrors --no-mirrorlist

# show status for your local mirrorlist
pacman-mirrors --status

# create backup
cp -av /etc/pacman.d/mirrorlist /etc/pacman.d/mirrorlist.YMD

# reorder custom mirror list based on speed
pacman-mirrors --fasttrack

# show status for your local mirrorlist
pacman-mirrors --status

After an update I always run: DIFFPROG=meld pacdiff

The variable GRUB_THEME is commented out in /etc/default/grub.pacnew.

I have it set from a previous install to /usr/share/grub/themes/manjaro/theme.txt.

I could not find GRUB_THEME set any place else. The file does exist.

Should it be set or not?

Updated with TTY quick test all apps functioning and seem fine on a desktop-Intel i7 dual screens LTS kernel KDE plasma stable edition , Thanks heaps

It exists if you have grub-theme-manjaro installed. It’s up to you what GRUB theme you want to use–or none at all.

Select kernel 5.9 while booting from grub menu, its hidden if it doesn’t show while booting, there is a shortcut key to reveal it, I have forgotten just google it.

I know that I can display this with Esc. But it would be normal if a newly installed higher kernel is active by itself at the next reboot. For me this is again a bug.

KDE Plasma, kernel 5.4.77., smooth update and reboot.

Cheers :+1:

Kernel 5.9.8-2 won’t boot for me. 5.8.18-1 works fine tho.

Hello everybody

After the update, I don’t get the display manager running. After a smooth boot, instead of a loginscreen I get a black screen with a white cursor in the upper left corner.

I tried to fix it, but haven’t found a solution yet.

What I have: Manjaro-Gnome (up to date): Note: After update: gnome-wallpaper was newer then in the repo.
What I tried to do:
-Install another dm (sddm with plasma) and start it. Didn’t work.

  • Downgrade gnome-wallpaper
  • Boot an older kernel: Can’t even boot, due to the fact that it doesn’t find a HDD, that should be mounted, that I’ve written in /etc/fstab (no problem with the newer kernel in this affair, but maybe I should investigate the further… :thinking: )
  • Switched to testing & unstable for updates. But no update available, that worked, so turned that back

What I should do: unplug my headset, which I added yesterday(USB), but I don’t expect that that solves the problem.
If anybody has an idea, I would be very thankful.

Updated, all good on XFCE with AMD hardware.

On Gnome QT5 app Kate fails to show the save file dialog.
I use
QT_STYLE_OVERRIDE=Fusion (tried switching to adwaita but that changes nothing)
I can’t seem to find anything online about this.
Anyone has any suggestions?

Also by switching to wayland my .profile does not seem to be loaded anymore? The PATH changes present in .profile are not executed in terminals.

1 Like

jesus, what happened to Thunderbird GUI :open_mouth: :frowning_face: :grinning: