[Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin

Welcome to the forum! :slight_smile:

There is no difference. Manjaro is a curated rolling-release distribution. The .iso images are only snapshots.

Was seeing a lot of errors "systemd: Failed to start Application launched by gnome-session-binary.

I’ve migrated my home folder through several upgrades and at least one new pc build, apparently I’d accumulated some cruft.

Check your ~/.config/autostart I had a lot of desktop files in there for software I no longer have installed.

Increasing memlock fixed it for me. I found this very helpful: io_uring throws and exception · Issue #972 · MusicPlayerDaemon/MPD · GitHub
I edited /etc/security/limits.conf

1 Like

This is my issue ─ only reporting it here, as I have opened a separate thread. :arrow_down:

Mamamia… Please do a search about the program called Timeshift. Why would anyone reinstall the whole system? Also why would you update your system if you’re working on something urgent don’t take any risk. Two noob errors I hope you’ll learn from that experience that should not have happened :stuck_out_tongue:

2 Likes

Gnome-Passwordsafe is not starting after update.

Here i found on gitlab why:

Hi there, pykeepass 3.2.1 changed the Error Exceptions in a minor release and uses now an CredentialsError rather an CredentialsIntegrityError (among other things).
So the old 3.99.2 release will never work with a pykeepass 3.2.1 package. For arch there might be essentially 2 solutions: 1) use an older pykeepass with that version of passwordsafe or 2) update to a currently still unreleased (and still changing) git release or 3) wait for the next release of passwordsafe which will work with pykeepass >=3.2.1.
Essentially nothing that passwordsafe can do about now. It is fixed in master.

Would it be a way to keep pykeepass on the old version in Manjaro until the next update of Gnome-Passwordsafe?

rebooted kde all went well. I like that now the manjaro boot menu is full screen on my montior and apparently it looks like the plasma team changed the clock on the taskbar to include the date. :+1:

Because that’s how it works. For some reason it’s not appreciated to keep an installation running for several years. Then there’ll be that one update that doesn’t cleanly update all installations to the same state and (maybe some time later) at one point one of the releasers say “Oh, I didn’t know anyone was still using it.”. And I’m not talking about installations that were highly customised.

It does make sense to reinstall every now and then. Rolling releases have that downside. It’s just how it is.

BTW, I’m not saying a reinstallation is bad, but it becomes bad when it’s being forced on you. Just find a weekend or something to get this done :slight_smile: And yes, timeshift is nice, I’ve never had the need to restore my system, though.

3 Likes

Same problem here. How did u downgrade to the older version?

After update when I input “df” in terminal I get “df: /run/user/1000/doc: Operation not permitted” as first string and new last string was added:
tmpfs 3287620 164 3287456 1% /run/user/1000
How to fix this error?

1 Like

That not true especially in that case the user could have clicked one button to rollback the system. As I said he made two mistake, first rushing an update when he was working on something important, and second he does not backup his system (and actually third error due to previous errors, he reinstalled when it was not needed without troubleshooting his issue).

What is true though is that a rolling release needs maintenance and the user needs to be aware of important changes that could occur, I give you that, from time to time on a rolling release.

2 Likes

I was so excited to get this update, but now I am facing a problem from “vtk” that prevents me from updating. I got a ton of errors saying “file.foo already exists in filesystem” in which the file names differ. Should I just try to delete the conflicting directories “/usr/lib/python3.8/site-packages/vtkmodules” " and “/usr/share/doc/vtk-8.2” and try again?

Manjaro GNOME here.

One of the updates of today was stopped by an already existing default.pa file in /var/lib/.config/pulse. I just sudo-su’ed in and renamed the file, then the updates went through. All seems to work for now in the Pulse-Audio department ;-).

My laptop screen is flickering and jumping around after this upgrade (gnome) and switching to the 5.9 kernel. reventing to 5.8 seems to fix but i notice that 5.8 is EoL.

If i go into gnome settings and change the refresh rate and back again - then all OK with 5.9.

Very strange. Any idea why there is an issue with 5.9? using Acer Laptop with intel HD 605.

1 Like

Thanks. I’ll give it a go.

Thanks, that worked by generating locale using locale-gen.
Sorry for being newbie I have two questions : if I use one locale for display (english) and another one for units (metric) and date should I generate them both using locale-gen? And why KDE settings is useless and does not do this by itself when choosing language ?

Bare metal r5 3600 and VBox VM both went smoothly.
Thanks Manjaro guys, you rock!

1.3 Gig of download - 6.1 Gig of files, all ok.
I had no reasons to post an hostile or incredibly impolite stuff.

Well done :wink:

~]$ inxi -F -v 7
System:
  Host: ordi1 Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.2.0 Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel, plank 
  wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: K53SD v: 1.0 
  serial: <superuser/root required> 
  Mobo: ASUSTeK model: K53SD v: 1.0 serial: <superuser/root required> 
  UEFI: American Megatrends v: K53SD.208 date: 08/10/2012 
Battery:
  ID-1: BAT0 charge: 16.3 Wh condition: 16.9/57.2 Wh (30%) volts: 12.4/11.1 
  model: ASUSTek K53--52 type: Li-ion serial: N/A status: Unknown 
Memory:
  RAM: total: 11.48 GiB used: 4.55 GiB (39.6%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Dual Core model: Intel Core i3-2350M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB bogomips: 18364 
  Speed: 2295 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 2295 2: 2295 
  3: 2295 4: 2295 
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est 
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear 
  mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good sep ssbd sse 
  sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0116 
  Device-2: NVIDIA GF119M [GeForce 610M] vendor: ASUSTeK driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:1058 
  Device-3: Alcor Micro Asus Integrated Webcam type: USB driver: uvcvideo 
  bus ID: 1-1.2:3 chip ID: 058f:a014 
  Display: x11 server: X.Org 1.20.9 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa resolution: 
  1: 1366x768~60Hz 2: 1680x1050~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 20.2.1 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Sound Server: ALSA v: k5.9.3-1-MANJARO 
Network:
  Device-1: Intel Centrino Wireless-N 100 driver: iwlwifi v: kernel 
  port: d000 bus ID: 03:00.0 chip ID: 8086:08ae 
  IF: wlp3s0 state: up mac: 78:92:9c:95:7a:b2 
  IP v4: 192.168.1.28/24 type: dynamic noprefixroute scope: global 
  broadcast: 192.168.1.255 
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: ASUSTeK 
  driver: atl1c v: kernel port: 9000 bus ID: 05:00.0 chip ID: 1969:1083 
  IF: enp5s0 state: down mac: 10:bf:48:0f:dd:cf 
  WAN IP: 80.200.1.75 
Drives:
  Local Storage: total: 931.51 GiB used: 425.27 GiB (45.7%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB 
  size: 931.51 GiB speed: 3.0 Gb/s rotation: 5400 rpm serial: S2TTJ9CC400760 
  rev: 0001 scheme: MBR 
  Optical-1: /dev/sr0 vendor: MATSHITA model: BD-CMB UJ141AF rev: 1.00 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / size: 95.62 GiB used: 37.01 GiB (38.7%) fs: ext4 dev: /dev/sda2 
  label: N/A uuid: d770c061-597b-4849-868d-6cb431db7ceb 
  ID-2: /boot/efi size: 246.1 MiB used: 278 KiB (0.1%) fs: vfat 
  dev: /dev/sda1 label: N/A uuid: C577-F478 
  ID-3: /home size: 819.53 GiB used: 388.26 GiB (47.4%) fs: ext4 
  dev: /dev/sda3 label: N/A uuid: 3dc71c14-bd34-452b-b101-0c4a4c6f745b 
Swap:
  ID-1: swap-1 type: file size: 256.0 MiB used: 17.1 MiB (6.7%) priority: 50 
  file: /var/lib/systemd-swap/swapfc/1 
Unmounted:
  Message: No unmounted partitions found. 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 
  Device-1: 1-1.2:3 info: Alcor Micro Asus Integrated Webcam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 058f:a014 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 2-1:2 info: Logitech MX Revolution Cordless Mouse 
  type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s chip ID: 046d:c525 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 4-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A gpu: nouveau temp: 46.0 C 
  Fan Speeds (RPM): cpu: 2000 
Info:
  Processes: 253 Uptime: 11h 19m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: 1754 pacman: 1721 flatpak: 33 Shell: Bash v: 5.0.18 
  running in: xfce4-terminal inxi: 3.1.08 

Vanilla Gnome, Linux54
After Update:
Some minor odd behavior from DashToDock (Can’t add the correct pamac as a favorite)
Had to re-install Evolution, it stopped connecting to exchange for loading contacts.

1 Like

I did this yesterday. I’m busy right now, but here’s a basic rundown of what I had to do which made rebooting work successfully. I copied the pamac log to Notepadqq to be able to search in it. I did a search in the pamac log for “pacnew” and found that I had 3 pacnew files to resolve. I did that manually. One of them was a dangerous-looking one with mkinitsomethingorother. I used Meld and compared the pacnew file with my file, and carefully chose which modules to use, or something like that. The others were for pulseaudio, and I had to keep the modules that break everything by auto-switching stuff disabled. After rebooting, everything worked as normal.

I really wish pulseaudio would have those broken modules disabled by default. They switch my microphone to go through my speakers and they stop my microphone from working after a while for no reason, and when I had them not disabled, I had to manually switch my input around in the pulseaudio tray icon to fix it before any zoom/skype/discord/etc. call or else my microphone wouldn’t work, and would start playing through my speakers. So nuts.

Anyway, my computer boots and has all the workarounds I needed to figure out completely alone because nobody talks about these problems.

Thanks for the update, Manjaro team! None of the problems I’m talking about are specific to Manjaro, and it’s on pulseaudio, and up to me to track the bugs there.