[Stable Update] 2020-10-19 - Kernels, Nvidia 455, Browsers,

I think they have to remove the 5.7 Kernel because it’s EOL don’t know why it’s still in repos. :woman_shrugging:


Steam won’t start anymore. Using Nvidia 450. Other accelerated programs (eg. glxgears) and non-Steam games are working fine.

(Edit: fixed after upgrading to Nvidia 455.)

# steam
Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
[2020-10-20 00:12:11] Startup - updater built Oct  7 2020 06:15:36
Installing breakpad exception handler for appid(steam)/version(1602115886)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

Symlinks to NFS-mounted directories now show up as broken in Thunar, Nautilus and the Places panel widget. The symlinks are not broken and can be entered with command line tools (cd, ls). Other file managers (Midnight Commander, PCManFM, Dolphin) are working correctly.

1 Like

What kernel are you on?

I’m on 5.8.
I tried 5.9, but it stalled after the login screen so I went back.

1 Like

Try the 440 series. (see my profile)


Try the solution for the 440-450 compatible issues in the existing problems category:

(which is the same @davicbhr is saying) :+1:


Kernel 5.7 is EOL please upgrade to an LTS or a higher version.


I haven’t had any noticeable issues with 450. Just 455 so far.

1 Like

I’m running 5.8, should I uninstall 5.7 ?

You’re lucky. (for newer cards, the 450 series is fine, but for older cards: lots of :poop:)


1 Like

so if im using nvidia 450 and want upgrade to 455 i need manualy intervention?or i can wait ?

Yes you need to change the driver branch from 450 to 455, it is not just an “update” of 450.

Go to the Manjaro Settings, Hardware, and remove nvidia 450 then install nvidia 455, reboot, you should be good.


Steam does not start with prime-run on an nvidia optimus configuration notebook.

prime-run /usr/bin/steam

Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
[2020-10-20 00:12:16] Startup - updater built Oct  7 2020 06:15:36
Installing breakpad exception handler for appid(steam)/version(1602115886)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

inxi -Fazy

  Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=ecbc1446-0bef-4139-9af4-3931710cef36 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: XMG product: P65xHP v: N/A serial: N/A Chassis: 
  type: 10 serial: N/A 
  Mobo: XMG model: P65xHP serial: N/A UEFI: American Megatrends v: 1.07.13 
  date: 10/02/2018 
  ID-1: BAT0 charge: 57.9 Wh condition: 57.9/60.2 Wh (96%) volts: 16.3/14.8 
  model: Notebook BAT type: Li-ion serial: <filter> status: Full 
  Topology: Quad Core model: Intel Core i7-7700HQ socket: U3E1 bits: 64 
  type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 
  microcode: D6 L1 cache: 256 KiB L2 cache: 6144 KiB L3 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44817 
  Speed: 900 MHz min/max: 800/3800 MHz base/boost: 3400/8300 volts: 1.0 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 901 5: 900 
  6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 630 vendor: CLEVO/KAPOK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: NVIDIA GP106BM [GeForce GTX 1060 Mobile 6GB] vendor: CLEVO/KAPOK 
  driver: N/A alternate: nouveau bus ID: 01:00.0 chip ID: 10de:1c60 
  Device-3: Chicony Chicony USB 2.0 Camera type: USB driver: uvcvideo 
  bus ID: 1-9:5 chip ID: 04f2:b5a7 
  Display: server: X.Org 1.20.9 driver: modesetting 
  alternate: fbdev,intel,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
  Sound Server: ALSA v: k5.9.1-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: d000 bus ID: 6d:00.1 
  chip ID: 10ec:8168 
  IF: enp109s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000 
  bus ID: 6e:00.0 chip ID: 8086:24fd 
  IF: wlp110s0 state: down mac: <filter> 
  Local Storage: total: 5.92 TiB used: 18.77 GiB (0.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW512G7 size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: PSF121C scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST2000LM015-2E8174 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
  ID-3: /dev/sdb type: USB vendor: Seagate model: StarTech RAID0 
  size: 3.64 TiB block size: physical: 512 B logical: 512 B rotation: 5400 rpm 
  serial: <filter> rev: 0101 scheme: GPT 
  ID-1: / raw size: 200.00 GiB size: 195.86 GiB (97.93%) 
  used: 18.77 GiB (9.6%) fs: ext3 block size: 4096 B dev: /dev/sdb3 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 33.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb2 
  System Temperatures: cpu: 53.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 222 Uptime: 17m Memory: 15.39 GiB used: 1.59 GiB (10.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1205 lib: 381 
  flatpak: 0 Shell: Bash (sudo) v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05 
1 Like

Yes and yes. (up to you which you want to do: I’m still on the 440 series on an nVidia GeForce GTX 1070 without any issues)



Kernel 5.9 did not fix the issue that started with 5.8:
No wifi networks detected, Intel 3168 wireless, iwlwifi driver.
Networks are still listed in Network Manager, nothing detected at desktop.

Kernels 5.7 and earlier work flawlessly. No wifi in 5.8 or now 5.9

Everything is fine, nvidia 455xx a little faster. I tried benchmark with a Trackmania nations forever and i’ve got 89,7fps, but when i had 450xx i have 87,4fps.
btw: If i want to everything working i should stay on a kernel 5.8 until nvidia release new drivers. It could be in a mid November?

Greetings all,

Ethernet is no longer working with Linux54-rt kernel. Same thing with 56-rt
Everything working good in Linux54 standard.
Not sure if the RT kernel does not support my particular ethernet on my laptop or if something is not loading at boot. Any help on this would be appreciated.


sudo pacman -Ss lib32-nvidia
multilib/lib32-nvidia-340xx-utils 340.108-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-390xx-utils 390.132-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-418xx-utils 418.113-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-430xx-utils 430.64-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-435xx-utils 435.21-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-440xx-utils 440.100-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-450xx-utils 450.66-1 [Installiert]
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-455xx-utils 455.28-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-cg-toolkit 3.1-7
    NVIDIA Cg libraries

Why no: multilib/lib32-nvidia-450xx-utils 450.80 ??

A new update broke Steam and league of legends for me. To fix make sure you install newest Nvidia driver(455xx).

Also I’m currently on 5.4 kernel and still get notification that new one is available, even though “Only notify LTS kernels” is checked.

Lastly, I wish I could get any notification that new Nvidia driver is ready to download. Feature to auto-update LTS kernel and Nvidia driver would be neat too.