[Stable Update] 2020-10-01 - Kernels, Mesa, KDE-Framework, Deepin, Systemd, Pamac, Xorg-Server, Qt

I used Event Calendar in a Latte dock, so after the update that crashed instead of Plasmashell. I have deleted the local version under ~/.local/share and installed v69 from the AUR, but Latte still crashes…

Edit to add that it works as expected without the Event Calendar widget.
Another edit to specify that I can install v69 from the AUR, add it to my Latte dock and change settings, and Latte crashes only after a reboot.

This issue with Event Calendar is wierd. I haven’t updated Manjaro yet because I’m not near that computer but Event Calendar is working fine on my Arch machine and my EndeavourOS machine. :man_shrugging:

At least I’ll be warned when I update on Monday! :slightly_smiling_face:

Not familiar with Latte, but see the logs to make sure it is loading the addon from /usr/share/plasma/plasmoids/org.kde.plasma.eventcalendar, or if there are other issues with it other than the ones mentioned above.

System settings > Display configuration > Compositor > uncheck ‘Allow applications to block compositing’. Additionally try to change the Rendering backend to OpenGL 3.1.

Seems to be fine on my side, on Manjaro Cinnamon.

Thanks for replying. latte-dock seems to leave no traces itself in the logs (checked the journal logs via the KSystemlog app that comes with KDE, as well as by running latte in the terminal), so I cannot say for sure where it is loading the widget from, but it has to be the one in /usr/share/plasma/ because I deleted the other version in ~. I tried adding the widget to the dock and changing settings or leaving the defaults before terminating the dock, in both cases it cannot start again. I have also tried creating a regular plasma panel and leaving the widget there, and that seems to work fine even after restarting plasmashell. So the problem is related to Latte.

@Jazz Latte works just fine in my case without the widget, and I don’t see how these compositor settings can help. I did try to change them just in case but there was no difference.

That makes some sense to me: something about using event calendar with Latte. I don’t use Latte hence no problems. Sorry I can’t offer a solution, I’m just tracking the thread before I update on Monday.

Will it update without any errors?

To be 100% sure everything will be alright, try to make your own backup/restore system and make a new backup every time right before each update:


Smooth update on 7 (KDE) computers.
Thank you Manjaro team!

With this update, auto-login stopped working in Cinnamon :thinking:

I’ve got the same problem as you.
I have a temporary fix for now.

When you have the black background hold down Ctrl + Alt + F2.
Log in and put in your password.

Than type startx.
It should take you to your gui.

That’s just the temporary fix I don’t know how to fix it permanently yet.

I resolved my issue and described how did I do it here:

$ rm -rf ~/.local/share/plasma/plasmoids/org.kde.plasma.eventcalendar

After the Manjaro update, you may update eventcalendar plasmoid and restart Manjaro.

1 Like

I’m not running KDE so should I still remove the eventcalendar?

Not sure, but I’d say it worth a try to temporarily move it to another location then…

I checked to see if it is on my system.
Using the cat command to find the eventcalendar returned no such file or directory.

Then we don’t have the same issue.

No I thought we did because you had a black screen like me.
I hope to find a fix.

Thanks for your time.

I have three kernels installed, only the 5.8 show the “firmware xhci_pci” warning in the make log.

NO 5.8 kernel sees any wireless network to list. Although their setup information, including password are there. Intel 3168 wifi card. AsRock X470 Taichi board.

Kernels 5.4 and 5.7 work flawlessly.

Hi, I updated today, but with 5.8Kernel…

Update causes long waiting time (1 minute) for SDDM after startup.
After that monitorsettings are not saved.
Upower could not be started, journal is talking about USB-Ports, that are broken. Dolphin takes 30s to start (quiet similar to this https://fungos.github.io/dolphin-deep-dive/).

Rolling back to 5.7Kernel solved all this.

1 Like